LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-12-2005, 01:35 PM   #1
hfawzy
Member
 
Registered: Aug 2002
Location: Egypt
Distribution: Debian Sarge, Slackware 10.0
Posts: 163

Rep: Reputation: 30
Grub splash image


I'm trying to configure grub to have a splash image when grub loads. I've edited /boot/grub/menu.lst, and added this line : splashimage (hd0,0)/grub/image.xpm.gz.
Also, I've converted this image to 14-colors and 640x480 using imagemagick's convert utility.
Upon booting, the image has ugly colors. The colors seem "inversed", and we can hardly see this image (this is not because the image has only 14 colors, I've seen it and it looked ok)
What could be the problem ?
If that matters, I'm using ATI 3D Rage Pro graphics card (an old one).

Thanks in advance.
 
Old 08-12-2005, 03:42 PM   #2
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
This may seem silly, but I solved a similar problem by changing the line from something like you have to

splashimage=/grub/splash.xpm.gz

Now my image displays properly, can't remember where I picked this up, or even why it should work, only that it works for me... YMMV
 
Old 08-12-2005, 03:58 PM   #3
bushidozen
Member
 
Registered: Oct 2004
Posts: 215

Rep: Reputation: 30
Perhaps the image is not in the correct format. Have a look at this link, it is intended for Gentoo, but might help you.
 
Old 08-13-2005, 06:16 AM   #4
hfawzy
Member
 
Registered: Aug 2002
Location: Egypt
Distribution: Debian Sarge, Slackware 10.0
Posts: 163

Original Poster
Rep: Reputation: 30
Thanks for your replies.
Strangely, I solved this problem by converting images using The GIMP instead of using the 'convert' utility.

Regards.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB: splash image with loading bar Michele Spinolo Linux - Software 1 11-26-2004 03:51 AM
grub 0.95 splash image doralsoral Linux - Software 1 11-25-2004 11:53 PM
Grub and splash-image Harp00 Slackware 1 11-10-2004 06:23 PM
GRUB splash image and timeout not working arobinson74 Linux - General 8 11-22-2002 05:26 PM
GRUB splash image LinuxDan Linux - Distributions 6 11-14-2002 01:12 PM


All times are GMT -5. The time now is 07:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration