LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-16-2012, 06:04 PM   #1
metaf5
LQ Newbie
 
Registered: Aug 2011
Distribution: I'm kind of fond of Crunchbang...
Posts: 19

Rep: Reputation: Disabled
Dual monitors: Dead space, stretched cursor, using Openbox


Hello,
I'll try to be thorough in hopes of making it easier to answer my questions.

Basically, I have dual monitors mostly working with xrandr. They are both 1680x1050 monitors, except one is rotated 'left' so I'm using it in portrait mode. My virtual resolution then, is a rectangle of that is 2730x1680. This leaves dead zones above and below my landscape-oriented monitor, as it doesn't have as many vertical pixels as the virtual screen/portrait monitor.

My configuration is accomplished through the following lines in my ~/.Xprofile:
Code:
xrandr --output DVI-0 --left-of DVI-1 --auto --rotate left --pos 0x0
xrandr --output DVI-1 --auto --pos 1050x345
The deadzone is annoying, but it also seems as if my cursor is "stretched". It's like X doesn't know I'm using a bigger resolution, and is stuck using a cursor for a smaller resolution.

As for the deadzone, all solutions are welcome, but I was wondering:
Is there anything I could perhaps put in my openbox config to block that area from having windows placed in it? Something like the margins that are used, except on a per-monitor basis? Furthermore, is there any way to prevent my mouse from going into that region using openbox or X, or anything else?
 
Old 07-17-2012, 12:58 PM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,299

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
What I'd try if you want/need the extra height is rotating the second monitor :-). Deadzones disappear.

That said, I could get 1280x800 on screen one, and 1440x900 on screen 2 and I did it by using stuff in xorg.conf.d/ so X set itself up that way. I haven't set Virtual, or left & right, but you can do that. It's probably a better way to go. Man xorg.conf is your friend.
Quote:
Section "Screen"
<Screen 1 details>
EndSection

Section "Screen"
<Screen 2 details>
EndSection
 
Old 07-17-2012, 01:59 PM   #3
metaf5
LQ Newbie
 
Registered: Aug 2011
Distribution: I'm kind of fond of Crunchbang...
Posts: 19

Original Poster
Rep: Reputation: Disabled
I've fixed the deadzones to the extend I care about, however this big cursor is really bugging me...

It's the right size at my login screen, but then I enter my password and hit enter: For a second it flashes to DMZ-Black, size: 16 as I set it to in my "~/.xdefaults" to try and fix things, but then as my monitors are getting setup(I think lines from my .xprofile are running at this time), the cursor goes back to DMZ white, and stretched out too big.

Is there some reason X doesn't seem to want to scale it appropriately(or respect my theme choice?)

I don't really care about the theme, but it seems strange that X is using the wrong cursor. Perhaps it thinks I'm using a smaller screen than I am?
 
Old 08-04-2012, 01:51 PM   #4
ivanvodisek
LQ Newbie
 
Registered: Aug 2012
Location: croatia
Distribution: xubuntu
Posts: 22

Rep: Reputation: 0
Lightbulb

What distro U are using?
I'd try google custom mouse cursor for specific distro, draw mouse cursor in Microsoft Paint , and apply it by standard distro cursor theme chooser.

hehe, just kidding about Microsoft, they are boring. Have fun with Linux
 
Old 08-05-2012, 04:41 AM   #5
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,299

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
The big cursor thing: have you tried the option for software cursor?
 
  


Reply

Tags
cursor, openbox, x11


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Openbox won't show cursor benc1213 Arch 6 07-06-2011 11:38 PM
help - dual monitor in stretched mode michaewlewis Linux - Hardware 10 07-09-2007 05:53 PM
Using dual monitors/dual heads displays a black screen (Fedora 6) ttnunam Linux - General 4 04-21-2007 12:50 AM
Setting up Dual Monitors on GeForce 6600GT dual DVI card. monkiidansu Linux - Hardware 1 09-29-2005 02:21 PM
Openbox with two monitors saon Linux - Software 0 01-22-2005 02:13 PM


All times are GMT -5. The time now is 05:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration