LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Dual monitors: Dead space, stretched cursor, using Openbox (http://www.linuxquestions.org/questions/linux-general-1/dual-monitors-dead-space-stretched-cursor-using-openbox-4175417052/)

metaf5 07-16-2012 06:04 PM

Dual monitors: Dead space, stretched cursor, using Openbox
 
Hello,
I'll try to be thorough in hopes of making it easier to answer my questions.

Basically, I have dual monitors mostly working with xrandr. They are both 1680x1050 monitors, except one is rotated 'left' so I'm using it in portrait mode. My virtual resolution then, is a rectangle of that is 2730x1680. This leaves dead zones above and below my landscape-oriented monitor, as it doesn't have as many vertical pixels as the virtual screen/portrait monitor.

My configuration is accomplished through the following lines in my ~/.Xprofile:
Code:

xrandr --output DVI-0 --left-of DVI-1 --auto --rotate left --pos 0x0
xrandr --output DVI-1 --auto --pos 1050x345

The deadzone is annoying, but it also seems as if my cursor is "stretched". It's like X doesn't know I'm using a bigger resolution, and is stuck using a cursor for a smaller resolution.

As for the deadzone, all solutions are welcome, but I was wondering:
Is there anything I could perhaps put in my openbox config to block that area from having windows placed in it? Something like the margins that are used, except on a per-monitor basis? Furthermore, is there any way to prevent my mouse from going into that region using openbox or X, or anything else?

business_kid 07-17-2012 12:58 PM

What I'd try if you want/need the extra height is rotating the second monitor :-). Deadzones disappear.

That said, I could get 1280x800 on screen one, and 1440x900 on screen 2 and I did it by using stuff in xorg.conf.d/ so X set itself up that way. I haven't set Virtual, or left & right, but you can do that. It's probably a better way to go. Man xorg.conf is your friend.
Quote:

Section "Screen"
<Screen 1 details>
EndSection

Section "Screen"
<Screen 2 details>
EndSection

metaf5 07-17-2012 01:59 PM

I've fixed the deadzones to the extend I care about, however this big cursor is really bugging me...

It's the right size at my login screen, but then I enter my password and hit enter: For a second it flashes to DMZ-Black, size: 16 as I set it to in my "~/.xdefaults" to try and fix things, but then as my monitors are getting setup(I think lines from my .xprofile are running at this time), the cursor goes back to DMZ white, and stretched out too big.

Is there some reason X doesn't seem to want to scale it appropriately(or respect my theme choice?)

I don't really care about the theme, but it seems strange that X is using the wrong cursor. Perhaps it thinks I'm using a smaller screen than I am?

ivanvodisek 08-04-2012 01:51 PM

What distro U are using?
I'd try google custom mouse cursor for specific distro, draw mouse cursor in Microsoft Paint :rolleyes:, and apply it by standard distro cursor theme chooser.

hehe, just kidding about Microsoft, they are boring. Have fun with Linux :)

business_kid 08-05-2012 04:41 AM

The big cursor thing: have you tried the option for software cursor?


All times are GMT -5. The time now is 07:17 PM.