LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 06-24-2002, 05:53 PM   #1
its4
LQ Newbie
 
Registered: Jun 2002
Distribution: Redhat
Posts: 9

Rep: Reputation: 0
dual boot - blinking cursor after selecting LINUX at win2k loader


Could someone please help me figure out what I'm doing wrong here? I have found references to the "dual boot blinking cursor" problem, but no solution.

I set about configuring my PC to dual boot between Win2K and Linux (7.2). This is what I've done so far:

I started with a new Dell 8200 with one 40GB hard drive installed running Win2K , I purchased a 2nd 40GB hard drive and installed it. I then booted Win2K and used partition magic 7.0 to create the following partitions on the 2nd drive:


G: Fat32 1GB primary
*. Extended 18GB primary
*.SWAPSPACE 500MB logical
*.Ext2 17.5GB logical
F: NTFS 19GB primary

I then booted off the RedHat 7.2 install CD and configured the install as follows:

Linux swap -> /dev/hdb5
Linux "/" -> /dev/hdb6

Use LILO as the boot loader
Install boot loader record on
/dev/hdb6 First sector of boot partition

The install went normally and I was able at this point to boot from the boot floppy created during the install setup just fine.

I then wanted to get the Win2K bootloader to allow me to dual-boot into either Windows or Linux, so I performed the following steps:

booted linux
dd if=/dev/hdb6 of=/bootsect.lnx bs=512 count=1
inserted a formated floppy
mount -t msdos /dev/fd0 /mnt
cp /bootsect.lnx /mnt
umount /mnt

reboot to win2k
copy a:\bootsect.lnx c:\
added "c:\bootsect.lnx="LINUX" to end of c:\boot.ini
attrib +s +h c:\bootsect.lnx

Now, when I boot window, I get the boot menu that specifies windows 2000 or LINUX. If I select LINUX, the disk light goes on for about 10 seconds then stops, but the blinking cursor remains in the top-left corner of the display and nothing happens.

By all accounts this has been done successfully before, but I've obviously missed something.

All advice appreciated - Thanks
 
Old 06-24-2002, 09:53 PM   #2
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
I don't know if this will solve the problem. Boot into linux using your boot disk. Run fdisk -l /dev/hdb and make sure /dev/hdb6 is the root ' / ' partition. If it is, check /etc/lilo.conf file and make sure these two lines are in there:

boot=/dev/hdb6
root=/dev/hdb6

If it's not hdb6, then change the two lines above to the correct partition.

Next, run as root /sbin/lilo. Then repeat all the steps that you used before to add linux to w2k's boot menu.

Last edited by linuxcool; 06-24-2002 at 09:55 PM.
 
Old 06-25-2002, 10:46 AM   #3
its4
LQ Newbie
 
Registered: Jun 2002
Distribution: Redhat
Posts: 9

Original Poster
Rep: Reputation: 0
fdisk returns the following information:

Device Boot Start End Blocks Id System
/dev/hdb1 2433 4865 19543041 7 HPFS/NTFS
/dev/hdb2 131 2432 18490815 f Win95 Ext'd (LBA)
/dev/hdb3 1 130 1044193+ Win95 FAT32
/dev/hdb5 131 193 506016 82 Linux swap
/dev/hdb6 * 194 2432 17084736 83 Linux


Lilo.conf contains:

prompt
timeout=50
default=linux
boot=/dev/hdb6
map=/boot/map
install=/boot/boot.b
messag/boot/message
linear

image=/boot/vmlinuz=2.4.7.10
label=linux
read-only
root=/dev/hdb6
append="hdc=ide-scsi"

other=/dev/hdb3
optional
label=DOS

Both the "boot=/dev/hdb6" and the "root=/dev/hdb6" lines are present, although not in the same section of the file.

I don't remember explicitly running /sbin/lilo during the install process. Is this something that I should have done?

Thanks
 
Old 06-25-2002, 10:49 AM   #4
its4
LQ Newbie
 
Registered: Jun 2002
Distribution: Redhat
Posts: 9

Original Poster
Rep: Reputation: 0
I went ahead and ran /sbin/lilo and got the following message:

Warning: /dev/hdb6 is not on the first disk
Fatal: sector 21460897 too large for linear mode (try 'lba32' instead)


Do you know what this is telling me?

Thanks again.
 
Old 06-25-2002, 10:34 PM   #5
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
According to here, lilo is just letting you know that it's not being installed on the first drive. lilo expects to be on the first drive so that it can boot linux. In this case, you don't want it on the first drive. So, just ignore the error.

The second one needs to be taken care of. It says to use lba32 instead of linear in the /etc/lilo.conf file. So, edit lilo.conf and replace linear with lba32. Then run /sbin/lilo and see if you get any errors except for the warning about not being on the first drive.

If you only get the warning about not being on the first drive, then repeat the steps to install linux in the boot menu of w2k.

Is the fat32 partition on your linux drive for data or does it have the msdos operating system on it? If it's just for data, then you don't need these three lines at the end of the lilo.conf file.

other=/dev/hdb3
optional
label=DOS




Last edited by linuxcool; 06-25-2002 at 10:40 PM.
 
Old 06-25-2002, 11:44 PM   #6
its4
LQ Newbie
 
Registered: Jun 2002
Distribution: Redhat
Posts: 9

Original Poster
Rep: Reputation: 0
Problem solved.

Linuxcool, thank you very much for the help. As it turns out, your help got me closer to where I wanted to be. Instead of completely hanging, I was getting the first "L" of lilo printed (without any error codes) before it hung.

I spent several hours reading the results of a "lilo hangs" google search and read several places that LILO uses the bios to load the 2nd stage boot loader. Well guess what? I had forgotten to enable the 2nd hdd in my bios setup. As soon as I did that it all works as advertised. I'm very happy.

Thanks again.
 
Old 06-25-2002, 11:50 PM   #7
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
You're welcome.
Glad you solved the problem.
 
Old 06-26-2002, 02:06 AM   #8
BittaBrotha
Member
 
Registered: Jan 2002
Location: Third Stone from the Sun
Distribution: Debian Sid, SourceMage 0.9.5, & To be Continued on a TP
Posts: 800

Rep: Reputation: 31
Just remember to do this again; "dd if=/dev/hdb6 of=/bootsect.lnx bs=512 count=1" each time you upgrade/update your kernel also.

Just a thought.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux console mono-color, blinking block cursor introuble Linux - General 1 06-24-2005 07:08 PM
grub (blinking cursor) - won't boot php4u Fedora - Installation 2 04-04-2005 11:23 AM
Blank screen with blinking cursor on boot (yoper) Fisslefink Linux - Newbie 3 02-15-2005 06:16 PM
Cannot dual boot win2k RH linux jm_rodrig Linux - Laptop and Netbook 6 01-06-2005 08:32 PM
Dual Boot Using Win2k Boot loader Nhai Saiyori Linux - General 3 11-23-2002 12:20 PM


All times are GMT -5. The time now is 01:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration