LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 01-04-2006, 09:29 AM   #1
tekhed21
LQ Newbie
 
Registered: Jan 2006
Location: USA
Distribution: RHEL 4 & FC4
Posts: 2

Rep: Reputation: 0
RHEL 4 RPM package dependency problem


Hello All,
I am currently using MRTG for network monitoring and have recently started using RRDTOOL. I'm getting familiar with how to collect the data and graph using just RRDTOOL. However, writing all the scripts and keeping track of all the files are too cumbersome and therefore I wish to try my hand at a frontend tool. I've chosen to try Cacti. I'm sure some of you are aware of this tool. Anyway, I am using a RHEL 4 machine with the following RPM packages installed;

httpd-2.0.52-19.ent
php-4.3.9-3.9
mysql-4.1.12-3.RHEL4.1
net-snmp-5.1.2-11.EL4.6

and ofcourse I have compiled RRDtool 1.2.11 which I have working on my machine.

Anyway, here is the problem. Forgive me for any newbie questions as I am "new" to network monitoring and Linux administration but greatly appreciate assistance.

Here are the package requirements per the Cacti site...


RRDTool 1.0.48 or greater

MySQL 3.23 or greater, 4.0.20d or greater highly recommended for advanced features

PHP 4.1 or greater, 4.3.6 or greater highly recommended for advanced features

Packages for RPM-based Operating Systems

httpd
php
php-mysql
php-snmp
mysql
mysql-server
net-snmp

Ok, so the only ones that I don't have are;
php-mysql
php-snmp

So I have downloaded the following .rpm packages to my machine:
php-mysql-4.3.9-3.i386.rpm
php-snmp-4.3.9-3.i386.rpm

Now, when I try to install these packages here is what I getdependency error ofcourse)

rpm -ivh php-mysql-4.3.9-3.i386.rpm
warning: php-mysql-4.3.9-3.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
php = 4.3.9-3 is needed by php-mysql-4.3.9-3.i386

rpm -ivh php-snmp-4.3.9-3.i386.rpm
warning: php-snmp-4.3.9-3.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
php = 4.3.9-3 is needed by php-snmp-4.3.9-3.i386


So I check the version of php that I have and I get this:

rpm -qa | grep "php"
php-4.3.9-3.9

-------------------

My question is, why am I getting a dependency error when it appears that I have the correct php version installed? What steps can I take to find out why these packages are not installing?

I greatly appreciate any input you could provide.
 
Old 01-05-2006, 03:21 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Carefully read again;

php = 4.3.9-3 is needed by php-snmp-4.3.9-3.i386
rpm -qa | grep "php"
php-4.3.9-3.9

It looks like the rpm's where created to work with php-4.3.9-3 exclusively and you have php-4.3.9-3.9 (there is a difference).

Visit; http://rpm.pbone.net/ both php-snmp-4.3.9-3.9.i386.rpm and
php-mysql-4.3.9-3.9.i386.rpm are available.

Or as a suggestion download the .src.rpms and rebuild the binaries after modifing the spec files, if needed.
 
Old 01-06-2006, 01:18 PM   #3
tekhed21
LQ Newbie
 
Registered: Jan 2006
Location: USA
Distribution: RHEL 4 & FC4
Posts: 2

Original Poster
Rep: Reputation: 0
Lenard,
Thanks for the input. I went to the site you mentioned and downloaded the correct rpm packages and it worked just fine.

Travis
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Package problem while installing RHEL 3 slashrsm Red Hat 2 04-21-2005 12:56 PM
There was a package dependency problem Kensai Fedora 3 02-15-2004 06:02 PM
RPM Dependency Problem JoAnywhere Linux - Software 3 10-30-2003 12:54 PM
Package dependency problem (glibc) jizlobber Linux - Newbie 1 10-08-2003 02:54 PM
possible to downgrade a package? (rpm dependency hell) Goog Linux - Software 3 05-26-2003 09:13 AM


All times are GMT -5. The time now is 05:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration