LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Enterprise (http://www.linuxquestions.org/questions/linux-enterprise-47/)
-   -   RHEL 4 RPM package dependency problem (http://www.linuxquestions.org/questions/linux-enterprise-47/rhel-4-rpm-package-dependency-problem-399450/)

tekhed21 01-04-2006 09:29 AM

RHEL 4 RPM package dependency problem
 
Hello All,
I am currently using MRTG for network monitoring and have recently started using RRDTOOL. I'm getting familiar with how to collect the data and graph using just RRDTOOL. However, writing all the scripts and keeping track of all the files are too cumbersome and therefore I wish to try my hand at a frontend tool. I've chosen to try Cacti. I'm sure some of you are aware of this tool. Anyway, I am using a RHEL 4 machine with the following RPM packages installed;

httpd-2.0.52-19.ent
php-4.3.9-3.9
mysql-4.1.12-3.RHEL4.1
net-snmp-5.1.2-11.EL4.6

and ofcourse I have compiled RRDtool 1.2.11 which I have working on my machine.

Anyway, here is the problem. Forgive me for any newbie questions as I am "new" to network monitoring and Linux administration but greatly appreciate assistance.

Here are the package requirements per the Cacti site...


RRDTool 1.0.48 or greater

MySQL 3.23 or greater, 4.0.20d or greater highly recommended for advanced features

PHP 4.1 or greater, 4.3.6 or greater highly recommended for advanced features

Packages for RPM-based Operating Systems

httpd
php
php-mysql
php-snmp
mysql
mysql-server
net-snmp

Ok, so the only ones that I don't have are;
php-mysql
php-snmp

So I have downloaded the following .rpm packages to my machine:
php-mysql-4.3.9-3.i386.rpm
php-snmp-4.3.9-3.i386.rpm

Now, when I try to install these packages here is what I get:(dependency error ofcourse)

rpm -ivh php-mysql-4.3.9-3.i386.rpm
warning: php-mysql-4.3.9-3.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
php = 4.3.9-3 is needed by php-mysql-4.3.9-3.i386

rpm -ivh php-snmp-4.3.9-3.i386.rpm
warning: php-snmp-4.3.9-3.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
php = 4.3.9-3 is needed by php-snmp-4.3.9-3.i386


So I check the version of php that I have and I get this:

rpm -qa | grep "php"
php-4.3.9-3.9

-------------------

My question is, why am I getting a dependency error when it appears that I have the correct php version installed? What steps can I take to find out why these packages are not installing?

I greatly appreciate any input you could provide. ;)

Lenard 01-05-2006 03:21 PM

Carefully read again;

php = 4.3.9-3 is needed by php-snmp-4.3.9-3.i386
rpm -qa | grep "php"
php-4.3.9-3.9

It looks like the rpm's where created to work with php-4.3.9-3 exclusively and you have php-4.3.9-3.9 (there is a difference).

Visit; http://rpm.pbone.net/ both php-snmp-4.3.9-3.9.i386.rpm and
php-mysql-4.3.9-3.9.i386.rpm are available.

Or as a suggestion download the .src.rpms and rebuild the binaries after modifing the spec files, if needed.

tekhed21 01-06-2006 01:18 PM

Lenard,
Thanks for the input. I went to the site you mentioned and downloaded the correct rpm packages and it worked just fine.

Travis ;)


All times are GMT -5. The time now is 04:58 AM.