LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 06-15-2009, 04:32 PM   #1
SteveInTallyFL
Member
 
Registered: May 2008
Location: Tallahassee, FL
Distribution: RHEL4, RHEL 5, OEL4, OEL5
Posts: 58

Rep: Reputation: 17
RHEL 4: Need to turn off multipath and use IBM RDAC.


The builder of this server installed device-mapper-multipath. It is thrashing our IBM DS4000 horribly. I want to turn this off and install the RDAC drivers provided by IBM. But the /etc/multipath.conf is virtually all commented out EXCEPT for "blacklist { devnode "*"}". Meanwhile multipath device list shows the following:
]# multipath -d -l
mpath1 (3600a0b800018cf3c000028aa475ffd51)
[size=200 GB][features="0"][hwhandler="0"]
\_ round-robin 0 [active]
\_ 1:0:0:41 sdc 8:32 [active]
\_ round-robin 0 [enabled]
\_ 1:0:1:41 sde 8:64 [active]
\_ round-robin 0 [enabled]
\_ 1:0:2:41 sdg 8:96 [active]
\_ round-robin 0 [enabled]
\_ 1:0:3:41 sdi 8:128 [active]
\_ round-robin 0 [enabled]
\_ 2:0:0:41 sdk 8:160 [active]
\_ round-robin 0 [enabled]
\_ 2:0:1:41 sdm 8:192 [active]

mpath0 (3600a0b800018cf3c00002841475e9cc7)
[size=60 GB][features="0"][hwhandler="0"]
\_ round-robin 0 [active]
\_ 1:0:0:40 sdb 8:16 [active]
\_ round-robin 0 [enabled]
\_ 1:0:1:40 sdd 8:48 [active]
\_ round-robin 0 [enabled]
\_ 1:0:2:40 sdf 8:80 [active]
\_ round-robin 0 [enabled]
\_ 1:0:3:40 sdh 8:112 [active]
\_ round-robin 0 [enabled]
\_ 2:0:0:40 sdj 8:144 [active]
\_ round-robin 0 [enabled]
\_ 2:0:1:40 sdl 8:176 [active]

Where is this configured? Besides doing a "chkconfig -multipathd off" and commenting out the two device specs in the /etc/fstab before the next reboot, what do need to do to turn this off?
 
Old 06-16-2009, 09:31 PM   #2
TBC Cosmo
Member
 
Registered: Feb 2004
Location: NY
Distribution: Fedora 10, CentOS 5.4, Debian 5 Sparc64
Posts: 355

Rep: Reputation: 43
Remove the device-mapper-multipath package and reboot. Otherwise the module will always be loaded. Or you could blacklist that. But if you're going to use RDAC, no need for dm-multipath at all. Easy enough to re-install later.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian etch, IBM SAN 4700, qlogic. How to change multipath to active /passive? vmm_sys Linux - Enterprise 4 08-16-2010 03:08 AM
How To Turn On RewriteEngine in RHEL phpserver Linux - Server 2 02-27-2009 10:46 AM
RHEL 5 on IBM x3850 doju Red Hat 3 12-17-2007 10:20 AM
RDAC for ubuntu colincraig127 Linux - Server 0 10-26-2007 03:02 PM
LXer: IBM vs. SCO: Now It's IBM's Turn LXer Syndicated Linux News 0 02-23-2006 02:46 PM


All times are GMT -5. The time now is 07:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration