LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 12-23-2008, 09:56 AM   #1
saivin
Member
 
Registered: Dec 2008
Location: Bengaluru, India
Distribution: CentOS, openSUSE, Mandriva, Slackware
Posts: 111

Rep: Reputation: 19
gtk+ icon theme error in PCManFM


Hi all,
I'm using JWM and PCManFM on my Debian system. When I click on PCManFM, I get the following error:
Quote:
GTK+ icon them is not properly set

This usually means you don't have an XSETTINGS manager running. Desktop environment like GNOME or XFCE automatically execute their XSETTING managers like gnome-settings-daemon or xfce-mcs-manager.

If you don't use these desktop environments, you have two choices:
1. run an XSETTINGS manager, or
2. simply specify an icon theme in ~/.gtkrc-2.0. For ex: to use the Tango ion theme andd a line: gtk-icon-theme-name="Tango" in your ~/.gtkrc-2.0. (create it if no such file)
But there is no error when I open Nautilus.

There is no .gtkrc* file in my home directory. There is only a 'im-multipress.conf' file in the /etc/gtk-2.0/. There are many gtkrc files in /etc/gtk/ but i didnot understand them and there was no mention of gtk-icon-theme-name in them anyway.

As suggested in the error msg, I also tried creating ~/.gtkrc-2.0 and put the line: gtk-icon-theme-name="Tango" there. Did you say dumb?

What can I try? A link would also be appreciated.

Cheers,
SV

Last edited by saivin; 12-23-2008 at 10:10 AM.
 
Old 12-23-2008, 04:37 PM   #2
Su-Shee
Member
 
Registered: Sep 2007
Location: Berlin
Distribution: Slackware
Posts: 509

Rep: Reputation: 41
Hm, strange - PcManFM doesn't depend on any settings manager.

To set up your gtk-theme stuff properly, try this:

* edit your .gtkrc-2.0
* add two lines:

include "/home/you/.themes/SomeTheme/gtk-2.0/gtkrc" # actual theme to be used
include "/home/you/.gtkrc.mine"

In a .gtkrc.mine, you add:

gtk-icon-theme-name="Iris"
gtk-font-name="Bitstream Vera Sans 8"

and whatever else you might like ...

.gtkrc-2.0 is the default file for all kinds of gtk-theme configuration applications and is newly written, overwritten or generated. By convention, all tools leave the include line for "gtkrc.mine" untouched and there should all your stuff go into.

And Tango is supposed to be THE default icon theme, you shouldn't even have to load it by hand.

Nautilus runs with the gnome settings manager which manages loading gtk stuff.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
icon-naming-utils not getting picked up during gnome-icon-theme... rendezvous123 Linux - Software 1 08-05-2007 12:42 AM
Installing icon theme? i have a index.theme and index.desktop, no directions! mr_coffee Linux - Newbie 2 01-25-2006 02:45 PM
kde / gtk cursor-theme / theme issue - gentoo imperfect Linux - Newbie 1 01-08-2006 06:09 PM
gtk theme switch - libpixmap.so error? kule Linux - Software 2 04-02-2005 04:16 PM
garnome 2.8 install gnome-icon-theme error XsuX Linux - Software 1 10-26-2004 12:16 AM


All times are GMT -5. The time now is 04:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration