LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   gtk+ icon theme error in PCManFM (http://www.linuxquestions.org/questions/linux-desktop-74/gtk-icon-theme-error-in-pcmanfm-692486/)

saivin 12-23-2008 08:56 AM

gtk+ icon theme error in PCManFM
 
Hi all,
I'm using JWM and PCManFM on my Debian system. When I click on PCManFM, I get the following error:
Quote:

GTK+ icon them is not properly set

This usually means you don't have an XSETTINGS manager running. Desktop environment like GNOME or XFCE automatically execute their XSETTING managers like gnome-settings-daemon or xfce-mcs-manager.

If you don't use these desktop environments, you have two choices:
1. run an XSETTINGS manager, or
2. simply specify an icon theme in ~/.gtkrc-2.0. For ex: to use the Tango ion theme andd a line: gtk-icon-theme-name="Tango" in your ~/.gtkrc-2.0. (create it if no such file)
But there is no error when I open Nautilus.

There is no .gtkrc* file in my home directory. There is only a 'im-multipress.conf' file in the /etc/gtk-2.0/. There are many gtkrc files in /etc/gtk/ but i didnot understand them and there was no mention of gtk-icon-theme-name in them anyway.

As suggested in the error msg, I also tried creating ~/.gtkrc-2.0 and put the line: gtk-icon-theme-name="Tango" there. Did you say dumb?

What can I try? A link would also be appreciated.

Cheers,
SV

Su-Shee 12-23-2008 03:37 PM

Hm, strange - PcManFM doesn't depend on any settings manager.

To set up your gtk-theme stuff properly, try this:

* edit your .gtkrc-2.0
* add two lines:

include "/home/you/.themes/SomeTheme/gtk-2.0/gtkrc" # actual theme to be used
include "/home/you/.gtkrc.mine"

In a .gtkrc.mine, you add:

gtk-icon-theme-name="Iris"
gtk-font-name="Bitstream Vera Sans 8"

and whatever else you might like ...

.gtkrc-2.0 is the default file for all kinds of gtk-theme configuration applications and is newly written, overwritten or generated. By convention, all tools leave the include line for "gtkrc.mine" untouched and there should all your stuff go into.

And Tango is supposed to be THE default icon theme, you shouldn't even have to load it by hand.

Nautilus runs with the gnome settings manager which manages loading gtk stuff.


All times are GMT -5. The time now is 10:16 AM.