LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices

Reply
 
Search this Thread
Old 06-09-2012, 05:26 PM   #1
sosoy77
LQ Newbie
 
Registered: Jan 2008
Posts: 9

Rep: Reputation: 0
Failed to emerge app-text/recode-3.6_p17-r2


hi everyone
i'm trying to install gnome to my new funtoo but when i get to recode it stops,this is what i get:



Quote:
# emerge gnome

* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!

>>> Verifying ebuild manifests
>>> Running pre-merge checks for net-misc/networkmanager-0.9.4.0-r2
openpty failed: 'out of pty devices'
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found sources for kernel version:
* 3.0.21-sysrescue-std302
* Checking for SYSFS_DEPRECATED support ... [ ok ]
>>> Running pre-merge checks for gnome-base/gnome-core-libs-3.2.1
* See http://www.gentoo.org/proj/en/deskto....2-upgrade.xml
* for the Gentoo GNOME 3.2 upgrade guide.

>>> Starting parallel fetch

>>> Emerging (1 of 232) app-text/recode-3.6_p17-r2
* recode-3.6.tar.gz RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* recode_3.6-17.diff.gz RMD160 SHA1 SHA256 size ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking recode-3.6.tar.gz to /var/tmp/portage/app-text/recode-3.6_p17-r2/work
>>> Unpacking recode_3.6-17.diff.gz to /var/tmp/portage/app-text/recode-3.6_p17-r2/work
>>> Source unpacked in /var/tmp/portage/app-text/recode-3.6_p17-r2/work
>>> Preparing source in /var/tmp/portage/app-text/recode-3.6_p17-r2/work/recode-3.6 ...
* QA Notice: The 'hasq' function is deprecated (replaced by 'has')
* Applying recode-3.6-gettextfix.diff ... [ ok ]
* Applying recode-3.6-as-if.patch ... [ ok ]
* Applying recode_3.6-17.diff ... [ ok ]
* Running eautoreconf in '/var/tmp/portage/app-text/recode-3.6_p17-r2/work/recode-3.6' ...
* Running libtoolize --install --copy --force --automake ... [ ok ]
* Running aclocal -I m4 ... [ !! ]

* Failed Running aclocal !
*
* Include in your bugreport the contents of:
*
* /var/tmp/portage/app-text/recode-3.6_p17-r2/temp/aclocal.out

* ERROR: app-text/recode-3.6_p17-r2 failed (prepare phase):
* Failed Running aclocal !
*
* Call stack:
* ebuild.sh, line 85: Called src_prepare
* environment, line 3104: Called eautoreconf
* environment, line 890: Called eaclocal
* environment, line 797: Called autotools_run_tool '--at-m4flags' 'aclocal' '-I' 'm4'
* environment, line 667: Called die
* The specific snippet of code:
* die "Failed Running $1 !";
*
* If you need support, post the output of `emerge --info '=app-text/recode-3.6_p17-r2'`,
* the complete build log and the output of `emerge -pqv '=app-text/recode-3.6_p17-r2'`.
/usr/lib64/portage/bin/isolated-functions.sh: line 214: wait: `Failed Running aclocal !': not a pid or valid job spec
* The complete build log is located at '/var/tmp/portage/app-text/recode-3.6_p17-r2/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/app-text/recode-3.6_p17-r2/temp/environment'.
* Working directory: '/var/tmp/portage/app-text/recode-3.6_p17-r2/work/recode-3.6'
* S: '/var/tmp/portage/app-text/recode-3.6_p17-r2/work/recode-3.6'

>>> Failed to emerge app-text/recode-3.6_p17-r2, Log file:

>>> '/var/tmp/portage/app-text/recode-3.6_p17-r2/temp/build.log'

* Messages for package gnome-base/gnome-core-libs-3.2.1:

* See http://www.gentoo.org/proj/en/deskto....2-upgrade.xml
* for the Gentoo GNOME 3.2 upgrade guide.

* Messages for package app-text/recode-3.6_p17-r2:

* Failed Running aclocal !
*
* Include in your bugreport the contents of:
*
* /var/tmp/portage/app-text/recode-3.6_p17-r2/temp/aclocal.out
* ERROR: app-text/recode-3.6_p17-r2 failed (prepare phase):
* Failed Running aclocal !
*
* Call stack:
* ebuild.sh, line 85: Called src_prepare
* environment, line 3104: Called eautoreconf
* environment, line 890: Called eaclocal
* environment, line 797: Called autotools_run_tool '--at-m4flags' 'aclocal' '-I' 'm4'
* environment, line 667: Called die
* The specific snippet of code:
* die "Failed Running $1 !";
*
* If you need support, post the output of `emerge --info '=app-text/recode-3.6_p17-r2'`,
* the complete build log and the output of `emerge -pqv '=app-text/recode-3.6_p17-r2'`.
* The complete build log is located at '/var/tmp/portage/app-text/recode-3.6_p17-r2/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/app-text/recode-3.6_p17-r2/temp/environment'.
* Working directory: '/var/tmp/portage/app-text/recode-3.6_p17-r2/work/recode-3.6'
* S: '/var/tmp/portage/app-text/recode-3.6_p17-r2/work/recode-3.6'
little bit of help will be greatly appreciated
thanx
 
Old 06-11-2012, 11:01 AM   #2
Fort2k
LQ Newbie
 
Registered: Jun 2012
Posts: 1

Rep: Reputation: Disabled
i had same problem

automake generate error message
- autom4te-2.69 error automatic de-ANSI-fication support has bin removed

sys-devel/automake downgrade from 1.12.1 to 1.11.5 resolve this problem

for gentoo in file /etc/portage/portage.mask add string
=sys-devel/automake-1.12.1
 
Old 06-12-2012, 02:24 AM   #3
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,043

Rep: Reputation: 375Reputation: 375Reputation: 375Reputation: 375
That's an invasive workaround. Other ebuilds will want an upper version. The proper fix would be forcing the right automake version in the ebuild. They are slotted, so you can have many.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Failed to emerge at installation cristi92b Gentoo 2 02-11-2012 04:06 PM
[SOLVED] cant emerge samba : Failed to emerge sys-libs/tdb-1.2.1 Adol Gentoo 2 03-09-2011 12:51 PM
failed to emerge amsn 0.97.2 the_rastaman Gentoo 2 10-21-2010 10:31 PM
Failed to emerge app-admin/python-updater-0.7-r1 godi Gentoo 2 02-22-2010 05:21 AM
emerge app-emulation/vmware-workstation UltimatePower Linux - Software 2 01-21-2005 11:55 AM


All times are GMT -5. The time now is 08:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration