LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices

Reply
 
Search this Thread
Old 02-19-2010, 04:42 PM   #1
godi
LQ Newbie
 
Registered: Feb 2010
Posts: 2

Rep: Reputation: 0
Failed to emerge app-admin/python-updater-0.7-r1


hi everyone,

while trying to emerge tomcat got the error:

ERROR: app-admin/python-updater-0.7-r1 failed.
Call stack:
ebuild.sh, line 48: Called src_install
environment, line 2224: Called die
The specific snippet of code:
doman ${PN}.1 || die "doman failed";
The die message:
doman failed

any ideas?

thanks,

godi
 
Old 02-19-2010, 05:57 PM   #2
godi
LQ Newbie
 
Registered: Feb 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Smile

figured it out: needed to emerge bash as the old version 'perceived' a syntax error where there was none
 
Old 02-22-2010, 04:21 AM   #3
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,036

Rep: Reputation: 372Reputation: 372Reputation: 372Reputation: 372
If it perceived a syntax error then either there was one or it's a bug in bash.

Some errors might not be that obvious, portage is quite complex and ebuilds inherit code from other places like eclasses, so the source of the error is not necessarily there. Also, the last part of the error with the die message is usually not too informative.
 
  


Reply

Tags
emerge, gentoo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to run python-updater (need to unmask a package) Genji Linux - Distributions 1 12-14-2008 09:19 AM
python: can't open file 'emerge\bin\emerge.py' Virtuality Programming 5 01-30-2008 01:23 PM
emerge dependency problem with Python docchang Linux - Software 0 09-20-2006 09:41 PM
Gentoo emerge kde verification failed Maverick1182 Linux - Newbie 1 07-24-2006 04:06 AM
emerge app-emulation/vmware-workstation UltimatePower Linux - Software 2 01-21-2005 10:55 AM


All times are GMT -5. The time now is 02:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration