Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Fedora > Fedora - Installation
User Name
Fedora - Installation This forum is for the discussion of installation issues with Fedora.


  Search this Thread
Old 08-02-2005, 04:43 PM   #1
LQ Newbie
Registered: Aug 2005
Posts: 9

Rep: Reputation: 0
Unhappy kmodule: error while loading shared library

I installed Fedora Core 4 and when it got to the last part, Post install, it hung at 50%. I rebooted it and had to use the rescue disk to install grub in the MBR. Now when it boots I get to the startup scripts and many of them fail because the executables can not open It states permission denied. I checked the permissions and ran ldconfig and everything looks fine. Also when I boot up in rescue mode and do a chroot to /mnt/sysimage. The executables work find. I put a line in the rc.sysinit file to start a shell before running the start up scripts to recreate the error - sure enough when I run kmodule I get the error. When I run ldd on kmodule it gives me the following:

ldd => /lib/libiefjewkfelf ( I can't remember ) => not found

I noticed there was no line in the output for I invoked and then kmodule worked fine.

What could I be doing wrong?

Thanks in advance,

Old 08-04-2005, 08:09 AM   #2
LQ Newbie
Registered: Aug 2005
Posts: 1

Rep: Reputation: 0
I just had the same troubles.
First I used the rescuedisc, to get into the system, and switched the default runlevel to 1

Well, the system started in runlevel 1. First smile.

After diabling selinux in /etc/selinux/config I actually got the system running even in runlevel 3.

I hope this helps.

Old 08-04-2005, 09:24 AM   #3
LQ Newbie
Registered: Aug 2005
Posts: 9

Original Poster
Rep: Reputation: 0

Thanks for your reply. I will try this.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while loading shared library : dhanilshah Linux - Software 5 08-18-2011 07:38 AM
error while loading shared libraries: cannot open shared object file: Franziss Linux - Newbie 10 06-28-2010 05:47 AM
error while loading shared library bonniehandi Linux - Newbie 2 11-18-2005 11:43 PM
MAndrake 10 library problem : error while loading shared libraries falojah Linux - Software 13 09-22-2005 06:18 AM
error while loading shared libraries: cannot open shared object file putquery8581 Linux - Software 1 10-01-2004 07:03 AM

All times are GMT -5. The time now is 11:44 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration