LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 12-16-2004, 08:29 PM   #1
acarpetknight
LQ Newbie
 
Registered: Dec 2004
Distribution: Fedora Core 3
Posts: 2

Rep: Reputation: 0
Stripes & Crash on Xorg


Hi folks,

Fairly newbesque here, so forgive any ignorance. I just upgraded my Dell Dimension L733r from RH9 to Fedora Core 3. I'm having major headaches getting the graphical interface up and running -- if I go in runlevel 3, all is fine and dandy; runlevel 5 leads to pinstripes and a complete crash. Can't ctrl-alt-backspace, can't ctrl-alt-delete, can't even push capslock.

I figured this was a resolution issue, and sure enough the monitor works fine at 1024 x 768 -- but I *know* that I ran with 1280x1024 in RH9, it works fine at that resolution when I dual boot into Windows 2000. Further, the refresh rate is the same as in Win2k. Can't figure out what's getting this thing down.

The graphics card is an Intel i810; monitor is a LiquidVideo (who? exactly) 17" Flat Panel TFT-LCD. I've rummaged and rummaged but can't find any documentation with the monitor as to what refresh/sync rates it wants to be run at.

Excerpt from my xorg.conf below.


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "CMC 17 AD"
DisplaySize 340 270
HorizSync 30.0 - 80.0
VertRefresh 60.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 810"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
Subsection "Display"
Videoport 0 0
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x800"
EndSubSection
EndSection

...as I said, if I remove the "1280x1024," I can launch X fine with a 1024x768 resolution.

Thanks!
 
Old 12-19-2004, 07:13 PM   #2
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 1,753

Rep: Reputation: 189Reputation: 189
This may not be ideal but,
Try using a depth of 8 instead of 16 and see if you can get that 1280X1024

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16 <---------------------------------- here
Subsection "Display"
Videoport 0 0
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x800"
EndSubSection
EndSection

The color won't be as good but you may get the resolution that you want.

Back up xorg someplace safe when editing it in case you mess it up so bad that you need to overwrite it.
 
Old 12-19-2004, 09:29 PM   #3
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
This thread has a link to an updated 810 driver which should correct your problems.
http://www.linuxquestions.org/questi...hreadid=253445
 
Old 12-20-2004, 07:50 AM   #4
acarpetknight
LQ Newbie
 
Registered: Dec 2004
Distribution: Fedora Core 3
Posts: 2

Original Poster
Rep: Reputation: 0
Most excellent -- I stumbled across a fedora bugzilla that appeared to be tracking my own issues. For anyone else having problems, just grabbing the latest xorg-x11 rpms will correct the problem -- xorg-x11-6.8.1-24 and subsequent dependencies (xorg-x11-devel, xorg-x11-libs, xorg-x11-xfs). It's too bad that the buggy driver made it into the FC3 release...

Also, to avoid serious head-on-table sessions, the old posted link to http://people.redhat.com/krh/i810_drv.o is no longer in service. This driver appears to have made it into the new xorg-x11 packages.

Thanks for the help, all! =]
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg.conf - video && touchpad problem * (Dell C640) Pear-i Linux - Laptop and Netbook 2 07-27-2005 08:12 AM
Xorg and NVIDIA drivers crash and burn JamieMcLaughlin Linux - Hardware 3 05-07-2005 02:00 PM
X query crash with Xorg kev82 Linux - General 1 04-21-2005 07:52 AM
Grub Boots into Colored Stripes ~zoey~ Linux - Newbie 3 09-30-2004 10:48 AM
Strange stripes with MACH64 -=bcc=-E-nigma Linux - Hardware 2 04-30-2003 11:48 PM


All times are GMT -5. The time now is 05:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration