LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 04-11-2005, 07:01 PM   #1
kev82
Senior Member
 
Registered: Apr 2003
Location: Lancaster, England
Distribution: Debian Etch, OS X 10.4
Posts: 1,263

Rep: Reputation: 50
X query crash with Xorg


X is not my area of expertise so hopefully someone who knows a bit more can help me out.

I have a compaq proliant 3000 which used to run debian testing. I have 3 thinclients and 2 X-terminals that booted from nfs and queried this machine for a login. I also occasionally connected to it from Exceed in win2k. Everything worked fine.

I am a gentoo user, and in an attempt to get everything running the same distribution to make things easier to manage I installed gentoo on the proliant. The problem is that whenever a thinclient queries the the server it crashes, and whenever an X-terminal queries the server it resets. Exceed however still runs well.

I can't give you logs from the X-terminal or thinclient very easily but I'll try and figure out how to get them if nobody suggests anything. The xdm log on the server is the same entry continuously repeated

Code:
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  14 (X_GetGeometry)
  Resource id in failed request:  0x0
  Serial number of failed request:  301
  Current serial number in output stream:  301
Thanks for any help.

<edit>
Doesn't matter, figured it out. Something in the Xresources file that came with xdm was too diificult for the clients to do. Will sift through it eventually to figure out what the problem was, but for now deleting the file has fixed the problem.
</edit>

Last edited by kev82; 04-11-2005 at 07:33 PM.
 
Old 04-21-2005, 08:52 AM   #2
knolle
LQ Newbie
 
Registered: Apr 2004
Location: Marseille, France
Distribution: Gentoo
Posts: 3

Rep: Reputation: 0
had the same problem. for me it was the background xpm under
xlogin*logoFileName
changing that helped.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg and NVIDIA drivers crash and burn JamieMcLaughlin Linux - Hardware 3 05-07-2005 03:00 PM
replace 'xfree86' by 'xorg' in your xorg config file dindoung Linux - Newbie 2 02-26-2005 05:43 AM
Stripes & Crash on Xorg acarpetknight Fedora 3 12-20-2004 08:50 AM
Xorg Hard Crashes and corrupts xorg.conf Advocator Linux - General 0 07-15-2004 02:41 PM
xmms crash xine crash mplayer crash paledread Linux - Software 9 03-09-2004 08:09 AM


All times are GMT -5. The time now is 04:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration