LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-05-2004, 12:27 AM   #1
taty
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Rep: Reputation: 0
SB 5.1 Live not working with emu10k1 alsa driver in 2.6 kernel


I have put in a Creative Labs SB 5.1 Live and upgraded to kernel 2.6 (my orig distro is FC1). Since 2.6 has alsa in the kernel source, I configured them as modules and wrote my /etc/modprobe.conf as follows. I have an Intel onboard sound so that's why I put in 2 sound card configuration. However I've not been able to get any soudn at all no matter what I tried.

**********************************************************************************
include /etc/modprobe.conf.dist
alias scsi_hostadapter ata_piix
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.6 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-1 snd-seq-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-8 snd-seq-oss
alias sound-service-1-12 snd-pcm-oss
alias snd-card-0 snd-emu10k1
alias snd-card-1 snd-emu10k1
alias sound-slot-0 snd-emu10k1
alias sound-slot-1 snd-emu10k1
**********************************************************************************

Here's my lspci -vv output and dmesg. It looks like the SB card is being recognized, but yet in dmesg I dont' see ALSA doing anything with it... Is it a problem with IRQ? I've been struggling with this for a long time. ANy help will be very much appreciated.

00:1f.5 Multimedia audio controller: Intel Corp. 82801EB AC'97 Audio Controller (rev 02)
Subsystem: Dell Computer Corporation: Unknown device 0162
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 0
Interrupt: pin B routed to IRQ 17
Region 0: I/O ports at ee00 [size=256]
Region 1: I/O ports at edc0 [size=64]
Region 2: Memory at febffa00 (32-bit, non-prefetchable) [size=512]
Region 3: Memory at febff900 (32-bit, non-prefetchable) [size=256]
Capabilities: <available only to root>

02:01.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
Subsystem: Creative Labs: Unknown device 8066
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 64 (500ns min, 5000ns max)
Interrupt: pin A routed to IRQ 22
Region 0: I/O ports at dda0 [size=32]
Capabilities: <available only to root>

dmesg:
Advanced Linux Sound Architecture Driver Version 0.9.7 (Thu Sep 25 19:16:36 2003 UTC).
PCI: Setting latency timer of device 0000:00:1f.5 to 64
intel8x0: clocking to 48000
ALSA device list:
#0: Intel ICH5 at 0xfebffa00, irq 17
 
Old 10-05-2004, 02:34 AM   #2
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
I think you need to disable the on board sound and then reboot. They may be conflicting with each other. Here any wrestling matches going on in there.

Also, make sure you unmute the sound. Linux is generally muted till you unmute it. Don't ask why, I'm just the messenger. I have done it myself and seen countless others do the same thing.

Hope that helps. I too disabled on board and installed a SB card.

 
Old 10-05-2004, 03:06 AM   #3
taty
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
When I disable sound in BIOS, ALSA found no sound card (in dmesg). Sounds like it's never found my SB card, although lspci was listing it, and when I cat /dev/dsp0 and /dev/dsp1 I"m seeing outputs. Am I missing some config (other than modprobe.conf)? Thanks for your help!
 
Old 10-05-2004, 03:35 AM   #4
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
This is what mine says in dmesg:

Code:
Advanced Linux Sound Architecture Driver Version 1.0.4 (Mon May 17 14:31:44 2004 UTC).
ALSA device list:
  #0: Sound Blaster Live! (rev.10) at 0xd000, irq 5
Sure you have it in the kernel correctly? I did mine in the kernel instead of a module. It shouldn't matter but. You may also want to type in lsmod to make sure it loaded. Should be listed if it is.



 
Old 10-05-2004, 04:47 AM   #5
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 740

Rep: Reputation: 81
You also might want to go into your kernel (make gconfig) and make sure that you've got the newer linux sound system enabled and the older one disabled. (I don't remember their names off the top of my head, but it'll tell you which is which in the comments.) My SB LIVE! MP3 card was pretty picky about that.

Good luck.

--Dane
 
Old 10-05-2004, 07:02 AM   #6
bglnelissen
Member
 
Registered: Feb 2004
Location: Utrecht Holland
Distribution: Fedora, Debian, Mandrake, OSX, OpenBSD
Posts: 76

Rep: Reputation: 15
check (and change alsa settings)
$ alsamixer

worked here.

luck
Bas
 
Old 10-05-2004, 01:43 PM   #7
taty
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for all the replies. I've turned on the alsa support in kernel config, unmuted in alsamixer, and my lsmod is showing the following:

Module Size Used by
snd_mixer_oss 18272 -
snd_emu10k1 94212 -
snd_seq_device 7784 -
snd_util_mem 4288 -
snd_hwdep 8864 -

I still suspect that for some reason the device is not being recognized, evident by the no-show of ALSA device in dmesg once I turned off on-board sound. The card is working fine in Windows though. I have to be missing some config? just don't know what it is...
 
Old 10-05-2004, 02:24 PM   #8
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
There is another place to unmute but I can't remember where it is. There is one that is command line and one in the GUI. You might try searching, I found it once when I did mine.

I wish I had better memory.

Later

 
Old 10-06-2004, 04:38 AM   #9
taty
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
I got it!! Disabling onboard sound actually did the magic. The only reason why I didn't notice this at first was that I tested with the cd player, which wouldnt' work unless I turned on digital audio extraction in xmms per this thread: http://www.linuxquestions.org/questions/history/214061.

Thanks everyone for helping out! I still dont' understand why my dmesg is saying 'No Sound card detected', but I'm surely much happier now that i hear sound, i can tell you that much!
 
Old 10-06-2004, 12:37 PM   #10
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
Woooo Hoooooooo

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Audigy 2 Sound not working: alsa with snd-emu10k1 hashbrown Mandriva 10 08-01-2005 01:10 PM
Surround on SB Live with emu10k1 (not ALSA) zahoo Linux - Hardware 4 02-25-2005 07:32 PM
ALSA Sound Blaster Live! (emu10k1) surround 5.1 Kronoss Linux - Hardware 4 01-17-2005 12:04 PM
SB 5.1 Live not working with emu10k1 alsa driver in 2.6 kernel taty Linux - Newbie 2 10-04-2004 02:20 PM
Why does my sb live (emu10k1) sound better with oss than alsa? haimeltjnfg Linux - Hardware 2 08-29-2004 03:19 AM


All times are GMT -5. The time now is 03:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration