LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-11-2003, 08:22 AM   #1
ronss
Member
 
Registered: Mar 2002
Location: phoenix,az
Distribution: red hat linux enterprise-centos
Posts: 766

Rep: Reputation: 31
nvidia driver and xmms


well, i got the nvidia driver installed, but now my xmms player does not work. have installed the xmms player mp3 rpm, but still does not work. i have had this problem before with another distro-not sure what the nvidia driver does with xmms player, but it stops it working. what a bummer
 
Old 11-11-2003, 12:00 PM   #2
egkenny
LQ Newbie
 
Registered: Aug 2003
Posts: 10

Rep: Reputation: 0
I bet a lot of people have problems with the Nvidia driver. I finally got it working myself. It doesn't seem to have affected the XMMS player.

Fedora like RedHat has a crippled XMS player. You need to install the pluggin for it to work. I could not find any links for the same pluggin for Fedora. I used the same one I used for RedHat 8.0 and 9. I installed this rpm "xmms-mpg123-1.2.7-21.i386.rpm". XMMS started playing MP3s then.

I already had it but can't find any direct link anymore at http://www.xmms.org. They do have it at http://havardk.xmms.org/dist/xmms-1.2.7-rh8-rh9-rpm/

Is the one you installed? I know Fedora comes with XMMS 1.2.8 but the older pluggin seems to work with the limited testing I did.
 
Old 11-11-2003, 12:43 PM   #3
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
Add the following into /etc/yum.conf

[livna-stable]
name=Fedora Compatible Packages (stable)
baseurl= http://rpm.livna.org/fedora/$releasever/$basearch/yum/stable
gpgcheck=1

And do

$ yum install xmms-mp3

Work just fine on my system. BTW, I've just installed NVIDIA driver and up until now, I don't have any problem with it.
 
Old 11-11-2003, 03:11 PM   #4
ronss
Member
 
Registered: Mar 2002
Location: phoenix,az
Distribution: red hat linux enterprise-centos
Posts: 766

Original Poster
Rep: Reputation: 31
. will try to get it working after work tonight. later

Last edited by ronss; 11-12-2003 at 03:30 AM.
 
Old 11-12-2003, 02:48 AM   #5
ronss
Member
 
Registered: Mar 2002
Location: phoenix,az
Distribution: red hat linux enterprise-centos
Posts: 766

Original Poster
Rep: Reputation: 31
[B]got off work, and just for the heck of it, opened shoutcast file , and clicked run on the xmms player-it started playing. what a surprise.,did not want to play last night, maybe the reboot did something. thanks for the great leads,

Last edited by ronss; 11-12-2003 at 03:32 AM.
 
Old 11-12-2003, 12:35 PM   #6
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
could some of you possibly help me...? I've got a Gentoo 1.4 distro, and (I guess it's because of NVIDIA driver because this problem appeared after installing it) I can't start xmms...well, actually I can start it, and it appears at the bottom of my screen where every program does, but no xmms windows are visible

so it's like xmms would start, but couldn't draw it's windows or something...if I minimize/unminimize it, I can see the Gnome's box-style-borders going down/up (like when minimizing any other application) so it's like the xmms would be invisible..? Also when I start it, I can't close it by clicking the bar at the bottom with my right mouse button and selecting "Close". The only way is to give it a kill command from terminal (and that's when terminal shows a line: "segmentation fault" or something)

so what could I do to get xmms visible (and working) again? I've tried to re-emerge it, but without success....

Last edited by b0uncer; 11-12-2003 at 12:37 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver makes xmms crash doralsoral Linux - Software 2 01-09-2005 08:32 AM
XMMS, libmikmod and nvidia driver GruiX Linux - Software 0 01-17-2004 05:30 PM
red hat 9-nvidia driver-xmms player problem ronss Linux - Software 2 10-01-2003 08:46 AM
red hat 9 xmms and nvidia driver-xmms ronss Red Hat 3 09-26-2003 08:06 AM
PyQt, xmms, ooffice segmentation fault after installing nvidia driver blais Linux - Software 4 08-06-2003 10:17 AM


All times are GMT -5. The time now is 04:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration