LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 06-03-2005, 06:07 PM   #1
CypherBeginner
LQ Newbie
 
Registered: Feb 2004
Location: Utah
Distribution: Fedora Core 1
Posts: 15

Rep: Reputation: 0
New soundcard, no sound


I am using Fedora Core 3 at work. Completely update. I am on a temporary box and installed FC3 with no sound card in the box. Since then, I have put in a sound card from my old computer. Fedora recognizes the card but I cannot get any sound when I try soundcard detection. When I click on volume control I get the following error "Sorry no mixer elements and/or devices found". Anyone have any suggestions on what I need to install/tweak to get this working?
 
Old 06-03-2005, 06:35 PM   #2
uberNUT69
Member
 
Registered: Jan 2005
Location: Tasmania
Distribution: Xen Debian Lenny/Sid
Posts: 578

Rep: Reputation: 30
I assume you mean that the module for the card is loading.
So I would think that all is happening is that you permissions are incorrect.
If that's the case, try this:
Create an audio group and add your user(s) to it.
Make sure that your /dev/audio, /dev/dsp and /dev/mixer devices are owned by root:audio.

Good luck
 
Old 06-03-2005, 06:59 PM   #3
CypherBeginner
LQ Newbie
 
Registered: Feb 2004
Location: Utah
Distribution: Fedora Core 1
Posts: 15

Original Poster
Rep: Reputation: 0
Ok, I guess I don't know linux as well as I thought. Could you walk me through how I would do that?
 
Old 06-03-2005, 07:20 PM   #4
uberNUT69
Member
 
Registered: Jan 2005
Location: Tasmania
Distribution: Xen Debian Lenny/Sid
Posts: 578

Rep: Reputation: 30
OK,

1. Check the card is recognised:
#lspci | grep Multimedia
should list your PCI devices, and you should see a multimedia device there somewhere
eg. I get:
0000:00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
0000:00:0f.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
0000:00:0f.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
The sound card is the first entry

2. Check a kernel module is loading for that card
#lsmod | grep snd
will list all the loaded modules that have anything to do with sound
one of them will be related to the sound card you are using
eg. mine is snd_cmipci

3. Add an audio group
#groupadd audio

4. Add your user to that group
#usermod -G audio username

5. Check / change devuice permissions:
#ls -l /dev/audio /dev/dsp /dev/mixer
#chown root:audio /dev/audio /dev/dsp /dev/mixer

Hope that helps.
 
Old 06-03-2005, 09:54 PM   #5
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Thumbs up

uberNUT69,

That list of instructions should be a tutorial. I certainly saved it for my little cheatsheet collection.
 
Old 06-06-2005, 12:57 PM   #6
CypherBeginner
LQ Newbie
 
Registered: Feb 2004
Location: Utah
Distribution: Fedora Core 1
Posts: 15

Original Poster
Rep: Reputation: 0
This all worked until ls -l /dev/audio

I don't have a /dev/audio. Any suggestions from here?

Scott
 
Old 06-06-2005, 12:58 PM   #7
CypherBeginner
LQ Newbie
 
Registered: Feb 2004
Location: Utah
Distribution: Fedora Core 1
Posts: 15

Original Poster
Rep: Reputation: 0
No /dev/mixer or /dev/dsp eithor.
 
Old 06-06-2005, 05:07 PM   #8
10SPlayer
LQ Newbie
 
Registered: Mar 2005
Distribution: Fedora Core 3
Posts: 14

Rep: Reputation: 0
CyberBeginner..

I had perhaps the same problem last night with my FC3 box. It is now fixed, see if the following info can be of any use for you. My card SB Live(digital audio/gaming card) in a gateways P3 w/ Boston 2speaker+sub audio system.

If your device manager recognizes your card with no problems and you happen to have speakers with digital input, then go to "Audio Control" (maybe Volume Control) under System Tools and look for something like "...Analog/Digital..." tool, and check to see if it's "MUTE" radio button is checked and simply uncheck it.

Hope that helps..

Good luck
 
Old 06-06-2005, 06:21 PM   #9
CypherBeginner
LQ Newbie
 
Registered: Feb 2004
Location: Utah
Distribution: Fedora Core 1
Posts: 15

Original Poster
Rep: Reputation: 0
10S Player,

No go. See first message - no mixer message. I think when I did my first install, no sound devices or support was installed. When I added the new card, I think the driver was installed but the mixers and dev folders were no installed. I am afraid this is one of those blackhole questions where I will just have to reinstall the OS with all the hardware already in and I know that will solve the problem. Thanks everyone for the help.
 
Old 06-06-2005, 08:30 PM   #10
SHERB142
LQ Newbie
 
Registered: Jun 2005
Distribution: Fedora Core 8
Posts: 23

Rep: Reputation: 15
What happens when you play the test sound on the soundcard detection?
 
Old 06-14-2005, 11:28 PM   #11
uberNUT69
Member
 
Registered: Jan 2005
Location: Tasmania
Distribution: Xen Debian Lenny/Sid
Posts: 578

Rep: Reputation: 30
Quote:
Originally posted by CypherBeginner
This all worked until ls -l /dev/audio

I don't have a /dev/audio. Any suggestions from here?

Scott
Quote:

No /dev/mixer or /dev/dsp eithor.

This would suggest that you haven't successfully loaded the correct audio module for your card.
Would you mind posting the output of lspci?
 
Old 06-23-2005, 01:36 AM   #12
vikasrawal
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Rep: Reputation: 0
Similar problems

Thanks for excellent help. I have a debian on which the sound does not work. I get an error message everytime I boot which says that /dev/dsp does not exist and therefore the sound server will use null output. I looked for it and found that /dev/dsp exists. I followed your instructions and this is what I get.

vikas@vikas:~$ lspci |grep Multimedia
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

After this "/sbin/lsmod |grep snd" gives no output.

Where does one go from there?

vikasrawal
 
Old 06-23-2005, 08:23 AM   #13
uberNUT69
Member
 
Registered: Jan 2005
Location: Tasmania
Distribution: Xen Debian Lenny/Sid
Posts: 578

Rep: Reputation: 30
I believe that the correct module for you sound card is "i810_audio".
Does
#lsmod | grep i810_audio
list anything?

If not, try
#modprobe i810_audio

and then see if your audio devices have been created:
# ls -l /dev/audio
(or try playing a sound!)

If this works, edit /etc/modules (you said Debiand, right? )
and put the following line at the end
i810_audio

or ... just do this:
#echo i810_audio >> /etc/modules

** If _any_ of the above tests work ... retry the steps from my earlier post http://www.linuxquestions.org/questi...44#post1676444
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound heard during soundcard detection but no sound when playing CD thanhvn Linux - Software 6 07-04-2005 01:30 PM
Soundcard - more than 1 sound stevesk Slackware 1 12-05-2004 05:31 PM
Soundcard or sound system problem: no sound! nmoog Linux - Newbie 4 09-01-2004 12:27 AM
On board soundcard but no sound vwal_13 Slackware 6 04-13-2004 01:32 PM
Quake II: No sound: Sorry but your soundcard can't do this asalford Linux - Games 5 02-27-2004 01:21 PM


All times are GMT -5. The time now is 03:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration