LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 04-29-2013, 07:51 AM   #1
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Rep: Reputation: 90
How to activate framebuffer with Fedora 18?


I boot into multi-user mode and like to use the framebuffer with mplayer to view videos. With
Code:
grub2-mkconfig -o /boot/grub2/grub.cfg
I know I can generate a new /boot/grub2/grub.cfg after editing a line in /etc/default/grub. Specifically the line "GRUB_CMDLINE_LINUX=". What should I add there? I had this information for the old grub backed up on another HDD but lost it to a nasty divorce. I'm using a Toshiba Satellite A665 with a wide screen. Thanks ahead of time.

EDIT: Apparently the framebuffer is working, it's a problem with mplayer, which I downloaded from rpmfusion. Here's the output from mplayer:
Code:
mplayer -vo fbdev some_video.mpg
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t

FATAL: Could not initialize video filters (-vf) or video output (-vo).
Should I compile mplayer from source??

Last edited by SharpyWarpy; 04-29-2013 at 08:16 AM.
 
Old 05-01-2013, 09:45 AM   #2
Andy Alkaline
Member
 
Registered: Jun 2004
Location: Minnesota, USA
Distribution: Slackware32-stable, Debian-wheezy-amd64, LFS 7.1
Posts: 355

Rep: Reputation: 33
I'm not sure the problem is mplayer. You might be getting those error messages because the framebuffer isn't enabled.

Do a google search:
enable framebuffer in kernel

Yes, there are some options you can pass to grub.
 
Old 05-01-2013, 02:21 PM   #3
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Original Poster
Rep: Reputation: 90
Quote:
Originally Posted by Andy Alkaline View Post
I'm not sure the problem is mplayer. You might be getting those error messages because the framebuffer isn't enabled.

Do a google search:
enable framebuffer in kernel

Yes, there are some options you can pass to grub.
fbi framebuffer image viewer works, so the framebuffer is enabled. Thanks for the reply.
 
Old 05-01-2013, 02:44 PM   #4
Andy Alkaline
Member
 
Registered: Jun 2004
Location: Minnesota, USA
Distribution: Slackware32-stable, Debian-wheezy-amd64, LFS 7.1
Posts: 355

Rep: Reputation: 33
Quote:
Originally Posted by SharpyWarpy View Post
Should I compile mplayer from source??
That's what I usually try when I can't get something to work.

I don't know how much experience you have building, but if you want to play it safe, pass --prefix=$HOME so you can install it as a non-priveleged user, so you don't have to worry about overwriting any files provided by "official" packages.

Or you might want to wait a few days and see if anybody more knowledgeable than myself replies.
 
Old 05-02-2013, 11:28 AM   #5
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Original Poster
Rep: Reputation: 90
Quote:
Originally Posted by Andy Alkaline View Post
That's what I usually try when I can't get something to work.

I don't know how much experience you have building, but if you want to play it safe, pass --prefix=$HOME so you can install it as a non-priveleged user, so you don't have to worry about overwriting any files provided by "official" packages.

Or you might want to wait a few days and see if anybody more knowledgeable than myself replies.
Thanks for the reply. I thinks that's what I'll do, I've done it several times in the past. Thanks again.
 
Old 05-06-2014, 02:14 PM   #6
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Original Poster
Rep: Reputation: 90
Sorry about resurrecting this old thread but I think it might help somebody.

I solved this by using
Code:
mplayer -vo fbdev2 <some_video_file>
I don't know why it won't use /dev/fbdev but /dev/fbdev2 works.
 
Old 05-14-2014, 09:18 AM   #7
Andy Alkaline
Member
 
Registered: Jun 2004
Location: Minnesota, USA
Distribution: Slackware32-stable, Debian-wheezy-amd64, LFS 7.1
Posts: 355

Rep: Reputation: 33
If I recall right, I too had to use fbdev2 last time I tried using the framebuffer with mplayer (because fbdev didn't work). I don't know why either.
 
Old 05-14-2014, 10:18 AM   #8
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Original Poster
Rep: Reputation: 90
Quote:
Originally Posted by Andy Alkaline View Post
If I recall right, I too had to use fbdev2 last time I tried using the framebuffer with mplayer (because fbdev didn't work). I don't know why either.
Yeah, it's really weird. For others who want to use mplayer in a console environment I use this script I wrote that maximizes the screen - necessary for utilizing the entire screen instead of a little block in the middle:
Code:
#!/bin/bash
if [ ! $DISPLAY ]
then mplayer -vo fbdev2 -vf scale=1366:768 -mixer-channel Master -quiet $1
else mplayer -vo x11 -mixer-channel Master -quiet $1
fi
exit 0
The "-quiet" option is nice, removes all that stuff mplayer puts in the bottom of the screen. The "-mixer-channel Master" option is there because mplayer volume control doesn't work with the default "PCM" channel.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to activate audio on fedora 10 shamjs Linux - Hardware 7 08-31-2012 05:26 PM
framebuffer confusion with Hauppauge PVR 350 framebuffer /dev/fb0 tofino_surfer Linux - General 4 09-19-2008 12:36 AM
Fedora Framebuffer Troubles PatrickNew Fedora 4 11-11-2006 11:17 AM
How to activate in Fedora 5 ? wlaw Linux - Newbie 4 09-25-2006 10:33 PM
VESA framebuffer vs Intel framebuffer in Slackware 10.0 with default kernel brancalessio Slackware 3 01-20-2005 04:21 PM


All times are GMT -5. The time now is 10:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration