LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   How to activate framebuffer with Fedora 18? (http://www.linuxquestions.org/questions/fedora-35/how-to-activate-framebuffer-with-fedora-18-a-4175459982/)

SharpyWarpy 04-29-2013 06:51 AM

How to activate framebuffer with Fedora 18?
 
I boot into multi-user mode and like to use the framebuffer with mplayer to view videos. With
Code:

grub2-mkconfig -o /boot/grub2/grub.cfg
I know I can generate a new /boot/grub2/grub.cfg after editing a line in /etc/default/grub. Specifically the line "GRUB_CMDLINE_LINUX=". What should I add there? I had this information for the old grub backed up on another HDD but lost it to a nasty divorce. I'm using a Toshiba Satellite A665 with a wide screen. Thanks ahead of time.

EDIT: Apparently the framebuffer is working, it's a problem with mplayer, which I downloaded from rpmfusion. Here's the output from mplayer:
Code:

mplayer -vo fbdev some_video.mpg
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [fbdev] 720x480 => 720x540 BGRA
FATAL: Cannot initialize video driver.t

FATAL: Could not initialize video filters (-vf) or video output (-vo).

Should I compile mplayer from source??

Andy Alkaline 05-01-2013 08:45 AM

I'm not sure the problem is mplayer. You might be getting those error messages because the framebuffer isn't enabled.

Do a google search:
enable framebuffer in kernel

Yes, there are some options you can pass to grub.

SharpyWarpy 05-01-2013 01:21 PM

Quote:

Originally Posted by Andy Alkaline (Post 4942614)
I'm not sure the problem is mplayer. You might be getting those error messages because the framebuffer isn't enabled.

Do a google search:
enable framebuffer in kernel

Yes, there are some options you can pass to grub.

fbi framebuffer image viewer works, so the framebuffer is enabled. Thanks for the reply.

Andy Alkaline 05-01-2013 01:44 PM

Quote:

Originally Posted by SharpyWarpy (Post 4941073)
Should I compile mplayer from source??

That's what I usually try when I can't get something to work. :)

I don't know how much experience you have building, but if you want to play it safe, pass --prefix=$HOME so you can install it as a non-priveleged user, so you don't have to worry about overwriting any files provided by "official" packages.

Or you might want to wait a few days and see if anybody more knowledgeable than myself replies. ;)

SharpyWarpy 05-02-2013 10:28 AM

Quote:

Originally Posted by Andy Alkaline (Post 4942848)
That's what I usually try when I can't get something to work. :)

I don't know how much experience you have building, but if you want to play it safe, pass --prefix=$HOME so you can install it as a non-priveleged user, so you don't have to worry about overwriting any files provided by "official" packages.

Or you might want to wait a few days and see if anybody more knowledgeable than myself replies. ;)

Thanks for the reply. I thinks that's what I'll do, I've done it several times in the past. Thanks again.

SharpyWarpy 05-06-2014 01:14 PM

Sorry about resurrecting this old thread but I think it might help somebody.

I solved this by using
Code:

mplayer -vo fbdev2 <some_video_file>
I don't know why it won't use /dev/fbdev but /dev/fbdev2 works.

Andy Alkaline 05-14-2014 08:18 AM

If I recall right, I too had to use fbdev2 last time I tried using the framebuffer with mplayer (because fbdev didn't work). I don't know why either.

SharpyWarpy 05-14-2014 09:18 AM

Quote:

Originally Posted by Andy Alkaline (Post 5170689)
If I recall right, I too had to use fbdev2 last time I tried using the framebuffer with mplayer (because fbdev didn't work). I don't know why either.

Yeah, it's really weird. For others who want to use mplayer in a console environment I use this script I wrote that maximizes the screen - necessary for utilizing the entire screen instead of a little block in the middle:
Code:

#!/bin/bash
if [ ! $DISPLAY ]
then mplayer -vo fbdev2 -vf scale=1366:768 -mixer-channel Master -quiet $1
else mplayer -vo x11 -mixer-channel Master -quiet $1
fi
exit 0

The "-quiet" option is nice, removes all that stuff mplayer puts in the bottom of the screen. The "-mixer-channel Master" option is there because mplayer volume control doesn't work with the default "PCM" channel.


All times are GMT -5. The time now is 05:04 AM.