LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-11-2005, 03:16 PM   #1
brancalessio
LQ Newbie
 
Registered: Aug 2004
Location: Italy
Distribution: Slackware 10.1
Posts: 16

Rep: Reputation: 0
VESA framebuffer vs Intel framebuffer in Slackware 10.0 with default kernel


First of all, hello everyone since this is my first thread!

I'm running Slackware 10.0 with the default kernel 2.4.26. My computer is a laptop equipped with an Intel i830m.

My problem is that I can't use the Itel framebuffer (which is compiled as a module in the kernel) and I'm compelled to use the VESA one (which is built in the kernel). On some page on the internet (I don't remember where now) I found that I have to pass to lilo the following extra parameter

video=i810fb

(the document I found was about Intel i810) after the usual

vga=773

Actually the framebuffer is always vesa as it can be see typing

cat /proc/fb

which returns as output "0 VESA VGA"


Thank you in advance for your help!
 
Old 01-11-2005, 06:05 PM   #2
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Maybe you should try to use append in lilo.conf, like :
append="video=i810fb"

(put the line after kernel and vga settings)

But as you have it as module, I doubt that it will loaded at this boot time
 
Old 01-12-2005, 07:36 AM   #3
brancalessio
LQ Newbie
 
Registered: Aug 2004
Location: Italy
Distribution: Slackware 10.1
Posts: 16

Original Poster
Rep: Reputation: 0
Hello!

Actually, I think the issue is that the intel framebuffer support is compiled as a module instead of being built in the kernel. What seems strange is that I get no error messages with the "video=..." option.

Do you think I need am initial ram disk? I could try this way (before rebuild the kernel...)

Quote:
Originally posted by Cedrik
Maybe you should try to use append in lilo.conf, like :
append="video=i810fb"

(put the line after kernel and vga settings)

But as you have it as module, I doubt that it will loaded at this boot time
 
Old 01-20-2005, 03:21 PM   #4
brancalessio
LQ Newbie
 
Registered: Aug 2004
Location: Italy
Distribution: Slackware 10.1
Posts: 16

Original Poster
Rep: Reputation: 0
I built the new kernel 2.4.29 without VGA and VESA framebuffer and with Intel i830M framebuffer (built-in, not as a module). It now works...

Bye!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cant get (vesa) framebuffer device to work on nvidia card, kernel 2.6.13.4, 'current' jaakkop Slackware 21 11-27-2005 09:36 AM
VESA Framebuffer Driver hubabuba Linux - General 1 10-02-2004 07:37 AM
got vesa framebuffer console working teacup LinuxQuestions.org Member Success Stories 0 05-26-2003 01:16 PM
vesa framebuffer ... failed to open pbhj Linux - Newbie 2 02-13-2003 07:52 PM
VESA framebuffer nautilus_1987 Slackware 3 09-26-2002 12:13 PM


All times are GMT -5. The time now is 01:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration