LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-09-2005, 01:49 AM   #1
hiux
LQ Newbie
 
Registered: Sep 2005
Posts: 8

Rep: Reputation: 0
WHY should I type startx twice to startx?


It's really a bad thing
Every time I reboot and login again, I type startx, but it can't start and come's with some error
but i type startx again, It come to work nice!
and it don't work after a reboot again!
i use xorg fvwm debian

forgive my poor English
 
Old 09-09-2005, 02:19 AM   #2
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
What's the error you get?
 
Old 09-09-2005, 02:20 AM   #3
hiux
LQ Newbie
 
Registered: Sep 2005
Posts: 8

Original Poster
Rep: Reputation: 0
here is the error message after i reboot and startx

Script started on Fri Sep 9 15:19:54 2005
hiux:~# startx



X: warning; process set to priority -1 instead of requested priority 0



X Window System Version 6.8.2 (Debian 6.8.2.dfsg.1-6 20050831134411 @squee)

Release Date: 9 February 2005

X Protocol Version 11, Revision 0, Release 6.8.2

Build Operating System: Linux 2.6.12-1-686 i686 [ELF]

Current Operating System: Linux hiux 2.6.8-1-386 #1 Thu Nov 25 04:24:08 UTC 2004 i686

Build Date: 31 August 2005

Before reporting problems, check http://wiki.X.Org

to make sure that you have the latest version.

Module Loader present

OS Kernel: Linux version 2.6.8-1-386 (joshk@trollwife) (gcc version 3.3.5 (Debian 1:3.3.5-2)) #1 Thu Nov 25 04:24:08 UTC 2004

Markers: (--) probed, (**) from config file, (==) default setting,

(++) from command line, (!!) notice, (II) informational,

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep 9 15:19:58 2005

(==) Using config file: "/etc/X11/xorg.conf"

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o": No symbols found

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o": No symbols found

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o": No symbols found

(WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1) found

Skipping "/usr/X11R6/lib/modules/libfb.a:fbmmx.o": No symbols found

(EE) xf86OpenSerial: Cannot open device /dev/psaux

No such device.

(EE) Configured Mouse: cannot open input device

(EE) PreInit failed for input device "Configured Mouse"

No core pointer



Fatal server error:

failed to initialize core devices



Please consult the The X.Org Foundation support

at http://wiki.X.Org

for help.

Please also check the log file at "/var/log/Xorg.0.log" for additional information.



XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"


after 0 requests (0 known processed) with 0 events remaining.


hiux:~# exit


Script done on Fri Sep 9 15:20:08 2005
 
Old 09-09-2005, 02:23 AM   #4
hiux
LQ Newbie
 
Registered: Sep 2005
Posts: 8

Original Poster
Rep: Reputation: 0
should i change my mouse setting?
but if it's wrong ,why can i startx after i type startx again?
 
Old 09-09-2005, 04:52 AM   #5
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
You don't have your mouse device loaded or so. I'm not completely sure on how to fix it. Looks like you have to reconfigure your xserver with "dpkg-reconfigure xserver-xorg and pick the right mouse.

Also look here:
http://wiki.x.org/wiki/FAQErrorMessa...f593ac99d7ab5a
 
Old 09-09-2005, 06:15 AM   #6
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Try adding a new line that says "psmouse" to the end of /etc/modules, like this:

psmouse

The /etc/modules file is used for loading kernel modules/drivers during boot time and adding "psmouse" there will load the psmouse module so that it's ready when you type "startx" to start X session.
 
Old 09-09-2005, 09:12 AM   #7
hiux
LQ Newbie
 
Registered: Sep 2005
Posts: 8

Original Poster
Rep: Reputation: 0
this really work below
"Please note: Usually the server refuses to start if there is no core pointer device. You can change this by adding the line:
Option "AllowMouseOpenFail" "1"
to the ServerFlags section of your xorg.conf. "

nice .!!!
thank you darkleaf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
startx on Debian gives grey background - cannot move mouse cursor or type fdac Linux - Newbie 7 05-04-2005 03:11 PM
Bug / Xwindows / startx : xinit works but startx crash www.rzr.free.fr Linux - Software 4 10-17-2004 08:06 AM
Why is it so slow, and why does it freeze after i type startx? potenza Slackware - Installation 7 03-12-2004 10:10 AM
startx vs startx -- :2 (font dimension is different!!) moly82 Linux - General 7 09-15-2003 12:11 PM
Must type startx after login to get itno gui? HellBound Linux - General 7 10-04-2002 10:40 AM


All times are GMT -5. The time now is 02:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration