LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-02-2005, 12:06 AM   #1
fdac
LQ Newbie
 
Registered: Apr 2005
Posts: 10

Rep: Reputation: 0
startx on Debian gives grey background - cannot move mouse cursor or type


G'day all,

I have a Debian installation on an old Pentium box. When I 'startx', I cannot move the mouse or use the keyboard. (Ctrl-Alt-Bkspc works to kill X though!)

I get the standard grey background with X mouse cursor, which then changes to a black 'arrow' cursor. A bar appears at the bottom of screen with the words 'Workspace 1', some arrows and the time displayed.

At this point I cannot move the mouse cursor and no keyboard keys respond except Ctrl-Alt-Bkspc to kill X or the function keys to switch consoles.

I have a two-button serial mouse. /dev/mouse is symlinked to /dev/ttyS1 which is where I think the serial port is mounted.

Any ideas on what is causing this? /etc/X11/XF86Config-4 attached below...

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "dbe"
Load "dri"
Load "extmod"
Load "glx"
Load "record"
Load "xtrap"
Load "speedo"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/mouse"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "ShadowFB" # [<bool>]
#Option "DefaultRefresh" # [<bool>]
Identifier "Card0"
Driver "vesa"
Option "UseFBDev" "false"
VendorName "S3 Inc."
BoardName "86c767 [Trio 64UV+]"
BusID "PCI:0:19:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Depth 1
EndSubSection
SubSection "Display"
Depth 4
EndSubSection
SubSection "Display"
Depth 8
EndSubSection
SubSection "Display"
Depth 15
EndSubSection
SubSection "Display"
Depth 16
EndSubSection
SubSection "Display"
Depth 24
EndSubSection
EndSection


Thanks
Francis
 
Old 05-02-2005, 12:20 AM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Try using CTRL + ALT + F1 to switch to the first console then login as root. Once there dpkg-reconfigure xserver-xfree86 to reconfigure the X server and select a default depth and resolution for the X server you have none in your config file at the moment along with the settings for your keyboard. You may also want to install a display manager like xdm unless of course you want to continue to use the startx to start it although I think you may have missed some X packages when setting it up because xdm should have been installed as part of the server install.
 
Old 05-02-2005, 01:17 AM   #3
fdac
LQ Newbie
 
Registered: Apr 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks HappyTux..

I re-ran dpkg-reconfigure xserver-xfree86 as you suggested.

This unfortunately hasn't changed anything. In fact, I checked /etc/X11/XF86Config-4 and it had not been altered.

Any ideas where dpkg might have stored the new X config file if not there?

It seems that the X Server loads up ok, because previously it wouldn't load at all when I had specified the wrong mouse location. I fixed this, and now I get to the graphical display with the cursor, but no further.

I also checked xdm and I definitely have the xdm package installed. I've also got fluxbox window manager (installed with apt-get) but haven't configured it yet.

Cheers
Francis
 
Old 05-02-2005, 01:34 AM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Re: startx on Debian gives grey background - cannot move mouse cursor or type

Alright try this for an /etc/X11/XF86Config-4 it is just a basic one based on what you posted you may need to change the number of keys through the "XkbModel" and "XkbLayout" if you use a layout other than us and change the Driver "vesa" to "s3".

Code:
Section "ServerLayout"
	Identifier     "XFree86 Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	ModulePath   "/usr/X11R6/lib/modules"
	FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
	FontPath     "/usr/X11R6/lib/X11/fonts/Speedo/"
	FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
	FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
	FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
	FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
	Load  "dbe"
	Load  "dri"
	Load  "extmod"
	Load  "glx"
	Load  "record"
	Load  "xtrap"
	Load  "speedo"
	Load  "type1"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "keyboard"
        Option      "CoreKeyboard"
        Option      "XkbRules"      "xfree86"
        Option      "XkbModel"      "pc101"
        Option      "XkbLayout"     "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "Microsoft"
	Option	    "Device" "/dev/mouse"
	Option	"Emulate3Buttons"	"true"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "DefaultRefresh"     	# [<bool>]
	Identifier  "Card0"
	Driver      "vesa"
	Option	    "UseFBDev"	"false"
	VendorName  "S3 Inc."
	BoardName   "86c767 [Trio 64UV+]"
	BusID       "PCI:0:19:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
        DefaultDepth 16
	SubSection "Display"
		Depth     1
	EndSubSection
	SubSection "Display"
		Depth     4
	EndSubSection
	SubSection "Display"
		Depth     8
	EndSubSection
	SubSection "Display"
		Depth     15
	EndSubSection
	SubSection "Display"
		Depth     16
                Modes     "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     24
	EndSubSection
EndSection
 
Old 05-04-2005, 06:51 AM   #5
fdac
LQ Newbie
 
Registered: Apr 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks for the info, HappyTux.

I tried your suggested modifications but nothing changed. I don't think it's a problem with the display driver as I am getting an X-like screen, it's just that I can't move the mouse or use the keyboard when I'm at this screen.

Here's the output of my /var/log/XFree86.0.log after I have run startx , gotten to the grey screen, then used Ctrl-Alt-Backspace to kill X and return to the console:

http://web.aanet.com.au/francis/xlog.txt

Any ideas?

Cheers
Francis
 
Old 05-04-2005, 06:56 AM   #6
fdac
LQ Newbie
 
Registered: Apr 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Here also is my /etc/X11/xinit/xinitrc:

http://web.aanet.com.au/francis/xinitrc

Anything missing that should be there?

Cheers again
Francis
 
Old 05-04-2005, 07:03 AM   #7
fdac
LQ Newbie
 
Registered: Apr 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Maybe it's the mouse...

Here's another thought.

I tried (as root) cat /dev/mouse and cat /dev/ttyS1 (the former is symlinked to the latter anyway, and the mouse is on the second serial port).

If the mouse is working correctly, I should get stuff on the screen when I move or click the mouse, right? I got nothing. Just a blank line until I killed the cat with Ctrl-C.

I have tried two different serial mice with the same result. I'm pretty sure the mice and the serial port work OK because this box was running Windows 98 with the same mouse with no problems.
(Well, not mouse problems anyway

How else can I check that Linux is recognising my mouse?

Thanks
Francis
 
Old 05-04-2005, 04:11 PM   #8
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Quote:
Originally posted by fdac
Here also is my /etc/X11/xinit/xinitrc:

http://web.aanet.com.au/francis/xinitrc

Anything missing that should be there?

Cheers again
Francis
You should have.

Code:
exec fluxbox
I believe in there to tell it to start your desktop environment. Try that and see if it works as to the X log I do not see any resolutions being tested but it looks like it is going to use the vesa modes so hopefully it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i'm using xandros 3.0.2, my mouse(logitech) is not being sensed(cursor doesnt move) rocky_sk0c Linux - Hardware 0 09-13-2005 11:51 AM
grey background after startx cragwolf Slackware 3 08-05-2004 02:01 AM
Highlights on Menus: text = white, background = grey GexNZ Linux - Software 1 08-01-2004 12:41 AM
mouse cursor doesn't move in X/Debian LovelyJunna Linux - Newbie 7 03-26-2004 06:12 PM
Boring grey splash background! finger51 Linux - Newbie 21 06-29-2003 07:19 PM


All times are GMT -5. The time now is 03:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration