LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-02-2008, 07:38 PM   #1
hazelett
LQ Newbie
 
Registered: Oct 2006
Distribution: Debian
Posts: 5

Rep: Reputation: 0
upgrade hangs on libc6


Hello everyone,
I'm running kernel 2.6.15 on a Pentium III notebook (Dell Inspiron 5000). I originally installed Debian Woody and am currently running a mixture of stable and unstable packages. I last successfully upgraded in the spring of 2007. Now I seem to be unable to upgrade, and unable to install new software. Apt-get hangs on the libc6 package:

# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
gcc-4.2-base libgcc1 libglib2.0-0 libglib2.0-dev libsqlite0 libstdc++6
Suggested packages:
libglib2.0-doc
The following NEW packages will be installed:
libsqlite0
The following packages will be upgraded:
gcc-4.2-base libgcc1 libglib2.0-0 libglib2.0-dev libstdc++6
5 upgraded, 1 newly installed, 0 to remove and 1002 not upgraded.
5 not fully installed or removed.
Need to get 0B/1729kB of archives.
After unpacking 446kB of additional disk space will be used.
Do you want to continue [Y/n]?
Setting up libc6 (2.7-4) ...
/usr/share/debconf/confmodule: /usr/share/debconf/frontend: /usr/bin/perl: bad interpreter: Permission denied
/usr/share/debconf/confmodule: line 17: /usr/share/debconf/frontend: Success
dpkg: error processing libc6 (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
libc6
E: Sub-process /usr/bin/dpkg returned an error code (1)


so, I tried building dependencies:


# apt-get build-dep libc6
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to find a source package for glibc

I have stable, testing and unstable sources in my sources.list file.

Any idea how to get past this?
 
Old 01-03-2008, 12:11 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
There's probably a conflict between stable packages installed and unstable packages that are trying to be installed (or vice versa) that doesn't allow those packages to install. Do you know which packages are installed form which branch? This problem is typical of mixed repositories, which is why it's generally discouraged.

I would try to pick one (probably lenny) and then dist-upgrade to it.

Last edited by pljvaldez; 01-03-2008 at 12:12 PM.
 
Old 01-03-2008, 02:12 PM   #3
hazelett
LQ Newbie
 
Registered: Oct 2006
Distribution: Debian
Posts: 5

Original Poster
Rep: Reputation: 0
My original post was too vague. The error was generated originally by a dist-upgrade command. If I use dist-upgrade now, apt hangs on libqt4-sql. Then when I try to build dependencies it hangs on libc6. I get the source for libc6, and then try to install, but it hangs on tzdata:

The following packages have unmet dependencies:
libc6: Conflicts: tzdata (< 2007j-2) but 2007f-9 is to be installed
libc6-dev: Depends: libc6 (= 2.7-4) but 2.7-5 is to be installed
libqt4-sql: Depends: libsqlite0 (>= 2.8.17) but it is not going to be installed

It seems like this should be a minor problem, and maybe results from not updating often enough (?). I tried to install the stable version of tzdata to no avail, because it requires libqt4-sql, which also cannot be installed. Am I hosed?
 
Old 01-03-2008, 05:40 PM   #4
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
I'm not sure how to fix it other than to select one branch (stable, testing, or unstable) and then dist-upgrade to that branch. Then try to reinstall programs that were from a higher branch.

For example, if you choose lenny (testing), dist-upgrade to testing. If it fails, then find out what has been installed from unstable, and uninstall those packages. Then dist-upgrade to lenny and reinstall those packages.

It's possible someone better versed at package management may be able to help you sort out this sordid affair. I've mostly avoided the problem by only running stable and dist-upgrading from one stable version to the next. I'm too chicken to play with a mixed system after my days in Red Hat with dependency hell...
 
Old 01-03-2008, 07:51 PM   #5
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally Posted by hazelett View Post
My original post was too vague. The error was generated originally by a dist-upgrade command. If I use dist-upgrade now, apt hangs on libqt4-sql. Then when I try to build dependencies it hangs on libc6. I get the source for libc6, and then try to install, but it hangs on tzdata:

The following packages have unmet dependencies:
libc6: Conflicts: tzdata (< 2007j-2) but 2007f-9 is to be installed
libc6-dev: Depends: libc6 (= 2.7-4) but 2.7-5 is to be installed
libqt4-sql: Depends: libsqlite0 (>= 2.8.17) but it is not going to be installed

It seems like this should be a minor problem, and maybe results from not updating often enough (?). I tried to install the stable version of tzdata to no avail, because it requires libqt4-sql, which also cannot be installed. Am I hosed?
apt-get -s install -t unstable libc6 libc6-dev libsqlite0 then keep adding the packages it complains about on the end of the line till everything will install then remove the -s for the simulation. Once done with this you may as well remove stable from your sources.list as you will be running unstable. If you want to run a mixed system then you should use testing and unstable with apt pinning to keep your system at testing while using the packages required/wanted from unstable as needed.
 
  


Reply

Tags
apt-get, libc6, upgrade


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I roll back a failed libc6 upgrade? davcefai Debian 7 10-21-2007 02:04 AM
libc6-dev version conflicts with libc6 in Dapper peppill Ubuntu 2 12-04-2006 01:13 PM
Boot loader hangs after upgrade Ezplan Fedora 3 03-27-2005 08:46 AM
libc6 upgrade error SiQDiZ Debian 3 08-12-2004 10:21 AM
Garnome upgrade hangs vsj Linux - Software 0 03-15-2004 08:47 AM


All times are GMT -5. The time now is 08:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration