LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 12-03-2006, 09:02 PM   #1
peppill
LQ Newbie
 
Registered: Aug 2006
Distribution: Kubuntu 6.06
Posts: 8

Rep: Reputation: 0
libc6-dev version conflicts with libc6 in Dapper


I am trying to install gcc and its libraries, but libc6-dev is giving me problems. Here's what I get from Synaptic:

libc6-dev:
Depends: libc6 (=2.3.6-0ubuntu20) but 2.4-1ubuntu12 is to be installed

How can I fix this?
 
Old 12-04-2006, 07:03 AM   #2
cement_head
Member
 
Registered: Mar 2006
Location: Oxford, OH, USA
Distribution: Ubuntu 10.04.1 LTS (Lucid Lynx)
Posts: 36

Rep: Reputation: 15
Quote:
Originally Posted by peppill
I am trying to install gcc and its libraries, but libc6-dev is giving me problems. Here's what I get from Synaptic:

libc6-dev:
Depends: libc6 (=2.3.6-0ubuntu20) but 2.4-1ubuntu12 is to be installed

How can I fix this?
If you are using Dapper Drake, you have installed an Edgy Eft libc6 runtime package. You need to either downgrade back to Dapper; or Upgrade the dev file to the Edgy version. If Synaptic doesn't give you the Edgy dev choice, manually download it from the Edgy Package repository.

****However...you should NOT mix and match Dapper and Edgy packages as you can run into wierd dependency issues (unless you know what you are doing) that can cause problems on your system****

-CH
 
Old 12-04-2006, 02:13 PM   #3
peppill
LQ Newbie
 
Registered: Aug 2006
Distribution: Kubuntu 6.06
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks a lot. I got the Edgy dev file and it works, also got build-essential and it looks like I'm set.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to role back my libc6 to stable version?? pwhitey86 Linux - Newbie 3 04-03-2006 07:23 PM
`Depends' field, reference to `libc6': version contains ` ' jamon Debian 1 01-24-2006 11:44 AM
Libc6-i686 utanja Debian 4 01-14-2005 03:13 AM
libc6 out of date teh_zero Linux - General 1 10-27-2004 07:39 AM
libstdc++-libc6.2-2.so.3 tommytomato Linux - General 1 12-12-2003 02:07 AM


All times are GMT -5. The time now is 01:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration