libc6 upgrade error
phex:/home/siqdiz# apt-get -f dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
Calculating Upgrade... Done
The following packages will be upgraded:
discover1-data exim4 exim4-base exim4-config exim4-daemon-light
gnome-terminal ifupdown initrd-tools libc6 libgnome2-0 libgnome2-common
libmyspell3 libnewt0.51 libopenh323-1.13.2 libpt-1.6.3 libpt-plugins-alsa
libpt-plugins-v4l libstartup-notification0 whiptail zenity
20 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0B/13.4MB of archives.
After unpacking 175kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Preconfiguring packages ...
(Reading database ... 48233 files and directories currently installed.)
Preparing to replace libc6 2.3.2.ds1-15 (using .../libc6_2.3.2.ds1-16_i386.deb) ...
WARNING: Your kernel version indicates a revision number
of 255 or greater. Glibc has a number of built in
assumptions that this revision number is less than 255.
If you've built your own kernel, please make sure that any
custom version numbers are appended to the upstream
kernel number with a dash or some other delimiter.
dpkg: error processing /var/cache/apt/archives/libc6_2.3.2.ds1-16_i386.deb (--unpack):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
for some reason it wont let me replace libc6 , any way to correct this error?