LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-21-2012, 07:48 AM   #1
DaComboMan
LQ Newbie
 
Registered: Jul 2012
Posts: 22

Rep: Reputation: Disabled
No Sound


The only sound i get is when i test sound with Logitech headset.

Dual booting with Windows 7 Home Ed. which has no issues with sound at all.
 
Old 10-21-2012, 01:44 PM   #2
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,217
Blog Entries: 23

Rep: Reputation: 279Reputation: 279Reputation: 279
Quote:
The only sound i get is when i test sound with Logitech headset.
Okay, so, something is comming out of the box. BTW, does'nt have to be a logitech, but hey

The usual suspects:

is sound unmuted? Use alsamixer
is sound cranked up at all? use (alsa)mixer
is this an older setup? Has sound even come from the box? what have you installed/added/changed?
are the speakers plugged into the right plug? the green one is the OUT one, I know, it's silly but I lost a weekend on that one before...heh
are the speakers powered?

Luck

Thor
 
Old 10-22-2012, 08:05 AM   #3
DaComboMan
LQ Newbie
 
Registered: Jul 2012
Posts: 22

Original Poster
Rep: Reputation: Disabled
Thought i did a quick reply on this.

Anyway, i removed/re-installed Pulse (which seems to be the major culprit) and nothing changed (rebooted each time).

Have all the possible Alsa and still nothing, nowhere.

Working on 2 year old laptop (now on Fedora 17 for a while with no sound issues).
Will consider Debian later.
 
Old 10-22-2012, 08:13 AM   #4
merijnofiets
LQ Newbie
 
Registered: Sep 2010
Location: Amsterdam
Distribution: Arch linux
Posts: 11

Rep: Reputation: 0
When only your headset works I think it is a problem with your alsamixer settings.
Because audio is working, just not through the correct output.

With 'M' you can mute/unmute channels in alsamixer
You can change the sound device in alsamixer with 's'

You can detect your sound devices with 'aplay -l'

Merijn

Last edited by merijnofiets; 10-22-2012 at 08:14 AM.
 
Old 10-22-2012, 09:41 AM   #5
DaComboMan
LQ Newbie
 
Registered: Jul 2012
Posts: 22

Original Poster
Rep: Reputation: Disabled
The thing is, i only got some sound from the headset when doing the test procedure.
Otherwise, nothing was coming out of headsets or regular sound output.
 
Old 10-22-2012, 12:15 PM   #6
merijnofiets
LQ Newbie
 
Registered: Sep 2010
Location: Amsterdam
Distribution: Arch linux
Posts: 11

Rep: Reputation: 0
What test did you use?
Maybe alsa does not use the right default audio device.

when you type 'aplay -l' what does it say? Hoe many devices doe you have?

With my laptop my default audio was over hdmi. So my laptop speakers didn't work.
You can select the default card in your asound.rc file.

Ill check how I did it when I get home.

M

Edit: btwe you don't need pulseaudio, its a really nice peace of software but alsa does not need it to work correctly

Last edited by merijnofiets; 10-22-2012 at 12:21 PM.
 
Old 10-22-2012, 08:02 PM   #7
DaComboMan
LQ Newbie
 
Registered: Jul 2012
Posts: 22

Original Poster
Rep: Reputation: Disabled
A bit late in the game but LMDE is back on!

Here are expected/requested results:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Headset [Logitech USB Headset], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

Last edited by DaComboMan; 10-29-2012 at 12:34 PM. Reason: update
 
  


Reply

Tags
sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] .../sound/core/snd-page-alloc.ko.gz': No such directory -- Sound *.ko files nuked. jv2112 Linux - Newbie 1 01-14-2012 09:16 AM
No sound coming from my sound blaster audigy 2 ZS platinum sound card msab Linux - Hardware 9 12-05-2010 05:10 AM
No sound with Diamond Xtreme Sound 5.1 Sound Card - PCI Port Jmccmw Linux - Software 1 07-30-2009 08:43 AM
no sound from sound blaster PCI sound card using mandrake-linux 10.1 box nila56 Linux - Hardware 2 05-29-2006 02:48 PM
No Sound : request_module: failed /sbin/modprobe -- sound-slot-0. error = 256 Mebuh Linux - General 0 01-26-2004 07:51 AM


All times are GMT -5. The time now is 05:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration