LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   No Sound (http://www.linuxquestions.org/questions/debian-26/no-sound-4175433340/)

DaComboMan 10-21-2012 07:48 AM

No Sound
 
The only sound i get is when i test sound with Logitech headset.

Dual booting with Windows 7 Home Ed. which has no issues with sound at all.

Thor_2.0 10-21-2012 01:44 PM

Quote:

The only sound i get is when i test sound with Logitech headset.
Okay, so, something is comming out of the box. BTW, does'nt have to be a logitech, but hey :)

The usual suspects:

is sound unmuted? Use alsamixer
is sound cranked up at all? use (alsa)mixer
is this an older setup? Has sound even come from the box? what have you installed/added/changed?
are the speakers plugged into the right plug? the green one is the OUT one, I know, it's silly but I lost a weekend on that one before...heh
are the speakers powered?

Luck

Thor

DaComboMan 10-22-2012 08:05 AM

Thought i did a quick reply on this.

Anyway, i removed/re-installed Pulse (which seems to be the major culprit) and nothing changed (rebooted each time).

Have all the possible Alsa and still nothing, nowhere.

Working on 2 year old laptop (now on Fedora 17 for a while with no sound issues).
Will consider Debian later.

merijnofiets 10-22-2012 08:13 AM

When only your headset works I think it is a problem with your alsamixer settings.
Because audio is working, just not through the correct output.

With 'M' you can mute/unmute channels in alsamixer
You can change the sound device in alsamixer with 's'

You can detect your sound devices with 'aplay -l'

Merijn

DaComboMan 10-22-2012 09:41 AM

The thing is, i only got some sound from the headset when doing the test procedure.
Otherwise, nothing was coming out of headsets or regular sound output.

merijnofiets 10-22-2012 12:15 PM

What test did you use?
Maybe alsa does not use the right default audio device.

when you type 'aplay -l' what does it say? Hoe many devices doe you have?

With my laptop my default audio was over hdmi. So my laptop speakers didn't work.
You can select the default card in your asound.rc file.

Ill check how I did it when I get home.

M

Edit: btwe you don't need pulseaudio, its a really nice peace of software but alsa does not need it to work correctly

DaComboMan 10-22-2012 08:02 PM

A bit late in the game but LMDE is back on!

Here are expected/requested results:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Headset [Logitech USB Headset], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0


All times are GMT -5. The time now is 01:46 PM.