Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Ubuntu This forum is for the discussion of Ubuntu Linux.


  Search this Thread
Old 08-18-2005, 03:24 PM   #1
LQ Newbie
Registered: Apr 2005
Location: Cheese Land
Distribution: Debian
Posts: 28

Rep: Reputation: 15
Sound makes static like a radio...

Hey, I am wondering what can cause the sound to produce static noise? This happens through all applications I use. If I boot up to windows there is no static sound, so it has to be some configuration with the sound card in linux. I havent messed with the default configuration that comes with a fresh install of kubuntu, which seems to be alsa. (although I did disable that awful arts!).

I have an aopen Cobra AW840 which uses the c-media chipset. Anyone know what could be causing this static? Thanx for the help!!
Old 08-18-2005, 05:39 PM   #2
LQ Newbie
Registered: Jun 2004
Location: Sammamish, WA USA
Distribution: Ubuntu (Hoary), Knoppix Live
Posts: 16

Rep: Reputation: 0
Try following the Getting Sound to Work section in the Ubuntu Beginner's Guide (see the Ubuntu Forums). If that still doesn't work, also try changing from ESD to polypaudio (you can do this with Synaptic). That's what worked for me Scott
Old 08-18-2005, 06:06 PM   #3
LQ Newbie
Registered: Apr 2005
Location: Cheese Land
Distribution: Debian
Posts: 28

Original Poster
Rep: Reputation: 15
Hey, will do. By the way, I am using kubuntu, not ubuntu, which uses kde, which of course doesnt use esd. You shouldnt need to use esd, arts, or any kind of sound daemon if you are using alsa, which supports hardware mixing.
Old 09-03-2005, 01:24 PM   #4
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Rep: Reputation: 15
I had the same problem with alsa on three ubuntu boxes. Switching to ESD according to the instructions from bored2k ( on the ubuntu forums solved the problem. Oops, I'vejust realised that if you use Kubuntu ESD won't be of much use to you. But if anyone else is having static problems in Ubuntu this worked for me. I've copied them below:

Preferably for AC97 Sound

1. Install alsa-oss
2. Install alsa-headers
3. Make sure you have libesd0 and gstreamer0.8-esd installed. (if not, install)
4. Make sure esound and esound-common are installed. (if not, install)
5. Install alsa-base
6. Install alsa-utils
7. Install gstreamer0.8-alsa
8. Install libpt-plugins-alsa

Ok, next.
1. Right click on the little volume control in your top panel and the
choose Open volume control.
2a. *IF* it opens, you should see two tabs, one for OSS and the other
for Alsa. Make sure nothing is muted.
2b. If it does not open and instead gives you an error, let me know.

We're going to switch you to a sound daemon that allows multiple sounds.
1. In gstreamer-properties, change the Default Sink to output: ESD -
Enlightenment Sound Daemon (Why not alsa you ask? Because alsa makes
crackling noises with the ac97)
2. Change your Output plugin in XMMS to eSound output plugin. (You
also might want to think about using beep-media-player ; it's
essentially identical to xmms, uses same plugins and skins, only it's
made for gtk2 and it's much nicer.)
3. Enable your sound server startup.

Last edited by Steve50; 09-03-2005 at 01:26 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card makes no sound Dankles Linux - Hardware 2 09-09-2005 04:10 PM
Linux, Internet Radio and Static IP address webwolf70 Linux - Software 5 03-10-2005 01:10 AM
No sound using bt878 based radio card pkid Linux - Hardware 0 10-02-2004 01:49 AM
Sound problem (makes no sense) carlosinfl Fedora 6 07-20-2004 06:40 PM
old radio sound twcinpa Fedora 6 01-31-2004 10:20 AM > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 03:17 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration