LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 07-11-2007, 06:14 PM   #1
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: openSUSE 15.2, Microware OS-9, MX-19, Bodhi 5.1.0
Posts: 256

Rep: Reputation: 41
Tovid missing dependency


While trying to run "tovid" I encounter the following error.

Running command: makemenu -noask -quiet -overwrite -pal -dvd -align northwest -menu-title "My Movie" -menu-title-fontsize 32 -background "/home/ion/nef.jpg" -audio "/home/ion/bin/timer.wav" -length 10 -font "Helvetica" -fontsize 24 -textcolor "rgb(255,255,255)" -fontdeco '-stroke rgb(0,0,0) -strokewidth 1' -button-font "Helvetica" -button ">xxxx" -highlightcolor "rgb(255,255,0)" -selectcolor "rgb(255,0,0)" -button-outline "rgb(140,140,140)" -out "/tmp/Untitled_menu_1"
mpeg2enc MISSING!
mp2enc MISSING!

You are missing CORE tovid dependencies! Please nstall the above MISSING dependencies and try again. See tovid.wikia.com/wiki/Tovid_dependencies or
tovid.org for help.

These two dependencies are supposed to be ncluded in the mpegtools package. I had previously installed mpegtools using Yast and re-ran Yast to confirm that mpegtools is installed, but apparently these two files are missing and a file search does not locate them. Has anyone come across this problem?
 
Old 07-11-2007, 09:20 PM   #2
Mac_North
LQ Newbie
 
Registered: Mar 2005
Location: Colorado
Distribution: debian
Posts: 15

Rep: Reputation: 0
Which version are you using?

What does type -a mpeg2enc and type -a mp2enc tell you?

Last edited by Mac_North; 07-11-2007 at 09:25 PM.
 
Old 07-12-2007, 01:02 AM   #3
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: openSUSE 15.2, Microware OS-9, MX-19, Bodhi 5.1.0
Posts: 256

Original Poster
Rep: Reputation: 41
Quote:
Originally Posted by Mac_North
Which version are you using?

What does type -a mpeg2enc and type -a mp2enc tell you?
Suse 10.2 GM and tovid 0.30-0 pm 2

ion@zeus:~> type -a mpeg2enc
bash: type: mpeg2enc: not found
ion@zeus:~> type -a mp2enc
bash: type: mp2enc: not found
ion@zeus:~>
 
Old 07-12-2007, 01:40 AM   #4
Mac_North
LQ Newbie
 
Registered: Mar 2005
Location: Colorado
Distribution: debian
Posts: 15

Rep: Reputation: 0
mjpegtools not installed

Quote:
Originally Posted by ionmich
ion@zeus:~> type -a mpeg2enc
bash: type: mpeg2enc: not found
ion@zeus:~> type -a mp2enc
bash: type: mp2enc: not found
ion@zeus:~>
Strange. mpeg2enc and mp2enc are not installed, but mplex is (otherwise it would've been listed as well). All three are part of the mjpegtools, so they should be installed together. I'd check with your packager; it's not a tovid problem.
 
Old 07-12-2007, 02:01 AM   #5
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: openSUSE 15.2, Microware OS-9, MX-19, Bodhi 5.1.0
Posts: 256

Original Poster
Rep: Reputation: 41
There's a typo error in my posts. "mpegtools" should read "mjepgtools".
 
Old 07-12-2007, 02:43 AM   #6
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: openSUSE 15.2, Microware OS-9, MX-19, Bodhi 5.1.0
Posts: 256

Original Poster
Rep: Reputation: 41
Quote:
Originally Posted by Mac_North
Strange. mpeg2enc and mp2enc are not installed, but mplex is (otherwise it would've been listed as well). All three are part of the mjpegtools, so they should be installed together. I'd check with your packager; it's not a tovid problem.
You are right. The package my Yast used comes from Packman. It's mjpegtools-1.8.0-38.i586.rpm and it does not include the two files in question. Package mjpegtools-1.9.0rc2-1.i586.rpm from Sourceforge does include those files but Yast goes into dependency insanity when I try to install it. It looks like this is going to take some time to straighten out.

Thanks for pointing me in the right direction. I might have more questions later.
 
Old 07-12-2007, 04:23 AM   #7
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: openSUSE 15.2, Microware OS-9, MX-19, Bodhi 5.1.0
Posts: 256

Original Poster
Rep: Reputation: 41
I removed all the offending dependency software and installed mjpegtools-1.9.0rc2-1.i586.rpm from Sourceforge. Then I let Yast install tovid. The GUI ran properly but the DVD burning process errored out.

I sent in a bug report to the tovid forum. I noticed that you (Mac_North) are on that forum so I won't post the log output here.

Thanks for the help getting it running. I hope the tovid forum can help me move further on this project.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to tell yum missing dependency is actually there decrepit Fedora 2 02-04-2007 05:36 AM
Missing Dependency - libmysqlclient.so.15 bpneiman Fedora 4 11-01-2006 03:08 PM
Missing Dependency for libquicktime jborn Linux - General 1 06-25-2006 09:16 PM
yum missing dependencY puppet Linux - Software 6 10-26-2005 10:20 AM
dependency: missing libnautilus.so.2 - but it's there sonaural Linux - Software 5 09-01-2005 05:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 04:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration