LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 06-30-2008, 07:28 PM   #1
swampdog2002
Member
 
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 400

Rep: Reputation: 33
Touchpad not working in openSUSE 11.0


Running GNOME under openSUSE 11, I am unable to use my touchpad for controlling the mouse cursor on-screen. This seems to only affect one profile, as I logged on as another user and can use the touchpad to control the mouse w/o issue. I checked under Control Center > Touchpad and Enable Touchpad is selected, however I cannot control the mouse cursor under my main profile. I don't recall doing anything before to disable this, and also under Sessions in Control Center the startup program Touchpad is selected there. Again, this is only affecting my main profile, as I set up another account for testing and was able to control the cursor with the touchpad. Any ideas of what I need to check to resolve this? Thanks.

Also, in addition to this, I can use the mouse buttons associated with the touchpad within my main account to control mouse button clicks w/o any problems, just the cursor is unable to move.

Last edited by swampdog2002; 06-30-2008 at 07:29 PM.
 
Old 06-30-2008, 08:45 PM   #2
swampdog2002
Member
 
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 400

Original Poster
Rep: Reputation: 33
Update: OK, now it is not working for my other profiles as well when logged into them. The only time that the touchpad can move the mouse cursor is at the login screen, so I am assuming that it has something to do with a setting within GNOME itself?
 
Old 06-30-2008, 11:32 PM   #3
swampdog2002
Member
 
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 400

Original Poster
Rep: Reputation: 33
Update #2: After logging out of GNOME and into a KDE session, I was able to correctly use the touchpad in all its functionality. Also, I attempted a clean install of openSUSE 11 with the default GNOME installation (in order to rule out any updated packages), and the problem still persisted. Just to inform you, this is installed on a Gateway 450SX4 laptop with a Synaptic Touchpad (as according to the /etc/X11/xorg.conf file). ANyone else running GNOME and having issues with their touchpad mouse?
 
Old 07-01-2008, 10:50 AM   #4
swampdog2002
Member
 
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 400

Original Poster
Rep: Reputation: 33
Update #3: OK, I found a resolution to the problem, but do not understand the implications. If I go to Control Center > Sessions, and then deselect Touchpad from the "Startup Programs" tab, whenever I restart my session I can successfully navigate the screen with the cursor using the touchpad. One item that I found interesting was when I selected the Edit button when highlighting the Touchpad item from the list. An "Edit Startup Program" window appears, and in the Command field the following is displayed:
Code:
gsynaptics-init --sm-disable
I am not certain of the parameters of this command, but the portion that has --sm-disable is sort of concerning me. Does anyone know what this option does? It would appear that something within this command is conflicting with something else on my system using the GNOME session, but am unsure what it could be.

Last edited by swampdog2002; 07-01-2008 at 10:53 AM.
 
Old 07-03-2008, 01:38 PM   #5
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Rep: Reputation: 32
It seems seems there's all sorts of problems with touchpad and gnome under suse 11.0

KDE seems to work 100% OK.

If you want to try kde download / install Ksynaptics,

You can then control the touchpad anyway you want -- I usually disable the whole thing anyway -- I hate touchpads -- the old fashioned IBM laptops used to have a little button embedded somewhere in the keyboard which worked a treat but modern laptops have abandoned that idea.

I can't say that I've ever been a real fan of GNOME -- maybe having got too used to Windows in the past switching to Linux with KDE wasn't such a great problem.

The only thing I can currently say about Gnome is that it seems to be trying to be more like VISTA --which I absolutely HATED.

However getting back to the point again many other posts have mentioned problems with SUSE 11.0 and GNOME whilst the KDE interface seems to work OK (and if you don't like KDE 4 you can still use KDE 3.5).

Cheers

-K

Last edited by 1kyle; 07-03-2008 at 01:40 PM.
 
Old 07-03-2008, 07:48 PM   #6
swampdog2002
Member
 
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 400

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by 1kyle View Post
The only thing I can currently say about Gnome is that it seems to be trying to be more like VISTA --which I absolutely HATED.
The version of GNOME that is included by default with openSUSE 11.0 seems pretty basic to me, and does not appear to resemble Vista much at all (which is one of the reasons I like this window manager). Actually, I've felt in a manner similar about KDE, where I felt it was too much like MS Windows for my liking.

Anyway, after finally resolving the touchpad issue in GNOME, now whenever I log into KDE the touchpad will not work there. Go figure . It seems that it is one or the other, and not both. I am not a fan of touchpads myself either, but I occasionally use this laptop in other parts of the household area using wi-fi, and it is more convenient to use the touchpad than to lug around a mouse with it. Usually, I have a Logitech USB mouse connected to the port replicator for my usual browsing needs.

Last edited by swampdog2002; 07-03-2008 at 07:49 PM.
 
Old 07-09-2008, 10:48 AM   #7
sara_miska
LQ Newbie
 
Registered: Jul 2008
Posts: 2

Rep: Reputation: 0
Hello there!

I had EXACTLY the same problem and I thank you very much for solving it!!!

I'm new to linux and such stuff makes me wanna go back to windows, but I resisted

Anyway, at first my touch pad worked fine, then I installed some software... I'm not sure what caused the problem, but I think it might have to do something with KDE (the problem started sometime after I installed Amarok). Like I said, I'm new around here and don't really have a clue, this is just a feeling I got when I tried to remember what did I install before the touch pad crashed.

I'm not a fan of touch pads, either, but you can't really use your mouse in bed or on a train, can you And it HAS TO WORK, KDE, Gnome or whatever. The answer to the problem cannot be: just switch to KDE and it'll work fine! That's why the forums are here.

Thanx again!
 
Old 07-09-2008, 12:14 PM   #8
swampdog2002
Member
 
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 400

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by sara_miska View Post
I had EXACTLY the same problem and I thank you very much for solving it!!!
I didn't actually solve the problem, only found a workaround to the issue. Now, as I mentioned earlier, if I change my session from GNOME to KDE, now the touchpad does not work in KDE after performing the workaround in GNOME. I suppose that now I need ksynaptics for this to work in KDE now. The touchpad should have been working with its default parameters rather than having to disable a startup item in order to make it work properly in GNOME. There are quite a few others that have issues similar to this. With that, I don't understand how this could have gone unnoticed during development of openSUSE 11.0, since I don't recall having this issue in 10.3 on the same laptop.

Last edited by swampdog2002; 07-09-2008 at 12:15 PM.
 
Old 07-10-2008, 02:40 AM   #9
sara_miska
LQ Newbie
 
Registered: Jul 2008
Posts: 2

Rep: Reputation: 0
I found this yesterday:

http://forums.opensuse.org/hardware/...-touchpad.html
 
Old 07-11-2008, 09:04 PM   #10
Reefcrazed
Member
 
Registered: May 2004
Distribution: Debian Stretch
Posts: 144

Rep: Reputation: 15
I had this problem on all of my laptops on OpenSuse 11.0 with Gnome. I just found using a regular mouse I could change the settings in Control Panel and increase/decrease sensitivity and turning off some of the options fixed the glidepad on every single laptop.
 
Old 07-13-2008, 10:01 AM   #11
jimbo1708
Member
 
Registered: Jan 2007
Location: Pennsylvania
Distribution: Ubuntu 8.10 Server/9.04 Desktop, openSUSE 11.1
Posts: 154

Rep: Reputation: 31
Control Center >> Touchpad >> Acceleration Tab

Adjust the acceleration so it is greater than none and make sure the max speed is more than the minimum speed.

- Jim
 
Old 09-11-2008, 03:52 PM   #12
tangram
LQ Newbie
 
Registered: Oct 2007
Posts: 5

Rep: Reputation: 0
Thanks for the solution swampdog2002!

That's the Opensource spirit afterall.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
opensuse 10.3 insprion 1720 touchpad scroll problem emg Linux - Hardware 0 10-21-2007 04:46 PM
IBM touchpad is not working santhosh.bachu Linux - Laptop and Netbook 1 08-02-2006 07:28 AM
Touchpad not working RockmanExe Slackware 3 11-25-2005 08:34 AM
TouchPad not working any more rsreeni Linux - Hardware 1 05-29-2005 06:48 AM
Touchpad stopped working!!! king_nothingzzz Linux - Hardware 8 03-01-2004 04:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 01:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration