LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 06-10-2005, 02:49 AM   #1
El Basto
Member
 
Registered: Jun 2004
Location: Thousand Oaks, CA
Distribution: Suse 9.2, Slackware
Posts: 76

Rep: Reputation: 15
Strange networking problem in 9.2


I am using Suse 9.2 Pro on a Dell Inspiron 6000 notebook. It has the typical Broadcom ethernet and an Intel Pro 2200BG wireless card. Suse set my ethernet up as eth0 and the wireless as eth1. My router IP is 192.168.1.1

If I restart the network ("/etc/init.d/network restart") w/o the ethernet plugged in, obviously eth0 ends up with no IP address and eth1 ends up with the IP address of 192.168.1.101. The default gateway is set to 192.168.1.1 (As I configured it that way in YaST and the file /etc/sysconfig/network/routes contains "default 192.168.1.1 - -". But /etc/resolv.conf is empty. Not only am I not able to resolve names but even if I go on another computer, look up the IP of google.com, and then use that IP directly instead of "www.google.com" it is still unable to connect to the site. But I know the card works because if I type "192.168.1.1" into the browser, I get the router login prompt.

If I reconnect my ethernet and then restart the network ("/etc/init.d/network restart") everything works fine. /etc/resolv.conf contains the nameservers and I am able to connect to any site just fine.

Also, in the firewall configuration in YaST, setting eth1 to external or stopping the firewall completely has no effect on making wireless work.

I have a feeling somewhere hidden in /etc is a file that is telling Suse to use eth0 by default. But I am still baffled that I can connect to my router but nothing else when using only wireless.

Take a second to digest all of that. Any ideas?
 
Old 06-10-2005, 03:03 AM   #2
lacerto
Member
 
Registered: Oct 2003
Location: South London
Distribution: Gentoo.
Posts: 297

Rep: Reputation: 30
Hi - Could you maybe post up the the relevent ifcfg- files,?
L
 
Old 06-10-2005, 03:14 AM   #3
El Basto
Member
 
Registered: Jun 2004
Location: Thousand Oaks, CA
Distribution: Suse 9.2, Slackware
Posts: 76

Original Poster
Rep: Reputation: 15
Yeah sure,

Here is ifcfg-eth0, the ethernet card...

BOOTPROTO='dhcp'
MTU=''
REMOTE_IPADDR=''
STARTMODE='hotplug'
UNIQUE='svHJ.47sYe_bIIi6'
USERCONTROL='no'
_nm_name='bus-pci-0000:03:00.0'



and here is ifcfg-eth1, the wireless card

BOOTPROTO='dhcp'
MTU=''
REMOTE_IPADDR=''
STARTMODE='onboot'
UNIQUE='5FRj.f5GwhWSfVf1'
USERCONTROL='yes'
WIRELESS_AP=''
WIRELESS_AUTH_MODE='open'
WIRELESS_BITRATE='auto'
WIRELESS_CHANNEL=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_ESSID=''
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0=''
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_POWER='yes'
WIRELESS_WPA_PSK=''
_nm_name='bus-pci-0000:03:03.0'


Thanks for the quick response!
 
Old 06-10-2005, 03:41 AM   #4
lacerto
Member
 
Registered: Oct 2003
Location: South London
Distribution: Gentoo.
Posts: 297

Rep: Reputation: 30
Mmm..I had the problem with similar symptoms when I was using SUSE 9.2, but it may have had a different cause. (I changed the startmode for eth0 to 'manual' or possibly 'ifplugd'). Worth tying though.

But you mention that you are not getting nameservers in resolv.conf, which may indicate something else.

Will check my notes on this, as I've still got them knocking about the office. Will be there in an hour or so.

L
 
Old 06-10-2005, 04:18 AM   #5
El Basto
Member
 
Registered: Jun 2004
Location: Thousand Oaks, CA
Distribution: Suse 9.2, Slackware
Posts: 76

Original Poster
Rep: Reputation: 15
Wow, setting eth0 to manual solved everything. I guess I was making that problem much harder then it really was.

Thanks a lot!

Well, have fun at work. I'm going to bed (2:15 Pacific time)
 
Old 06-10-2005, 04:40 AM   #6
lacerto
Member
 
Registered: Oct 2003
Location: South London
Distribution: Gentoo.
Posts: 297

Rep: Reputation: 30
Glad it worked. I think eth0 starts anyway if not set to manual, and so confuses things.

Can't remember if SUSE had ifplugd in 9.2, but if it did, then that is the most elegant solution. i.e. eth0 only starts if a cable is connected to it.

L
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Networking Problem (super slowness) starcastic Linux - Networking 13 03-02-2005 06:10 PM
Strange networking problem webdwarf Debian 2 08-02-2004 01:30 AM
Strange networking problem-or I hate wireless aclaunch Linux - Wireless Networking 1 01-18-2004 04:51 PM
Strange networking.. nibbana Linux - Networking 7 07-24-2003 01:15 PM
strange networking issues in mandrake 9.1 sirohmsford Linux - Networking 1 05-30-2003 07:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 01:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration