LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 05-26-2008, 08:46 PM   #1
Raccoon1400
Member
 
Registered: Apr 2008
Distribution: Arch
Posts: 37

Rep: Reputation: 15
openSuse 10.3: new install won't boot


i just installed 10.3 on an old box from a dvd from the linux format magazine. It has kde4.
I tried installing to hdb4 and hda2 and when it boots, it waits for /dev/hda2 or /dev/hdb4 to appear. It times out, and gives me this prompt. Hardly any commands work at this prompt. It never booted successfully. I installed, rebooted and this happens.
Code:
$
There are two hard drives, and two other OSs on each.

Any help?

Last edited by Raccoon1400; 05-26-2008 at 09:35 PM.
 
Old 05-27-2008, 01:40 AM   #2
htnakirs
Member
 
Registered: Mar 2007
Posts: 239

Rep: Reputation: 34
Prior to this prompt, there would be an error message which will tell you precisely what is wrong. Put it here.

Most probably this would be a result of some of the partitions having errors on them. You can circumvent this situation by modifying the etc/fstab file to prevent checking of non boot partitions at boot time. I usually delete entries in the fstab relating to non essential partitions.
 
Old 05-27-2008, 05:26 AM   #3
Raccoon1400
Member
 
Registered: Apr 2008
Distribution: Arch
Posts: 37

Original Poster
Rep: Reputation: 15
Code:
ide: Assuming 33MHz system bus speed for P10 modes; override with idebus=xx
resume device not found (ignoring)
Waiting for device /dev/hda2 to appear..............................Could not
find /dev/hda2
Want me to fall back to /dev/hda2? (Y/n)

Waiting for device /dev/hda2 to appear..............................not found
--exiting to /bin/sh
sh: no job control in this shell
$

Here it is. hda2 is the root partition.
 
Old 05-27-2008, 07:47 AM   #4
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
In OpenSuse 10.3, the drive and partition numbering should not be /dev/hdaX or /dev/hdbX. With the kernel in 10.3, your drives should now be /dev/sda and /dev/sdb (this applies to IDE, SATA, and SCSI drives).

Edit /etc/fstab, and change all references to hda or hdb to sda and sdb respectively.

Then check /boot/grub/menu.lst. In the kernel line, make sure that root=/dev/sda2 is there, and not root=/dev/hda2.

If you are booting into command-line mode, su to root and run 'fdisk -l' to see the disks and partitions. sda2 should be flagged with an * in the Boot column. There should not be entries for hda or hdb.

Last edited by bigrigdriver; 05-27-2008 at 07:50 AM.
 
Old 05-27-2008, 08:05 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
Can you boot from the DVD in repair mode? Please post your /etc/fstab.

<edit> Ups, coming a little late to answer, already good posts here. @bigrigdriver On my box /etc/fstab uses partition-ids (twenty-plus letters long unwieldy things), but I never noticed sdx notation in menu.lst, will check it...

Last edited by JZL240I-U; 05-27-2008 at 08:46 AM.
 
Old 05-27-2008, 08:20 AM   #6
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
I just checked my own, and had my memory refreshed for me. When I installed 10.3, I found the /dev/disk/by-id thing too cumbersome for my taste, so I commented out that line, and entered a new one with the /dev/sdXY that I'm more confortable with. I did the same in my /etc/fstab.

But, the point is that if Raccoon1400 is using /dev/hda or /dev/hdb designations in fstab or menu.lst, it won't work. They must be converted to sda and sdb.
 
Old 05-27-2008, 03:30 PM   #7
Raccoon1400
Member
 
Registered: Apr 2008
Distribution: Arch
Posts: 37

Original Poster
Rep: Reputation: 15
This is and ide computer. Isn't sda for sata?
 
Old 05-27-2008, 06:51 PM   #8
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 9,307

Rep: Reputation: 2057Reputation: 2057Reputation: 2057Reputation: 2057Reputation: 2057Reputation: 2057Reputation: 2057Reputation: 2057Reputation: 2057Reputation: 2057Reputation: 2057
Opensuse uses sda, sdb, etc. whether or not it is ide,scsi,sata. Just installed it a few months ago and noticed this. My computer also is only 2 ide drives and partitions are all labelled 'sda' or 'sdb'.
 
Old 05-27-2008, 08:38 PM   #9
Raccoon1400
Member
 
Registered: Apr 2008
Distribution: Arch
Posts: 37

Original Poster
Rep: Reputation: 15
I'll see if I have time to try that tomorrow. I have been extremely busy lately.
 
Old 05-28-2008, 08:01 PM   #10
Raccoon1400
Member
 
Registered: Apr 2008
Distribution: Arch
Posts: 37

Original Poster
Rep: Reputation: 15
Ok . Here goes.
I tried booting from uuid and /dev/sda2. Neither worked.

SuSE's fstab:
Code:
/dev/disk/by-id/ata-MAXTOR_6L040J2_662219027643-part2 /                    ext3       acl,user_xattr        1 1
/dev/disk/by-id/ata-MAXTOR_6L040J2_662219027643-part5 swap                 swap       defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
And the grub entry I try to boot with:
Code:
title		openSUSE 10.3 (i586) (on /dev/sda2)
root		(hd0,1)
kernel		/boot/vmlinuz-2.6.22.13-0.3-default root=UUID=77fe97a0-8ca3-4b11-b344-4d0c8ec239aa ro quiet
initrd		/boot/initrd-2.6.22.13-0.3-default
boot
 
Old 05-29-2008, 12:37 AM   #11
htnakirs
Member
 
Registered: Mar 2007
Posts: 239

Rep: Reputation: 34
Who created the grub menu? It doesn't seem to be the creation of Opensuse, during installation.
The error message refers to hda2 - something that doesn't appear in the fstab or grub menu. Can you post the entire fstab and grub menu files?

I am assuming that the grub was created by another distro, and you tried to include the Opensuse installation in that menu. The difference in hard disk nomenclature between distros is to blame here. I suggest replacing the "root(hd0,1)" entry in the grub menu to " root /dev/disk/by-id/ata-MAXTOR_6L040J2_662219027643-part2" as shown in fstab.

Last edited by htnakirs; 05-29-2008 at 12:47 AM.
 
Old 05-29-2008, 12:57 AM   #12
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
Quote:
Originally Posted by htnakirs View Post
Who created the grub menu? It doesn't seem to be the creation of Opensuse, during installation....
If, what htnakirs assumes here is right, your easiest course would be to pop in the install CD/DVD and boot it in repair mode. It then offers to repair the boot sequence and that should be it...
 
Old 05-29-2008, 05:54 AM   #13
Raccoon1400
Member
 
Registered: Apr 2008
Distribution: Arch
Posts: 37

Original Poster
Rep: Reputation: 15
The grub entry was generated by ubuntu.I modified it a bit. The original SuSE grub didn't work either. How could we change fstab not to do disk by id? I never succesfully booted this install.

Original grub entry:
title openSUSE
Code:
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.22.13-0.3-default root=/dev/disk/by-id/ata-MAXTOR_6L040J2_662219027643-part2 resume=/dev/hda5 splash=silent showopts
    initrd /boot/initrd-2.6.22.13-0.3-default
With this entry, it waits for /dev/disk/by_id/.... to appear, fails and falls back to /dev/hda2, and fails again.

That was the entire fstab.
Here is the entire menu.lst
Code:
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default		0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
#timeout		10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title		Windows 95/98/NT/2000
# root		(hd0,0)
# makeactive
# chainloader	+1
#
# title		Linux
# root		(hd0,1)
# kernel	/vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=140b6ac9-c5ce-4526-9e43-77d5db988170 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title		Ubuntu 7.10, kernel 2.6.22-14-generic
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=140b6ac9-c5ce-4526-9e43-77d5db988170 ro quiet splash
initrd		/boot/initrd.img-2.6.22-14-generic
quiet

title		Ubuntu 7.10, kernel 2.6.22-14-generic (recovery mode)
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=140b6ac9-c5ce-4526-9e43-77d5db988170 ro single
initrd		/boot/initrd.img-2.6.22-14-generic

#title		Ubuntu 7.10, memtest86+
#root		(hd0,0)
#kernel		/boot/memtest86+.bin
#quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title		Other operating systems:
root


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/hda6.
title		Ubuntu 8.04, kernel 2.6.24-16-generic (on /dev/hda6)
root		(hd0,5)
kernel		/boot/vmlinuz-2.6.24-16-generic root=UUID=8efa6146-2ddf-47a4-9dfc-8e59faddf84f ro quiet splash 
initrd		/boot/initrd.img-2.6.24-16-generic
boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/hda6.
title		Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode) (on /dev/hda6)
root		(hd0,5)
kernel		/boot/vmlinuz-2.6.24-16-generic root=UUID=8efa6146-2ddf-47a4-9dfc-8e59faddf84f ro single 
initrd		/boot/initrd.img-2.6.24-16-generic
boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/hdb1.
title		Yoper Linux - 2.6.21_yos-47 (on /dev/hdb1)
root		(hd1,0)
kernel		/boot/vmlinuz-2.6.21_yos-47 ro root=/dev/hda1 rhgb quiet nofscheck 
initrd		/boot/initrd.img-2.6.21_yos-47
boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/hdb1.
#title		Yoper Linux - 2.6.21_yos-47 - Failsafe (on /dev/hdb1)
#root		(hd1,0)
#kernel		/boot/vmlinuz-2.6.21_yos-47 ro root=/dev/hda1 ramdisk=16384 noacpi noapm showopts ide=nodma nofscheck failsafe 
#initrd		/boot/initrd.img-2.6.21_yos-47
#boot

title openSUSE
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.22.13-0.3-default root=/dev/disk/by-id/ata-MAXTOR_6L040J2_662219027643-part2 resume=/dev/hda5 splash=silent showopts
    initrd /boot/initrd-2.6.22.13-0.3-default

# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/hdb4.
title		openSUSE 10.3 (i586) (on /dev/sda2)
root		(hd0,1)
kernel		/boot/vmlinuz-2.6.22.13-0.3-default root=UUID=77fe97a0-8ca3-4b11-b344-4d0c8ec239aa ro quiet
initrd		/boot/initrd-2.6.22.13-0.3-default
boot

title		openSUSE 10.3 (i586) (on /dev/hdb4)
root		(hd1,3)
kernel		/boot/vmlinuz root=/dev/hdb4 
initrd		/boot/initrd
boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/hdb4.
#title		openSUSE 10.3 (i586) (on /dev/hdb4)
#root		(hd1,3)
#kernel		/boot/vmlinux-2.6.22.13-0.3-default.gz root=/dev/hdb4 
#boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/hdb5.
title		Slackware Linux (on /dev/hdb5)
root		(hd1,4)
kernel		/boot/vmlinuz root=/dev/hdb5 ro vga = 773 
boot
 
Old 05-29-2008, 07:21 AM   #14
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,439

Rep: Reputation: Disabled
Where is your /boot? Extra partition or directory? GRUB expects a stanza telling it where /boot is. In case you are using Ubuntu's GRUB with SuSE's menu.lst you are nuked right here...

See:
http://www.gnu.org/software/grub/man...le-name-syntax

Last edited by JZL240I-U; 05-29-2008 at 07:24 AM.
 
Old 05-29-2008, 02:57 PM   #15
Raccoon1400
Member
 
Registered: Apr 2008
Distribution: Arch
Posts: 37

Original Poster
Rep: Reputation: 15
/ and /boot are on the same partition
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
opensuse 10.2 and 10.3beta install CD/DVD boot problems on K6 system TurboI SUSE / openSUSE 1 09-19-2007 06:44 AM
failure to install opensuse 10.2 after boot from cd digitaldivider667 Linux - Hardware 5 06-25-2007 09:45 AM
dual boot xp n opensuse,,,need to install my own kernel version,2.0-2.4 ace.adi Linux - Newbie 1 03-03-2007 06:02 PM
Have OpenSuSE only boot from floppy after install TheTK421 SUSE / openSUSE 1 02-23-2006 08:12 PM
Install/Boot problem with OpenSuSE 10 FKereki Linux - Laptop and Netbook 0 10-19-2005 11:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 07:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration