LinuxQuestions.org
Review your favorite Linux distribution.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 07-24-2009, 05:16 AM   #1
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Rep: Reputation: 107Reputation: 107
Question find out make of ethernet card in Solaris 9


Hi,

How can we find out make of ethernet card in Solaris 9 ?

Do we have something like (like Linux) in /etc/sysconfig/hwconf in Solaris ?
 
Old 07-24-2009, 06:30 AM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Unlike Linux where all NICs are named eth<something>, Solaris uses the driver name as device name, so you can have a clue of the NIC make(s) by running ifconfig -a.

Boot messages might also give some information about the hardware used (dmesg).

prtconf and prtdiag (SPARC only with Solaris 9) are also providing information.
 
Old 07-24-2009, 07:52 AM   #3
gregoreo
LQ Newbie
 
Registered: Jul 2009
Location: DC area, USA
Distribution: CentOS
Posts: 1

Rep: Reputation: 0
On any networked device the MAC can often identify a manufacturer:
standards.ieee.org/regauth/oui/oui.txt
See also standards.ieee.org/regauth/oui/
A screwdriver may be necessary to determine both make and model, which is what I usually need to successfully seek online advice and firmware updates.
- Greg J
 
Old 07-28-2009, 11:07 PM   #4
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by jlliagre View Post
Unlike Linux where all NICs are named eth<something>, Solaris uses the driver name as device name, so you can have a clue of the NIC make(s) by running ifconfig -a.

Boot messages might also give some information about the hardware used (dmesg).

prtconf and prtdiag (SPARC only with Solaris 9) are also providing information.

None of these commands could help me out.
Any other idea.
 
Old 07-29-2009, 03:28 AM   #5
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
It's hard to tell without you providing any clue.

Why are you asking ?

Is your interface recognized by the system ?

Please post "prtconf -d" output.
 
Old 07-29-2009, 10:00 PM   #6
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by jlliagre View Post
It's hard to tell without you providing any clue.

Why are you asking ?

Is your interface recognized by the system ?

Please post "prtconf -d" output.
Hi jlliagre,

I am trying to find out "make" of the Ethernet card.

Like in Linux it is in /etc/sysconfig/hwconf file.

Code:
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: tg3
desc: "Broadcom Corporation|NetXtreme BCM5705_2 Gigabit Ethernet"
network.hwaddr: 00:13:21:19:6D:CE
vendorId: 14e4
deviceId: 1654
subVendorId: 103c
subDeviceId: 1654
pciType: 1
pcibus:  4
pcidev:  4
pcifn:  0



prtconf output
Code:
# prtconf -d
prtconf: illegal option -- d
prtconf [ -F | -V | -x | -vpPD ]
#

# uname -a
SunOS ussd-gw 5.9 Generic_118558-25 sun4u sparc SUNW,Sun-Fire-280R
 
Old 07-30-2009, 03:27 PM   #7
Blinker_Fluid
Member
 
Registered: Jul 2003
Location: Clinging to my guns and religion.
Posts: 683

Rep: Reputation: 63
What about this command:
Code:
 prtpicl -c network -v | egrep 'name|instance'
 
Old 07-30-2009, 04:25 PM   #8
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Indeed.
"prtconf -D" might also provide some clues.
 
Old 07-31-2009, 01:23 AM   #9
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by Blinker_Fluid View Post
What about this command:
Code:
 prtpicl -c network -v | egrep 'name|instance'

Output
Code:
#  prtpicl -c network -v | egrep 'name|instance'
  :driver-name   eri
  :binding-name  pci108e,1101
  :instance      0
  :name  network

Is this "eri" the make of the ethernet card like broadcom ??
 
Old 07-31-2009, 01:24 AM   #10
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by jlliagre View Post
Indeed.
"prtconf -D" might also provide some clues.
Yeah, prtconf -D also gives the same result.

Code:
#  prtconf -D | egrep 'network, instance'
        network, instance #0 (driver name: eri)
 
Old 07-31-2009, 03:29 AM   #11
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
http://www.pcidatabase.com/search.ph..._search=Search will tell you the card manufacturer is (not surprisingly) "Sun Microsystems" and looking for 1101 in http://www.pcidatabase.com/vendor_details.php?id=526 will tell you it is a using rio chipset.

"man eri" would have tell you the same.
 
Old 07-31-2009, 11:51 AM   #12
Blinker_Fluid
Member
 
Registered: Jul 2003
Location: Clinging to my guns and religion.
Posts: 683

Rep: Reputation: 63
Quote:
Originally Posted by vikas027 View Post
Output
Code:
#  prtpicl -c network -v | egrep 'name|instance'
  :driver-name   eri
  :binding-name  pci108e,1101
  :instance      0
  :name  network

Is this "eri" the make of the ethernet card like broadcom ??
The eri is the type. You will use it when you configure the NIC (for example in your case you would create /etc/hostname.eri0).
 
Old 08-04-2009, 05:52 AM   #13
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Thumbs up

Quote:
Originally Posted by jlliagre View Post
http://www.pcidatabase.com/search.ph..._search=Search will tell you the card manufacturer is (not surprisingly) "Sun Microsystems" and looking for 1101 in http://www.pcidatabase.com/vendor_details.php?id=526 will tell you it is a using rio chipset.

"man eri" would have tell you the same.
Kewl, good learning for me. Exactly, what I was looking for. Thanks a ton
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ethernet and wirless card cant find downsys Linux - Hardware 2 12-06-2005 10:59 AM
Solaris newbie -- help with 3COM ethernet card btmiller Solaris / OpenSolaris 2 05-04-2004 04:23 PM
redhat suddenly can't find ethernet card blahJake Linux - Networking 1 02-12-2004 01:47 PM
How to find ethernet card I/O address palanisaravanan Linux - Newbie 2 12-29-2003 12:53 PM
SuSE7 Cannot find ethernet card Rutnut Linux - Newbie 1 06-06-2001 05:31 AM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 07:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration