LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Solaris / OpenSolaris (https://www.linuxquestions.org/questions/solaris-opensolaris-20/)
-   -   find out make of ethernet card in Solaris 9 (https://www.linuxquestions.org/questions/solaris-opensolaris-20/find-out-make-of-ethernet-card-in-solaris-9-a-742428/)

vikas027 07-24-2009 05:16 AM

find out make of ethernet card in Solaris 9
 
Hi,

How can we find out make of ethernet card in Solaris 9 ?

Do we have something like (like Linux) in /etc/sysconfig/hwconf in Solaris ?

jlliagre 07-24-2009 06:30 AM

Unlike Linux where all NICs are named eth<something>, Solaris uses the driver name as device name, so you can have a clue of the NIC make(s) by running ifconfig -a.

Boot messages might also give some information about the hardware used (dmesg).

prtconf and prtdiag (SPARC only with Solaris 9) are also providing information.

gregoreo 07-24-2009 07:52 AM

On any networked device the MAC can often identify a manufacturer:
standards.ieee.org/regauth/oui/oui.txt
See also standards.ieee.org/regauth/oui/
A screwdriver may be necessary to determine both make and model, which is what I usually need to successfully seek online advice and firmware updates.
- Greg J

vikas027 07-28-2009 11:07 PM

Quote:

Originally Posted by jlliagre (Post 3618725)
Unlike Linux where all NICs are named eth<something>, Solaris uses the driver name as device name, so you can have a clue of the NIC make(s) by running ifconfig -a.

Boot messages might also give some information about the hardware used (dmesg).

prtconf and prtdiag (SPARC only with Solaris 9) are also providing information.


None of these commands could help me out.
Any other idea.

jlliagre 07-29-2009 03:28 AM

It's hard to tell without you providing any clue.

Why are you asking ?

Is your interface recognized by the system ?

Please post "prtconf -d" output.

vikas027 07-29-2009 10:00 PM

Quote:

Originally Posted by jlliagre (Post 3623926)
It's hard to tell without you providing any clue.

Why are you asking ?

Is your interface recognized by the system ?

Please post "prtconf -d" output.

Hi jlliagre,

I am trying to find out "make" of the Ethernet card.

Like in Linux it is in /etc/sysconfig/hwconf file.

Code:

class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: tg3
desc: "Broadcom Corporation|NetXtreme BCM5705_2 Gigabit Ethernet"
network.hwaddr: 00:13:21:19:6D:CE
vendorId: 14e4
deviceId: 1654
subVendorId: 103c
subDeviceId: 1654
pciType: 1
pcibus:  4
pcidev:  4
pcifn:  0




prtconf output
Code:

# prtconf -d
prtconf: illegal option -- d
prtconf [ -F | -V | -x | -vpPD ]
#

# uname -a
SunOS ussd-gw 5.9 Generic_118558-25 sun4u sparc SUNW,Sun-Fire-280R


Blinker_Fluid 07-30-2009 03:27 PM

What about this command:
Code:

prtpicl -c network -v | egrep 'name|instance'

jlliagre 07-30-2009 04:25 PM

Indeed.
"prtconf -D" might also provide some clues.

vikas027 07-31-2009 01:23 AM

Quote:

Originally Posted by Blinker_Fluid (Post 3625945)
What about this command:
Code:

prtpicl -c network -v | egrep 'name|instance'


Output
Code:

#  prtpicl -c network -v | egrep 'name|instance'
  :driver-name  eri
  :binding-name  pci108e,1101
  :instance      0
  :name  network


Is this "eri" the make of the ethernet card like broadcom ??

vikas027 07-31-2009 01:24 AM

Quote:

Originally Posted by jlliagre (Post 3625999)
Indeed.
"prtconf -D" might also provide some clues.

Yeah, prtconf -D also gives the same result.

Code:

#  prtconf -D | egrep 'network, instance'
        network, instance #0 (driver name: eri)


jlliagre 07-31-2009 03:29 AM

http://www.pcidatabase.com/search.ph..._search=Search will tell you the card manufacturer is (not surprisingly) "Sun Microsystems" and looking for 1101 in http://www.pcidatabase.com/vendor_details.php?id=526 will tell you it is a using rio chipset.

"man eri" would have tell you the same.

Blinker_Fluid 07-31-2009 11:51 AM

Quote:

Originally Posted by vikas027 (Post 3626287)
Output
Code:

#  prtpicl -c network -v | egrep 'name|instance'
  :driver-name  eri
  :binding-name  pci108e,1101
  :instance      0
  :name  network


Is this "eri" the make of the ethernet card like broadcom ??

The eri is the type. You will use it when you configure the NIC (for example in your case you would create /etc/hostname.eri0).

vikas027 08-04-2009 05:52 AM

Quote:

Originally Posted by jlliagre (Post 3626380)
http://www.pcidatabase.com/search.ph..._search=Search will tell you the card manufacturer is (not surprisingly) "Sun Microsystems" and looking for 1101 in http://www.pcidatabase.com/vendor_details.php?id=526 will tell you it is a using rio chipset.

"man eri" would have tell you the same.

Kewl, good learning for me. Exactly, what I was looking for. Thanks a ton :)


All times are GMT -5. The time now is 01:36 PM.