LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices


Reply
  Search this Thread
Old 09-17-2005, 09:05 AM   #1
zeroz52
Member
 
Registered: Feb 2005
Distribution: Slackware 10.2
Posts: 121

Rep: Reputation: 15
10.2 Error during startup please help me


This is my first Slackware install, everything went fine until I rebooted and this is what I get:

\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\

Warning: couldn't open /etc/fstab: No such file or directory
/sbin/e2sck: Is a directory while trying to open /
/:
The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it reall contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt and you might try running e2fsck w/ an alternate superblock:
e2fsck -b 9183 <device>

An error occured during the root filesystem check. you will be given a chance to log into the system in single-user mode to fix the problem.

If you are using the ext2 filesystem, running 'e2fsck -v -y <partition> might help.

\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\

I'm not sure what is wrong. I followed the handbook, and everything went really smoothly. Here is my setup:

/dev/hdb1 Linux Swap 1G
/dev/hdb2 /
/dev/hdb3 /home

I did go thru and turn the swapon. I did the "expert" mode when configuring LILO. Set it on MBR (/dev/hda1) and set it to boot
/dev/hda1 WinXP
/dev/hdb2 / for Slackware

I used reiserfs as my filesystem on all linux partitions.

I don't know if this could have caused a problem, but once I finished configuring LILO it went to the root login, I set my root password. I couldn't remember how to exit out properly at the prompt (it was really late and I was stupid) and reboot so I did a hard restart. Really dumb I know. What is the correct proceedure, im a moron.

Thanks for the help it is greatly appreciated.
 
Old 09-17-2005, 09:26 AM   #2
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
The MBR isn't on hda1 but rather hda, but I doubt that's the problem. If you post what's in /etc/fstab, /etc/lilo.conf and the result from fdisk -l it would be easier to figure out what's going wrong.
 
Old 09-17-2005, 09:31 AM   #3
zeroz52
Member
 
Registered: Feb 2005
Distribution: Slackware 10.2
Posts: 121

Original Poster
Rep: Reputation: 15
Thanks for the reply, I will post those asap. Gotta get some grub (not the boot loader)



Last edited by zeroz52; 09-17-2005 at 09:52 AM.
 
Old 09-17-2005, 09:54 AM   #4
zeroz52
Member
 
Registered: Feb 2005
Distribution: Slackware 10.2
Posts: 121

Original Poster
Rep: Reputation: 15
when I attempted to check the contents of fstab it said no such file or directory.
When I tried to see the lili.conf it said access permission denied.

I am kind of a newb and this is a stupid question, but is there a better way to post what the results of me typing a command are? Right now I'm writing down the results, restarting and booting into winxp then retyping them here.
 
Old 09-17-2005, 10:11 AM   #5
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
The easiest thing to do would probably to mount a dos floppy and redirect all output there, like so:
Code:
mount -t vfat /dev/floppy /mnt/floppy
fdisk -l > /mnt/floppy/fdisk-out
cp /etc/lilo.conf /mnt/floppy/lilo.conf
umount /mnt/floppy
Although running through the install again might be faster and easier
 
Old 09-17-2005, 11:09 AM   #6
zeroz52
Member
 
Registered: Feb 2005
Distribution: Slackware 10.2
Posts: 121

Original Poster
Rep: Reputation: 15
I wouldn't have a problem with just reinstalling, but if it was something I did during the install to get this error I don't want to do it again. I'm guessing that if it can't even find my /etc/fstab there is something majorly bad that happened cause when I was "turning on" my swap and other partitions it said that it was writing the info to my fstab. I willpost my results a lil later. Thanks again for the help.
 
Old 09-17-2005, 12:57 PM   #7
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,012

Rep: Reputation: 115Reputation: 115
It would be good to write down on hard paper what it says it is writing to the fstab. Also, using ext3 instead of reiserfs might help.
 
Old 09-17-2005, 01:40 PM   #8
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
I made a mistake with the mount command, it should be:
Code:
mount -t vfat /dev/floppy/0 /mnt/floppy
assuming you have the same device structure as I do.
 
Old 09-17-2005, 05:42 PM   #9
zeroz52
Member
 
Registered: Feb 2005
Distribution: Slackware 10.2
Posts: 121

Original Poster
Rep: Reputation: 15
Ok here were the results.

Root@(none):/# /etc/fstab
-bash: /etc/fstab: No such file or directory
root@(non):/# /etc/lilo.conf
-bash: /etc/lilo.conf: Permission Denied
root@(none):/# fdisk -l

Device Boot Start End Blocks ID System
/dev/hda1 * 7 HPFS/NTFS
/dev/hda2 C W95 Fat32 (LBA)
/dev/hda3 C W95 Fat32 (LBA)

/dev/hdb1 82 Linux Swap
/dev/hdb2 83 Linux
/dev/hdb3 83 Linux


I'm a "newb", and this is my first time installing Slackware so I probably screwed something up. Could it be an issue with using Reiserfs? I didn't think that would screw anything up.
 
Old 09-17-2005, 05:49 PM   #10
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,012

Rep: Reputation: 115Reputation: 115
do "cat /etc/fstab" not just "/etc/fstab". The first displays it in the terminal, and the second tries to run it. Personally, feel safer with ext3, and I prefer the swap partition at the end, but that might just be me.
 
Old 09-17-2005, 08:51 PM   #11
zeroz52
Member
 
Registered: Feb 2005
Distribution: Slackware 10.2
Posts: 121

Original Poster
Rep: Reputation: 15
I tried to reinstall with ext3 instead of reiserfs. This is how I was setting it up structure wise:

/dev/hdb1 swap
/dev/hdb2 /
/dev/hdb3 /home

I had it check for bad sectors during the format and hdb3 always would hang up my comp. I tried this then:

/dev/hdb1 /
/dev/hdb2 /home
/dev/hdb3 swap

It then got hung up when trying to format and activate my swap. Could I have a bad sector in the end of that hard drive? If so why was I able to install it the first time? I did everything by the book
 
Old 09-18-2005, 01:33 AM   #12
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
You could always try leaving the last part of the HDD unpartitioned...
 
Old 09-18-2005, 03:21 AM   #13
zeroz52
Member
 
Registered: Feb 2005
Distribution: Slackware 10.2
Posts: 121

Original Poster
Rep: Reputation: 15
Thanks for the help ciotog and everyone else, I am up and running. I changed a few things from the original install so I'm not sure exactly which one fixed it.

1. I went from reiserfs back to ext3
2. I used a rescue disk I had for awhile and ran qtparted from it and formated it that way.
3. I left the last 3gigs of hdb out of my /home partition.

One more quick question for you all. I'm pretty sure my sound is muted. I went into also mixer and it looks like this -> Master (off) ect... Everything is off. How do I turn them on? I tried spacebar and enter and arrows. Can ya help me. I know they need to be turned on and then once I exit I need to do a alsact1 store right?


Thanks again everyone who have been helping me. I'm now, officially a Slacker
 
Old 09-18-2005, 09:49 AM   #14
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
I always use aumix, when you get everything in order you can save the settings (which will be in aumixrc), then in say /etc/rc.d/rc.local you can include the line "/usr/bin/aumix -L".
I like aumix because the file aumixrc is so easily understandable, and I like the look/function.
 
Old 09-18-2005, 11:03 AM   #15
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,012

Rep: Reputation: 115Reputation: 115
You can save mixer settings using alsa itself by doing "alsactl store". Also, if you put that statement near the begining of /etc/rc.d/rc.6, just after the intro comment, it will save your settings when your system shuts down. The system is already set up to restore settings with "alsactl restore" when it boots up. Then you don't need aumix at all, just something that can adjust volumes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error in startup iwdu15 Linux - Newbie 3 06-08-2005 07:59 PM
My Redhat Linux 9 machine won't startup but gives a startup error" njugs79 Linux - Newbie 2 03-23-2005 12:50 AM
SQL Startup error : Error while setting value '@MYSQL_TCP_PORT@' to 'port' glenn69 Linux - Newbie 1 08-07-2004 11:08 PM
ALSA Startup error, MPlayer startup error, Sid andymadigan Debian 4 08-03-2004 04:15 PM
DG startup error enk0d Slackware 2 10-29-2003 03:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation

All times are GMT -5. The time now is 04:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration