LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-12-2002, 11:24 PM   #1
spanky
LQ Newbie
 
Registered: Apr 2002
Distribution: Slackware 8.0, Caldera OpenLinux 2.4, RH 6.1
Posts: 5

Rep: Reputation: 0
Question XF86 and mouse issues - Slackware 8.0


I'm having a heck of a time trying to get my mouse working. It doesn't seem to auto load during the installation. I've tried to edit the /usr/X11R6/lib/X11/XF86Config as suggested in the instructions for XFree (ftp://ftp.xfree86.org/publ/XFree86/4.1.0/doc/README.mouse) and still it doesn't function properly.

When I "startx" everything loads ok. Gnome comes up just fine, the mouse pointer is dead middle on the screen but as soon as I move the mouse the pointer jumps to the very most upper lefthand corner. The mouse won't move unless I really move the mouse quickly and then there is no pattern to where the pointer goes. It always seems to default back to the upper lefthand corner.

Does anyone have a fix???

PS: I've used both Caldera OpenLinux eDesktop 2.4 and RH 6.1 with no mouse issues....

Thanks

Asus A7V
900 Athlon TBird
384 MB PC133 Ram
STB Velocity 4400 16 mb
Courier VEverything External
Samsung SyncMaster 955df
 
Old 05-13-2002, 12:46 AM   #2
jpweston
Member
 
Registered: Mar 2002
Location: Sacramento, CA
Distribution: Slackware 8.1; Debian 3.0
Posts: 222

Rep: Reputation: 30
spanky,

Check out this thread:

http://www.linuxquestions.org/questi...threadid=20784

I posted some bits of my current Slack XF86Config which deal with the mouse.

Also, post the mouse portion of your XF86Config file so we can see how it's set up right now.

When I first installed Slack, I ended up needing to run XFree86 -configure to get a nice clean XF86Config file with the correct info.

j.
 
Old 05-13-2002, 09:28 AM   #3
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
GPM and imwheel can cause mice to do this sometimes. I always disable gpm and imwheel was developed before Xfree86, gnome and kde supported wheels and is no longer needed unless your running old versions for some reason.
 
Old 05-13-2002, 02:08 PM   #4
NSKL
Senior Member
 
Registered: Jan 2002
Location: Rome, Italy ; Novi Sad, Srbija; Brisbane, Australia
Distribution: Ubuntu / ITOS2008
Posts: 1,207

Rep: Reputation: 46
The problem is the protocol used by the mouse. I use logitech USB iFeel mice and i have this problem every time, but the fix is simple, you just need to change the protocol in core pointer section. For USB mice its usually imps/2, but it can be psaux, or something else. What mouse do you have, try looking at some sample config files to see what different protocols there are and try them all out, eventually you will find the right one...
Hope that helps.

-nskl
 
Old 05-14-2002, 12:10 AM   #5
spanky
LQ Newbie
 
Registered: Apr 2002
Distribution: Slackware 8.0, Caldera OpenLinux 2.4, RH 6.1
Posts: 5

Original Poster
Rep: Reputation: 0
Right now my XF86Config is set up as such:

Indentifier "mouse1"
Driver "mouse"
Option "protocol" "MouseManPS/2"
Option "device" "/dev/mouse"

I do have gpm enabled.

I have available a regular PS/2 Logitech MouseMan Serial-MousePort (this is a PS/2 and will adapt to a serial) as well as a Logitech TrackMan Marble Wheel (USB), I'd prefer the trackman.

JP, I tried the setting that you had on the link. It still does the same thing.

Does the XF file need to be "XF86Config"? I had one that was XF86Config.98 and was wondering if that may have been a problem. So when I tried JP's suggestion I saved is as just "XF86Config".

The version of XFree I'm using is the one that came with Slack, I do know that it isn't the 4.2.0, I think it might be 4.1.0.

Thanks for all the suggestions, I'm determined to get this thing working....

spanky
 
Old 05-14-2002, 09:35 AM   #6
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Quote:
Originally posted by NSKL
--<snip>--
For USB mice its usually imps/2, but it can be psaux, or something else.
--<snip>--

-nskl
......ummm...I think you'll find that while imps/2 is a protocol, psaux is a device......
 
Old 05-19-2002, 04:25 AM   #7
NSKL
Senior Member
 
Registered: Jan 2002
Location: Rome, Italy ; Novi Sad, Srbija; Brisbane, Australia
Distribution: Ubuntu / ITOS2008
Posts: 1,207

Rep: Reputation: 46
hmmm, indeed i found that out
Sorry, my mistake....
Thanks for the correction!

-NSKL
 
Old 05-20-2002, 10:32 PM   #8
mrprez
LQ Newbie
 
Registered: Apr 2002
Posts: 5

Rep: Reputation: 0
I had the same problem as spanky. I disabled gpm and it works just fine now.

/etc/rc.d/rc.gpm

comment out all lines

John
 
Old 05-22-2002, 11:00 AM   #9
sapilas
Member
 
Registered: Apr 2002
Location: Greece
Distribution: the best !
Posts: 176

Rep: Reputation: 30
removing gpm from the startup scripts does n;t make any difference..

Everytime I confige xfree in slack8 I go manually and configure the mouse protocol, I have the intelli mouseand I set it to

"IMPS/2" or "PS/2"

and then I go to the gpm init file /etc/rc.d/rc.gpm and I set the mouse device to

/dev/psaux

(if you have a ps2/mouse..)


 
Old 05-22-2002, 12:59 PM   #10
mrprez
LQ Newbie
 
Registered: Apr 2002
Posts: 5

Rep: Reputation: 0
All I can tell you is that it worked for me.

YMMV

John
 
Old 05-22-2002, 01:37 PM   #11
sapilas
Member
 
Registered: Apr 2002
Location: Greece
Distribution: the best !
Posts: 176

Rep: Reputation: 30
yeap . . but now do you have a console mouse ??

y not configure the gpm ?

as u wich...its ur box..

 
Old 05-26-2002, 07:55 PM   #12
spanky
LQ Newbie
 
Registered: Apr 2002
Distribution: Slackware 8.0, Caldera OpenLinux 2.4, RH 6.1
Posts: 5

Original Poster
Rep: Reputation: 0
I got the mouse working!!! I went into /usr/X11/bin/xfree86setup*, answered a couple of questions and the bad boy was up and running immediately. Working in the xf86config just didn't seem to do it. Added to fact that I was probably jazzing around in the wrong XF86Config file.... Now I just have to focus on the getting the cdrom accessible through Gnome. Slowing starting to learn my way around slack. Thanks for everyones help.

spanky
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10 - C-Media AC97 Sound Card, (and some Mouse issues) thugic Slackware 23 01-02-2005 05:33 PM
Slackware 10 mouse configuration issues libranikki Slackware 3 08-07-2004 07:41 PM
XF86 Configuration Mouse and Monitor issues.. fastly Linux - Laptop and Netbook 3 05-08-2004 12:37 PM
xf86 mouse scripting Longinus Linux - Software 0 03-20-2004 11:48 PM
Slackware 8.1 - Default [Full] Install, Mouse Issues narusegawa Slackware 10 03-17-2003 08:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration