LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-28-2014, 12:29 AM   #1
Siliskor
LQ Newbie
 
Registered: May 2014
Posts: 11

Rep: Reputation: Disabled
Slackware not working after update


Hey all,

I recently ran...

slackpkg update
slackpkg upgrade-all
slackpkg install-new


Everything seemed okay until I rebooted. The login screen seems different from last time, apart from that I was able to login but when I try and run 'startx' I received the following error message...

xauth: file /home/user/.serverauth.767 does not exist

/usr/bin/X: error while loading shared libraries: libxshmfence.so.1: cannot open shard object file: No such file or directory
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error


Can anyone help me with this error? I am 99% certain the update I recently ran has caused this as it was working fine before that.

I am a noob with Linux in general but am trying to learn more and get better.

Thanks.
 
Old 07-28-2014, 01:37 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 5,580

Rep: Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560
libxshmfence.so.1 is installed by package libxshmfence-1.1 that is shipped only in Slackware current at time of writing.

In a Slackware version 14.1 no software should require this as a dependency, so you probably have a mix of packages coming from Slackware current and Slackware 14.1, which is bad.

Maybe you uncommented a mirror for Slackware current instead of Slackware14.1 in /etc/slackpkg/mirrors?

Please confirm that (or not) and tell us what are your Slackware version and architecture (32 or 64 bit).

Last edited by Didier Spaier; 07-28-2014 at 01:49 AM. Reason: Last sentence added.
 
1 members found this post helpful.
Old 07-28-2014, 01:48 AM   #3
Siliskor
LQ Newbie
 
Registered: May 2014
Posts: 11

Original Poster
Rep: Reputation: Disabled
Damn I think you are probably correct. A collegue normally gives me the .iso file and my mirror is pointing to the file in my local directory.

Should I just uncomment one of the ftp mirrors for Slackware14.1 and try updating again or has the damage already been done?

EDIT: I am using 14.1 32 bit

Last edited by Siliskor; 07-28-2014 at 01:56 AM.
 
Old 07-28-2014, 01:56 AM   #4
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 5,580

Rep: Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560
Quote:
Originally Posted by Siliskor View Post
Should I just uncomment one of the ftp mirrors for Slackware14.1 and try updating again or has the damage already been done?
You can try to update again with a good mirror, issuing also "slackpkg clean-system" to remove packages possibly shipped in current but not in 14.1 (assuming that you have only genuine Slackware packages. Else in the list of packages that should be removed uncheck only those you want to keep that are *not* shipped in Slackware).

If that doesn't go well, reinstall Slackware 14.1
 
1 members found this post helpful.
Old 07-28-2014, 02:09 AM   #5
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,668
Blog Entries: 1

Rep: Reputation: 1094Reputation: 1094Reputation: 1094Reputation: 1094Reputation: 1094Reputation: 1094Reputation: 1094Reputation: 1094
Also note that the correct order of commands is:
Code:
slackpkg update
slackpkg install-new
slackpkg upgrade-all
To make sure you cater for any new dependencies that might have been added in an updated version of a package.
 
2 members found this post helpful.
Old 09-24-2014, 08:27 PM   #6
spatmur
LQ Newbie
 
Registered: Jul 2014
Location: Meadville, PA, USA
Distribution: Slackware, OpenBSD
Posts: 14

Rep: Reputation: Disabled
I just discovered this same problem tonight when working on my Slackware current machine. I haven't started the X server since upgrading to current and had no idea that it wasn't functioning correctly.

But, I followed the advice in the above posts and everything came up the way it should. Hail Bob!
 
1 members found this post helpful.
Old 09-25-2014, 07:47 AM   #7
WhiteWolf1776
Member
 
Registered: Oct 2010
Location: Pittsburgh, PA
Distribution: Slackware
Posts: 270

Rep: Reputation: 84
Don't forget to at least look at the package list from a run of:

slackpkg clean-system

Sometimes, removing packages is necessary as well...
 
2 members found this post helpful.
Old 09-25-2014, 08:26 AM   #8
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware64-current
Posts: 4,607

Rep: Reputation: 735Reputation: 735Reputation: 735Reputation: 735Reputation: 735Reputation: 735Reputation: 735
The first time I run slackpkg on a system I run slackpkg update gpg then the following commands.

Code:
slackpkg update gpg
slackpkg update
slackpkg install-new
slackpkg upgrade-all
 
2 members found this post helpful.
Old 02-02-2015, 10:40 AM   #9
rcorkum
Member
 
Registered: Aug 2005
Location: Thunder Bay, Ontario, Canada
Distribution: Slackware Current
Posts: 107

Rep: Reputation: 15
hmm looks like I am having also the exact same issue.

I had started http://www.linuxquestions.org/questi...05#post5310605

but will move over here. 64 bit clean install i update and bang startx borked exact same error.

Rob
 
Old 02-02-2015, 12:05 PM   #10
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.1 64-bit
Posts: 267

Rep: Reputation: 47
Can you try adding "915.modeset=1" to your kernel line in lilo or grub conf?
 
Old 02-02-2015, 12:08 PM   #11
rcorkum
Member
 
Registered: Aug 2005
Location: Thunder Bay, Ontario, Canada
Distribution: Slackware Current
Posts: 107

Rep: Reputation: 15
Quote:
Originally Posted by jostber View Post
Can you try adding "915.modeset=1" to your kernel line in lilo or grub conf?
okay just saved that to a text file in my /root going to just keep it at stable and upgrade all if that borks will try above. if that doesn't will adjust mirror to current and try again and if it borks try the above fix and report back

okay stable didn't bork it i can tell as not only can't i startx where I still have an xsession started (xcfe here) I can't launch a terminal a browser nada with a window of anykind)

now changing mirror to current and working to break it again

just completed
slackpkg update
slackpkg install-new

now onto
slackpkg upgrade-all

okay I am completely upgraded to current and don't think there is going to be an issue this time.

I think I made a 24 hour no sleep 3am missed slackpkg install-new which broke some dependencies

but going to reboot to make sure. and just in case already appended your suggest to kernel options in lilo and touched lilo so I can get back to here in case all else fails

issue resolved on my end that HAD to be the culprit. will promise to repeat 50 RTFM's before bedtime tonight

Last edited by rcorkum; 02-02-2015 at 01:14 PM. Reason: myself resolved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to update SA using ip xfrm update,its not working!! samiran.linux Linux - Networking 1 05-05-2014 12:31 AM
Slackware security update/package update Michael_aust Slackware 6 10-04-2006 08:19 PM
After Online update: Hard drive working and working dacosta SUSE / openSUSE 6 11-06-2004 12:14 AM


All times are GMT -5. The time now is 09:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration