LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-07-2004, 04:40 PM   #16
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,263

Rep: Reputation: 54

On the cdrw did you try what I posted before?

To be able to mount your windows partition put the following in your /etc/fstab:
/dev/hdb1 /mnt/windows ntfs noauto,user,ro 0 0
make sure you create /mnt/windows with mkdir. then to mount it just type mount /mnt/windows
 
Old 06-07-2004, 05:36 PM   #17
Teckno
Member
 
Registered: May 2004
Location: Why do you want to know?
Posts: 82

Original Poster
Rep: Reputation: 15
thanks, I diddent think to try that on the cdrw.

(btw does linux have that neat automount/supermount feature?)

Last edited by Teckno; 06-07-2004 at 05:38 PM.
 
Old 06-07-2004, 05:45 PM   #18
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,263

Rep: Reputation: 54
look in /usr/doc/Linux how tos/automount. that isn't exact but you can find it with that.
 
Old 06-07-2004, 05:51 PM   #19
Teckno
Member
 
Registered: May 2004
Location: Why do you want to know?
Posts: 82

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by ringwraith

/dev/sr1 /mnt/cdrom iso9660 noauto,user,rw 0 0

Hope that helps [/B]
um shoudent that be: /dev/scd0 ?
or have I got my wires cross again?
 
Old 06-07-2004, 06:33 PM   #20
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,263

Rep: Reputation: 54
scd0 will be symlinked to sr0 so that doesn't matter.
you said the cdrw was the secondary slave, that is why i thought it would be on 1 not 0.... but you will only have 1 scsi if you do not append both drives for scsi emulation.... i run ide-scsi on both so I have sr0 and sr1. to be honest i am not sure. you can set it up as one then try to mount, if it won't then change it, unless someone else chimes in here.
 
Old 06-07-2004, 06:46 PM   #21
Teckno
Member
 
Registered: May 2004
Location: Why do you want to know?
Posts: 82

Original Poster
Rep: Reputation: 15
ok I just tried scd0, scd1, sr0, and sr1 none of them worked
when I tried to mount them it said :
mount: /dev/scdX (srX) is not a valid block device
 
Old 06-07-2004, 06:49 PM   #22
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,263

Rep: Reputation: 54
you added the line to /etc/fstab, you added the append='hdd=ide-scsi' line in lilo.conf, ran lilo as root, rebooted, then tried mounting?
 
Old 06-07-2004, 06:54 PM   #23
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
Since you got someone helping you I've backed off, but kept up with your progress.
Only three things to "chime in" at this point. I always use this for ide writers
Code:
/dev/scd0        /mnt/cdrw        iso9660     user,unhide,noauto,rw  0 0
/dev/scd1        /mnt/dvd         iso9660     user,unhide,noauto,rw  0 0
and the second thing is, after you add append="hdd=ide-scsi" to your /etc/lilo.conf
file, you will have to issue
# /sbin/lilo
again, or it won't be added - and then reboot.

Last, I believe you issued
bash-2.05b$ cdrecord -scanbus
rather than
bash-2.05b# cdrecord -scanbus
Notice the $ indicates a normal user, and the # indicates root.
You can only use cdrecord as root.

Like ringwraith said whilst I was posting, you have to rerun lilo for
the changes to stick - then reboot - always have to do that after
changing LiLO.

Also, you have to have a mount point to mount the CD-RW. You
have issued a command to mount a device but didn't tell your
system where you want to mount it. My setup above allows
you to mount them as a regular user. You don't want to su to root
in a *nix system except for sys maintenance reasons. That's the
primary thing that makes your Slackware box 100 times more secure
than that Windoze eXperiment thing. ;-)
 
Old 06-07-2004, 07:00 PM   #24
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
making mount point

Slack comes with /mnt/cdrom - I think. Issue
$ ls -alc /mnt
and see what's there. Then su to root and issue
bash-2.05b# pico /etc/fstab
and add the mount point for your drive. Look at
the example I posted above, post back with ???
 
Old 06-07-2004, 08:43 PM   #25
Teckno
Member
 
Registered: May 2004
Location: Why do you want to know?
Posts: 82

Original Poster
Rep: Reputation: 15
ok I reran LiLo but it gave me this:
Code:
Syntax error at or above line 41 in file '/etc/lilo.conf'
line 41 is the line I put append='hdd=ide-scsi'

I did cdrecord -scanbus in root and got this:
Code:
  cdrecord -scanbus
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
I Triple checked to make sure I was in root

I did $ ls -alc /mnt , but im not sure what to make of it
Code:
total 3
drwxr-xr-x    7 root     root          168 Jun  7 17:20 ./
drwxr-xr-x   17 root     root          384 Jun  7 17:33 ../
drwxr-xr-x    2 root     root           48 Jun  7 16:58 cdrw/
drwxr-xr-x    2 root     root           48 Jun  5 19:46 dvdrom/
drwxr-xr-x    2 root     root           48 Jun  5 19:46 floppy/
drwxr-xr-x    2 root     root           48 Jun  5 19:46 hd/
dr-x------    1 root     root         4096 May  5 18:51 windows/
just for reference heres my fstab and LiLo
Code:
/dev/hda1        swap             swap        defaults               0   0
/dev/hda2        /                reiserfs    defaults               1   1
/dev/hda3        /home            ext2        defaults               1   1
/dev/hdb1        /mnt/windows     ntfs        noauto,user,ro         0   0
/dev/scd1        /mnt/cdrw        iso9660     user,unhide,noauto,rw  0   0
/dev/hdc         /mnt/dvd         iso9660     user,unhide,noauto,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,users           0   0
devpts           /dev/pts         devpts      gid=5,mode=620         0   0
proc             /proc            proc        defaults               0   0
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot="/dev/hda"
message = /boot/boot_message.txt
prompt
timeout="100"
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# VESA framebuffer console @ 800x600x64k
vga="788"
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image="/boot/vmlinuz"
	root="/dev/hda2"
	label="Linux"
  read-only
# Linux bootable partition config ends
append='hdd=ide-scsi'
btw I got /windows working, thing is that everything is owned by root (locked up), I tried chmoding it (777) but it dident to the subdirectys
 
Old 06-07-2004, 08:54 PM   #26
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,263

Rep: Reputation: 54
Put the append line up at the top, right below
# Start LILO global section

Also I noticed I gave you single quotes ' , should be regular "

Here is mine just as an example:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
append="hdc=ide-scsi hdd=ide-scsi"
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hdb1
label = Slackware
read-only
image = /boot/vmlinuz
root = /dev/hda5
label = RockLinux
read-only
# Linux bootable partition config ends
other = /dev/hda1
label = WindowsXP
other = /dev/hda2
label = Debian
 
Old 06-07-2004, 09:16 PM   #27
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
Quote:
Originally posted by Teckno
ok I reran LiLo but it gave me this:
Code:
Syntax error at or above line 41 in file '/etc/lilo.conf'
line 41 is the line I put append='hdd=ide-scsi'
That line should read append="hdd=ide-scsi"
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
append="hdd=ide-scsi"
boot = /dev/hda
and should be exactly where you see it above. You have the double quotes
as single quotes and have it after the data is finished. So, make it like the
above, save the file, and issue
# /sbin/lilo
and you're good to go for that. And I don't know if it matters, but I've personally
never had quotes around the boot device.

Quote:
I did cdrecord -scanbus in root and got this:
Code:
  cdrecord -scanbus
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
I Triple checked to make sure I was in root
There is a difference between "in root" and "as root." The first one, "in root" means
that you are in the root directory; the second one means you are logged in as root,
super user. You do this by issuing
$ su
password:
and then the prompt changes from $ to # and you know you are "logged in" as root.
Sorry to have you check for a fourth time - maybe you just stated it wrong. This time
post it with the entire bash prompt like this:
Code:
bash-2.05b# cdrecord -scanbus
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
Linux sg driver version: 3.1.25
Using libscg version 'schily-0.7'
scsibus0:
        0,0,0     0) 'SONY    ' 'CD-RW  CRX230E  ' 'QYS1' Removable CD-ROM
        0,1,0     1) 'SONY    ' 'DVD RW DRU-500A ' '2.0c' Removable CD-ROM
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
scsibus1:
        1,0,0   100) 'ON-DATA ' '                ' '7.77' Removable Disk
        1,1,0   101) *
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *
scsibus2:
        2,0,0   200) 'TOSHIBA ' 'MK4021GAS       ' '0811' Disk
        2,1,0   201) *
        2,2,0   202) *
        2,3,0   203) *
        2,4,0   204) *
        2,5,0   205) *
        2,6,0   206) *
        2,7,0   207) *
bash-2.05b#
though the problem will be solved after you fix LiLO, assuming you did the
standard full install and have the proper modules. I know it's anal retentive,
but IMO this issue should be resolved before trying something else. If you
have it right in LiLO, your machine should see it. So, you must run this test
again after you've redone LiLO and rebooted - okay?

Quote:
I did $ ls -alc /mnt , but im not sure what to make of it
Code:
total 3
drwxr-xr-x    7 root     root          168 Jun  7 17:20 ./
drwxr-xr-x   17 root     root          384 Jun  7 17:33 ../
drwxr-xr-x    2 root     root           48 Jun  7 16:58 cdrw/
drwxr-xr-x    2 root     root           48 Jun  5 19:46 dvdrom/
drwxr-xr-x    2 root     root           48 Jun  5 19:46 floppy/
drwxr-xr-x    2 root     root           48 Jun  5 19:46 hd/
dr-x------    1 root     root         4096 May  5 18:51 windows/
That's real good. You have a place to mount all the devices. So for your
/etc/fstab entry, put
Code:
/dev/scd0        /mnt/cdrw        iso9660     user,unhide,noauto,rw  0   0
Don't worry - it will all come out in the wash. ;-) And you will be able
to mount your CD-RW as user, and not as root. Good security measure...

Quote:
just for reference heres my fstab and LiLo
Code:
/dev/hda1        swap             swap        defaults               0   0
/dev/hda2        /                reiserfs    defaults               1   1
/dev/hda3        /home            ext2        defaults               1   1
/dev/hdb1        /mnt/windows     ntfs        noauto,user,ro         0   0
/dev/scd1        /mnt/cdrw        iso9660     user,unhide,noauto,rw  0   0
/dev/hdc         /mnt/dvd         iso9660     user,unhide,noauto,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,users           0   0
devpts           /dev/pts         devpts      gid=5,mode=620         0   0
proc             /proc            proc        defaults               0   0
Thanks - you just need to change the 1 in the cdrw line to 0

Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot="/dev/hda"
message = /boot/boot_message.txt
prompt
timeout="100"
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# VESA framebuffer console @ 800x600x64k
vga="788"
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image="/boot/vmlinuz"
	root="/dev/hda2"
	label="Linux"
  read-only
# Linux bootable partition config ends
append='hdd=ide-scsi'
Quote:
btw I got /windows working, thing is that everything is owned by root (locked up), I tried chmoding it (777) but it dident to the subdirectys
You can't change permissions of the Windoze drive in Linux. Well, I can't by issuing
bash-2.05b# chown -R mingdao.users /DATA_FAT32/
but if I'm wrong, I welcome the correction. :} You don't want to mess with that bad boy,
btw, because Linux cannot reliably write to a NTFS drive, but can read it. Linux
can, however, read and write very well to FAT32. :}

Last edited by Bruce Hill; 06-07-2004 at 09:18 PM.
 
Old 06-07-2004, 09:39 PM   #28
Teckno
Member
 
Registered: May 2004
Location: Why do you want to know?
Posts: 82

Original Poster
Rep: Reputation: 15
I got lilo working!!!

cdrecord -scanbus is seeing it!!
(btw I was root, the thingy I was triple checking was the # promt, oh well it working now)
Code:
sam@darkstar:~$ su
Password:
root@darkstar:/home/sam# cdrecord -scanbus
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
Linux sg driver version: 3.1.25
Using libscg version 'schily-0.7'
scsibus0:
        0,0,0     0) 'CyberDrv' 'CW038D CD-R/RW  ' '120C' Removable CD-ROM
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
and I got my cdrw mounted!!!.... well sorta
Code:
sam@darkstar:~$ mount /mnt/cdrw
mount: block device /dev/scd0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
       or too many mounted file systems



Quote:
You can't change permissions of the Windoze drive in Linux. Well, I can't by issuing
bash-2.05b# chown -R mingdao.users /DATA_FAT32/
but if I'm wrong, I welcome the correction. :} You don't want to mess with that bad boy,
btw, because Linux cannot reliably write to a NTFS drive, but can read it. Linux
can, however, read and write very well to FAT32. :}
sorry I left something out, I once I was able to access the drive I copied everything over to a folder on my desktop (cause the hd is gonna zero-writ, reformated and loaded with windows). Thats where every thing was locked up, the folder, not the drive. sorry about the confuseion
 
Old 06-07-2004, 10:07 PM   #29
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
Quote:
Originally posted by Teckno
I got lilo working!!!

cdrecord -scanbus is seeing it!!
(btw I was root, the thingy I was triple checking was the # promt, oh well it working now)
Code:
sam@darkstar:~$ su
Password:
root@darkstar:/home/sam# cdrecord -scanbus
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J�rg Schilling
Linux sg driver version: 3.1.25
Using libscg version 'schily-0.7'
scsibus0:
        0,0,0     0) 'CyberDrv' 'CW038D CD-R/RW  ' '120C' Removable CD-ROM
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
and I got my cdrw mounted!!!.... well sorta
Code:
sam@darkstar:~$ mount /mnt/cdrw
mount: block device /dev/scd0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
       or too many mounted file systems
Wait...stop the presses...what type of CD did you try to mount?
I bet it was a blank one. If so, try one with some data...any kind
of data...and fyi you don't have to mount a CD before you burn...
and by all means, burn from the command line!

And Sam, to unmount it you issue
bash-2.05b$ umount /mnt/cdrw (that's correct - there is no n after the first u)

Quote:
sorry I left something out, I once I was able to access the drive I copied everything over to a folder on my desktop (cause the hd is gonna zero-writ, reformated and loaded with windows). Thats where every thing was locked up, the folder, not the drive. sorry about the confuseion
You got me on that one for sure. You just use that command I posted
# chown sam.users /path/to/file
or
# chown -R sam.users /path/to/dir
and you'll make something happen. Read
$man chown
 
Old 06-07-2004, 10:59 PM   #30
Teckno
Member
 
Registered: May 2004
Location: Why do you want to know?
Posts: 82

Original Poster
Rep: Reputation: 15
chown sam.users /path/to/file worked !!!!!

the cd I tried was a burned audio cd. I tried a data cd and it worked!!!!
but why wont audio cds work? I tried to play it in KsCD but it wont play

Last edited by Teckno; 06-07-2004 at 11:03 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.2 Problems: Display Server/SAMBA/Lisa/Finding the internet Steven_Shelton Slackware 7 11-22-2005 01:13 AM
Slackware and USB drives? carlosinfl Slackware 2 06-12-2005 05:48 PM
Trouble finding cd-drives after new kernel TaNeK Linux - Hardware 2 01-11-2005 02:30 AM
CD Drives not working in Slackware 9.1 jon1591 Linux - Hardware 10 01-01-2005 12:07 PM
finding slackware vicente Linux - Distributions 3 08-11-2001 04:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration