LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-30-2019, 07:33 AM   #1
camerabambai
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 145

Rep: Reputation: 19
Slackware current: some help to get an identical font rendering as 14.2


I really like the font rendering of Slackware 14.2
Imho is the best rendering, better than many other distros.
I use on 14.2 those settings

Code:
fonts: deja-vu sans book 10
hinting: slight
dpi: 96x96
On the current I see the font rendering very bad after upgrading the freetype package from 2.8 to latest current.
For tryng to reach the good rendering as 14.2 I have modify this script

Code:
/etc/profile.d/freetype.sh

export FREETYPE_PROPERTIES="truetype:interpreter-version=35"
The result is good..but I still think on 14.2 is really, really better (sometimes on current and other distros with latest freetype I have some eyes "burning" because bad rendering)
Some suggestions to get the same rendering as 14.2?
 
Old 07-30-2019, 07:07 PM   #2
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,450

Rep: Reputation: 2038Reputation: 2038Reputation: 2038Reputation: 2038Reputation: 2038Reputation: 2038Reputation: 2038Reputation: 2038Reputation: 2038Reputation: 2038Reputation: 2038
Have you seen /etc/fonts/conf.d/README ? Perhaps a hinting or subpixel rendering setting will improve your experience. It is always hard to give advice on this, as the experience is subjective and hardware can be variable.
 
1 members found this post helpful.
Old 07-30-2019, 08:09 PM   #3
EdGr
Member
 
Registered: Dec 2010
Location: California, USA
Distribution: I run my own OS
Posts: 488

Rep: Reputation: 236Reputation: 236Reputation: 236
Edit /etc/fonts/conf.d/60-latin.conf to pick the DejaVu fonts over the Liberation fonts. The DejaVu fonts are easier to read and edit because the characters are wider.
Ed
 
1 members found this post helpful.
Old 07-31-2019, 12:44 PM   #4
TheRealGrogan
Member
 
Registered: Oct 2010
Location: Ontario, Canada
Distribution: Slackware, LFS, Manjaro (for gaming)
Posts: 396

Rep: Reputation: 256Reputation: 256Reputation: 256
Yeah, I don't care for those liberation fonts. It took me a while to figure out why my fonts looked different on this slackware-current. It was mostly in Firefox where I was unhappy, when certain fonts were called for.

I tried changing the order and stuff in those files, and had it almost the way I wanted it, but certain forum fonts still didn't look right (to me). I ended up removing every TTF font except the Deja Vu family. Perfect... it's different configurations of those fonts that I am used to.

I was comparing everything in Manjaro and I had everything the same in Slackware, the symlinks, the ordering, but the difference was, in Manjaro I only had the Deja Vu family installed. I had to install legacy fonts for things like urxvt and stuff, but never got around to any other TTF. Good then.

P.S. I should also note that I use the dreaded bytecode interpreter (not really necessary anymore with modern freetype, it's pretty close, but I'm used to it) and lcd filter.

Last edited by TheRealGrogan; 07-31-2019 at 12:58 PM.
 
1 members found this post helpful.
Old 07-31-2019, 02:55 PM   #5
solarfields
Senior Member
 
Registered: Feb 2006
Location: slackalaxy
Distribution: Slackware
Posts: 1,106

Rep: Reputation: 668Reputation: 668Reputation: 668Reputation: 668Reputation: 668Reputation: 668
I had the same adventures with fonts on -current:
https://slackalaxy.com/2019/04/17/fr...-hinting-mode/
I did what you did and in the end specified the DejaVu fonts in my browser and text editor... I have hinting 'full' and sub-pixel order 'None', but i guess that's all a matter of preference.

Last edited by solarfields; 07-31-2019 at 02:57 PM.
 
Old 07-31-2019, 03:20 PM   #6
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Ubuntu, Debian, Slackware
Posts: 2,107
Blog Entries: 6

Rep: Reputation: 2335Reputation: 2335Reputation: 2335Reputation: 2335Reputation: 2335Reputation: 2335Reputation: 2335Reputation: 2335Reputation: 2335Reputation: 2335Reputation: 2335
I have found the default rendering to be pretty much excellent on -current. On 14.2 I had to install Infinality which I haven't had to do on -current.

I imagine some of it may come down to your DE, I use Xfce with Sans font and slight hinting on RGB. I use Vivaldi browser with a few modifications to text size relative to my setup.

But you can drive yourself mad with font rendering. Sometimes it's worth stepping away from the computer, because you'll tie yourself in knots over it. As long as it's generally smooth enough, your mind will adjust to it, that's where most of the 'rendering' happens.

Last edited by Lysander666; 07-31-2019 at 03:21 PM.
 
1 members found this post helpful.
Old 08-01-2019, 07:27 AM   #7
EdGr
Member
 
Registered: Dec 2010
Location: California, USA
Distribution: I run my own OS
Posts: 488

Rep: Reputation: 236Reputation: 236Reputation: 236
Here is a comparison of the DejaVu, Liberation, and Luxi fonts. If you step back from your monitor, you can see that DejaVu remains readable at greater distances.
Ed

https://www.edgrochowski.com/photos-...nts-8-1-19.png
 
1 members found this post helpful.
Old 08-02-2019, 05:38 AM   #8
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,625

Rep: Reputation: 299Reputation: 299Reputation: 299
My FF fonts have looked terrible for a while. Yesterday, I changed in System Settings to enable anti-aliasing, changed hinting to slight, and to force font dpi to 96. I already had fonts set to Deja-Vu Sans Book. That was the best thing I've done in a while.

I have -current in VBox also. Everything there is set to Vendor Default, and there is no problem with fonts. That may also be due to the Nvidia GT 730 card with the Nvidia blob installed. VBox uses its own graphics stuff.
 
1 members found this post helpful.
Old 08-07-2019, 06:11 AM   #9
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 142

Rep: Reputation: Disabled
I figured out that the best way to go for me was to set Hinting to slight in Xfce which decreases the height of the fonts a little bit:

Click image for larger version

Name:	current_slight_hinting.png
Views:	88
Size:	24.3 KB
ID:	31058

left is default / right is with Hinting: slight.

As the fonts still looked way to small for me, I have increased the size for both, the default font and the Monospace font to 11. Within Settings > Windows Manager I have set the Title font size to 10 (Sans Bold).

Lioh

Last edited by lioh; 08-07-2019 at 06:21 AM.
 
1 members found this post helpful.
Old 08-08-2019, 05:38 AM   #10
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 142

Rep: Reputation: Disabled
An alternate approach to mimic the old font-rendering behavior of Slackware 14.2 is to edit /etc/fonts/conf.d/60-latin.conf and to modify it that DejaVu fonts are listed before Liberation:

Click image for larger version

Name:	DejaVu.png
Views:	53
Size:	128.0 KB
ID:	31066

Afterwards one has to modify /etc/profile.d/freetype.sh as described in camerabambai's post.

Code:
export FREETYPE_PROPERTIES="truetype:interpreter-version=35"
Within Xfce Hint-mode has to be set to full. The default font sizes (10) match the settings of 14.2, so there is no need to change them.

Here is a screenshot comparing the results:

Click image for larger version

Name:	dejavu_restored.png
Views:	79
Size:	31.3 KB
ID:	31067

Have Phun
Lioh
 
1 members found this post helpful.
Old 10-11-2019, 09:34 AM   #11
camerabambai
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 145

Original Poster
Rep: Reputation: 19
The last solution seems to works fine, but I prefer the hinting not full
 
1 members found this post helpful.
Old 10-11-2019, 01:28 PM   #12
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 505

Rep: Reputation: 271Reputation: 271Reputation: 271
Also, if you have the corefonts installed, I'd recommend deleting the symlink at /etc/fonts/conf.d/60-liberation.conf
 
1 members found this post helpful.
Old 10-11-2019, 02:14 PM   #13
philanc
Member
 
Registered: Jan 2011
Posts: 258

Rep: Reputation: 226Reputation: 226Reputation: 226
Quote:
Originally Posted by Lysander666 View Post
As long as it's generally smooth enough, your mind will adjust to it, that's where most of the 'rendering' happens.
Good point!
 
  


Reply

Tags
fontproblems, fonts, freetype


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] broken font rendering in -current? giomat Slackware 0 06-01-2019 10:45 PM
[SOLVED] Current and freetype font rendering upnort Slackware 16 12-26-2018 06:55 PM
Font rendering in Chromium 21, slackware 64-current fogpipe Slackware 3 04-22-2013 02:43 PM
autofs local map files identical but not identical to automount jwaldram Linux - Server 2 10-26-2012 10:35 AM
Identical disks that are not identical staphanes Linux - Hardware 8 03-11-2006 11:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration