LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-27-2013, 10:16 AM   #1
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 222

Rep: Reputation: 33
Sendmail 8.14.6 broken in current


Looks like my sendmail has been broken since the Feb 12 update. This version requires libdb-4.8.so which is not yet available in current. I'm guessing this will be included in the next aaa_elflibs roll out. Rolling back to sendmail-8.14.5 which requires libdb-4.4.so fixes the problem.
 
Old 02-27-2013, 10:42 AM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,342

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
Here's what i got on my system:
Code:
ldd /usr/bin/sendmail 
        linux-gate.so.1 (0xffffe000)
        libdb-4.8.so => /usr/lib/libdb-4.8.so (0xb75da000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xb75c1000)
        libcrypt.so.1 => /usr/lib/libcrypt.so.1 (0xb758e000)
        libnsl.so.1 => /lib/libnsl.so.1 (0xb7573000)
        libdl.so.2 => /lib/libdl.so.2 (0xb756d000)
        libssl.so.1 => /usr/lib/libssl.so.1 (0xb750a000)
        libcrypto.so.1 => /usr/lib/libcrypto.so.1 (0xb7354000)
        libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0xb733a000)
        libm.so.6 => /lib/libm.so.6 (0xb730e000)
        libc.so.6 => /lib/libc.so.6 (0xb7189000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb716e000)
        /lib/ld-linux.so.2 (0xb7791000)
i'm guessing you didn't install db48-4.8.30-i486-2
 
Old 02-27-2013, 10:51 AM   #3
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 222

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by willysr View Post
Here's what i got on my system:
i'm guessing you didn't install db48-4.8.30-i486-2
Ahh, that did it. I didn't have db48 installed (guess nothing else on my system used it) and I missed it because it wasn't in the recent change logs.

Thanks willysr
 
  


Reply

Tags
current, sendmail


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] llvm - clang broken in current comet.berkeley Slackware 9 01-13-2013 02:01 AM
[SOLVED] PlayOnLinux broken in current Bindestreck Slackware 6 06-27-2012 02:37 AM
libxslt in -current broken? Slim Backwater Slackware 8 06-23-2006 11:14 PM
slackware current broken? sweetnsourbkr Slackware 8 03-11-2006 06:26 AM
wget broken after new packages in -current sh1ft Slackware 3 12-22-2004 11:50 PM


All times are GMT -5. The time now is 01:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration