Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 12-22-2004, 02:57 PM   #1
Registered: Feb 2004
Location: Ottawa, Ontario, Can
Distribution: Slackware, ubuntu
Posts: 391

Rep: Reputation: 31
wget broken after new packages in -current

I noticed upgrades ssl libraries in current and so upgraded them using installpkg. Then to my surprise, when trying to use wget:

[~]# wget
           => `coreutils-5.2.1.tar.gz'
wget: symbol lookup error: /usr/lib/ undefined symbol: FIPS_mode
What the hell? is there and yes i've done ldconfig... sooo.. what the hell?
Old 12-22-2004, 04:45 PM   #2
LQ Guru
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 245Reputation: 245Reputation: 245
Upgrade your wget packages from current probably will fix the issue, it was probably compiled against the older packages that were there.
Old 12-22-2004, 07:17 PM   #3
Registered: Apr 2004
Location: France
Distribution: Debian Sid (Kanotix)
Posts: 237

Rep: Reputation: 30
Is wget installed?

I have a newbie question.

I think I installed wget using an .rpm - at least, I must have because I get the "already installed" message if I try to install it from this .rpm.

Now how do I invoke the program? The command "wget" is not recognised, nothing is listed in the Runlevel Editor, can't find anything that looks like a binary on the hard drive.

What should I do next?

Old 12-22-2004, 11:50 PM   #4
Registered: Feb 2004
Location: Ottawa, Ontario, Can
Distribution: Slackware, ubuntu
Posts: 391

Original Poster
Rep: Reputation: 31
Never mind looks like pat repacked the ssl upgrade to fix this, from the changlog:

Wed Dec 22 19:50:57 PST 2004
a/openssl-solibs-0.9.7e-i486-2.tgz:  Rebuilt.
d/automake-1.9.4-noarch-1.tgz:  Upgraded to automake-1.9.4.
n/nfs-utils-1.0.7-i486-1.tgz:  Upgraded to nfs-utils-1.0.7.
n/openssl-0.9.7e-i486-2.tgz:  Small in patch in to
  prevent some symlinks that point to a library that doesn't exist.
  Thanks to /i. for pointing that out!
wget works great again

Last edited by sh1ft; 12-23-2004 at 12:03 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
wget --exclude-directories option broken? (fc2) fsbooks Fedora 3 06-20-2009 06:08 PM
Broken Packages hongman Linux - Software 2 04-13-2005 05:48 AM
what's with all those broken packages darkleaf Debian 8 09-29-2004 01:40 PM
apt-get + broken packages = death ulaoulao Linux - Software 2 09-19-2004 09:55 AM
Broken Packages Kujila Linux - Software 2 02-01-2004 05:07 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:18 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration