LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-06-2017, 11:26 AM   #811
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,472

Original Poster
Rep: Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377

Quote:
Originally Posted by sbolokanov View Post
Wondering if somebody else have problems compiling mpv?
are you using the SlackBuild from the repository indicated in the first post of this topic? because it includes a patch that should let you build it

http://cgit.ponce.cc/slackbuilds/commit/?h=mpv
 
Old 12-06-2017, 11:41 AM   #812
sbolokanov
Member
 
Registered: Feb 2013
Location: Бдинъ, Бѫлгариѧ
Distribution: GNU/Linux
Posts: 100

Rep: Reputation: 23
Quote:
Originally Posted by ponce View Post
are you using the SlackBuild from the repository indicated in the first post of this topic? because it includes a patch that should let you build it

http://cgit.ponce.cc/slackbuilds/commit/?h=mpv
I where wondering if it's the new version of ffmpeg.
Patch works great, thanks ponce!
 
Old 12-06-2017, 03:39 PM   #813
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 988

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
Hi , after last gmime update , totem-pl-parser , no see the lib and fails on configure time.


Quote:
checking for GMIME... no
configure: error: libgmime is required to compile totem-pl-parser.
 
Old 12-06-2017, 03:47 PM   #814
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,529
Blog Entries: 3

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Quote:
Originally Posted by USUARIONUEVO View Post
Hi , after last gmime update , totem-pl-parser , no see the lib and fails on configure time.
hey Hi . slackw-version plz
 
Old 12-06-2017, 03:53 PM   #815
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,529
Blog Entries: 3

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Quote:
Originally Posted by USUARIONUEVO View Post
Hi , after last gmime update , totem-pl-parser , no see the lib and fails on configure time.
just built in 14.2 multi-lib GMIME not required. check what you are linked to. ldd is your friend then rebuild.
 
Old 12-06-2017, 03:55 PM   #816
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,529
Blog Entries: 3

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
forgive me PLZ this is for current throw the pie.
build fine in slackware current just built it.
Code:
SUMMARY LOG
Using the SBo repository for Slackware 14.2
Queue Process:  Download and build

totem-pl-parser:
  MD5SUM check for totem-pl-parser-3.4.5.tar.xz ... OK
  Building package totem-pl-parser-3.4.5-x86_64-1_SBo.tgz ... OK

Last edited by Drakeo; 12-06-2017 at 04:02 PM. Reason: build fine in slackware current
 
Old 12-06-2017, 05:03 PM   #817
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 988

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
@Drakeo

Today updates put gmime-2.x to --> gmime 3.x

And now totem-pl-parser cant see version 3.x

This thread is for current-slackware.

I think , totem-pl-parser need go up in version for slackbuild.
 
Old 12-06-2017, 05:36 PM   #818
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,472

Original Poster
Rep: Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377Reputation: 2377
Quote:
Originally Posted by USUARIONUEVO View Post
@Drakeo

Today updates put gmime-2.x to --> gmime 3.x

And now totem-pl-parser cant see version 3.x

This thread is for current-slackware.

I think , totem-pl-parser need go up in version for slackbuild.
please check if this is ok (also if it's compatible with whatever needs it)

http://cgit.ponce.cc/slackbuilds/com...otem-pl-parser
 
1 members found this post helpful.
Old 12-06-2017, 07:41 PM   #819
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 988

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
@ponce

This new version bilds fine , and i test to build brasero , and all is ok.

Thanks!
 
Old 12-06-2017, 07:54 PM   #820
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 988

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
Other problem here ,

graphviz , use a patch for php5 , but now is php7 , i get an error in build time , some messages say "swig" , then im not sure if the problem is caused by stock "swig" package.


Quote:
gv_php.cpp: In function 'void _wrap_nextin__SWIG_0(zend_execute_data*, zval*)':
gv_php.cpp:1001:27: error: 'gv_globals' was not declared in this scope
#define SWIG_ErrorCode() (gv_globals.error_code)
 
Old 12-06-2017, 07:55 PM   #821
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,529
Blog Entries: 3

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Quote:
Originally Posted by USUARIONUEVO View Post
@Drakeo

Today updates put gmime-2.x to --> gmime 3.x

And now totem-pl-parser cant see version 3.x

This thread is for current-slackware.

I think , totem-pl-parser need go up in version for slackbuild.
Hello do you think I cant read current is a version of slackware the current in the Fing git hub i want to learn git than read the fing instructions. master is what we use or Ponce fix your read me in GITHUB.
I am in current building 14.2. if you want to say I am building from GTITHUB CURRENT AND IT IS BROKE FING SAY THAT.; NBow FO
Current is a moving target in PONCE GIT HUB
WAIST MY FING TIME ON A BRANCH THAT WILL BE DELETED FGRK

Last edited by Drakeo; 12-06-2017 at 07:58 PM.
 
Old 12-06-2017, 08:02 PM   #822
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 988

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
for graphviz ,

Quote:
--enable-php=no
I found , same ponce fix in other comment , but probably when merge with slackbuilds , that fix goes lost.

I build graphviz , removing php5 patch , and disabling php on build time.

@Drakeo

sorry , im not sure what do you say , im not english and i understand minimal.

This thread is only current , im on current , and here totem-pl-parser is not build with gmime-3 , in current since 6 of december.
 
Old 12-06-2017, 08:04 PM   #823
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,529
Blog Entries: 3

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Quote:
Originally Posted by USUARIONUEVO View Post
for graphviz ,



I found , same ponce fix in other comment , but probably when merge with slackbuilds , that fix goes lost.

I build graphviz , removing php5 patch , and disabling php on build time.

@Drakeo

sorry , im not sure what do you say , im not english and i understand minimal.

This thread is only current , im on current , and here totem-pl-parser is not build with gmime-3 , in current since 6 of december.
I am saying current slackware building SBO. since Current is never in sync with master do not waist time. till it becomes master. read
https://github.com/Ponce/slackbuilds...current/README

Last edited by Drakeo; 12-06-2017 at 08:06 PM.
 
Old 12-06-2017, 08:19 PM   #824
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 988

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
@Drakeo

I know SBo , is for stable ...i know that , .. and ?

current users need wait for final stable version of slackware to build extra packages ?

The tittle of the thread is clear , SBo scripts , not build IN CURRENT .. and i report , after test SBo + ponce repo , no one builds, the report here for ponce see possible fixes on "ponce unnoficial repo" ..ok , i know is "unnoficial" no problem.
 
Old 12-06-2017, 08:22 PM   #825
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,529
Blog Entries: 3

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
Quote:
Originally Posted by USUARIONUEVO View Post
@Drakeo

I know SBo , is for stable ...i know that , .. and ?

current users need wait for final stable version of slackware to build extra packages ?

The tittle of the thread is clear , SBo scripts , not build IN CURRENT .. and i report , after test SBo + ponce repo , no one builds, the report here for ponce see possible fixes on "ponce unnoficial repo" ..ok , i know is "unnoficial" no problem.
I was talking about current github. Never mine happy slacking.
since ponce care less about the version of Slackware that is running and stable he will let anyone add stuff that breaks slackware 14.2 that should be in current. I give up on slackbuild long time ago good for what version. no QT5 in slack 14.2 but he shoves it down your throat not mine it is his github so he likes breaking 14.2. he does not develop or run a devel team . he opens the gates to cats then hurds them.

Last edited by Drakeo; 12-06-2017 at 08:28 PM.
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 06:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 02:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 02:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 08:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration