LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-16-2019, 07:16 PM   #2221
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 585

Rep: Reputation: 162Reputation: 162

Quote:
Originally Posted by SCerovec View Post
There is some odd ball mismatch going on:
I can't build Inkscape 1.0 on my -current and when i try run the prebuilt one from ponce's repo i get missing ImagMagick6 error while -current is running an I.M.-7 package

Looks like some commit somewhere is missing?
https://github.com/ImageMagick/ImageMagick/issues/236 <- related?

FWIW it started when i only referenced the missing symlinks
see just above: post6057306

BTW inkscape 1.0 is/was quite buggy (see also before in this thread about compiling 0.92.4 with cmake)

Last edited by brobr; 11-16-2019 at 07:18 PM.
 
Old 11-17-2019, 03:48 AM   #2222
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,090

Original Poster
Rep: Reputation: Disabled
actually the inkscape issue is a little more messy.
inkscape is not compatible with imagemagick >= 7.x so either a dedicated imagemagick-6.x installation has to be used (like archlinux does) or, since the newer 1.0 version in beta, GraphicsMagick could be used as an alternative for handling images: if neither of these two prerequisites are satisfied inkscape builds the same but without those features (and this is frankly not acceptable).
I opted for the second choice, updating inkscape to a git snapshot, hoping that the previous bug reported for 1.0b1 has been already addressed there (if not I'll update to a newer version whenever it will be available).

Quote:
Originally Posted by SCerovec View Post
when i try run the prebuilt one from ponce's repo i get missing ImagMagick6 error while -current is running an I.M.-7 package
I haven't rebuilt my packages yet, I will do ASAP (also for the perl upgrade)...

Last edited by ponce; 11-17-2019 at 06:14 AM.
 
1 members found this post helpful.
Old 11-17-2019, 03:50 AM   #2223
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,090

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by USUARIONUEVO View Post
Hi , i cant compile efitools
[...]
I try update to 1.9.2 , but same error building
that happens because a variable has been renamed upstream (because of a typo): I applied a simple fix to it

http://cgit.ponce.cc/slackbuilds/commit/?h=efitools
 
Old 11-17-2019, 03:54 AM   #2224
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,090

Original Poster
Rep: Reputation: Disabled
regarding pandoc yes/no I personally would like to see it in current, maybe an all-in-one binary because of the many dependencies, but I also have no issues on shipping READMEs in markdown format: IMHO they are readable just fine.
 
Old 11-17-2019, 07:01 AM   #2225
nobodino
Member
 
Registered: Jul 2010
Location: in France
Distribution: slackware, slackware from scratch, LFS, linux Mint,Manjaro...
Posts: 646

Rep: Reputation: 383Reputation: 383Reputation: 383Reputation: 383
FligthGear from SBo-current doesn't to likde much the new alsa packages:
--------------
/usr/bin/ld*: /usr/lib64/gcc/x86_64-slackware-linux/9.2.0/../../../../lib64/libflite_cmu_us_kal.a(cmu_us_kal.o)*: dans la fonction «*register_cmu_us_kal*»*:
cmu_us_kal.c.text+0x18d)*: référence indéfinie vers «*diphone_synth*»
/usr/bin/ld*: cmu_us_kal.c.text+0x1b4)*: référence indéfinie vers «*diphone_db_val*»
/usr/bin/ld*: /usr/lib64/gcc/x86_64-slackware-linux/9.2.0/../../../../lib64/libflite_usenglish.a(us_ffeatures.o)*: dans la fonction «*us_ff_register*»*:
us_ffeatures.c.text+0x765)*: référence indéfinie vers «*basic_ff_register*»
collect2: erreur: ld a retourné le statut de sortie 1
make[2]: *** [src/Main/CMakeFiles/fgfs.dir/build.make:7410: src/Main/fgfs] Error 1
make[1]: *** [CMakeFiles/Makefile2:1857: src/Main/CMakeFiles/fgfs.dir/all] Error 2
make: *** [Makefile:163: all] Error 2

FlightGear:
Would you like to continue processing the rest of the
queue or would you like to abort? If this failed
package is a dependency of another package in the queue
then it may not make sense to continue.

(Y)es to continue, (N)o to abort, (R)etry the build?:
 
Old 11-17-2019, 10:24 AM   #2226
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,090

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by nobodino View Post
FligthGear from SBo-current doesn't to likde much the new alsa packages:
that's strange, it seems to build fine here...
 
Old 11-17-2019, 11:01 AM   #2227
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 585

Rep: Reputation: 162Reputation: 162
Quote:
Originally Posted by ponce View Post
actually the inkscape issue is a little more messy.
inkscape is not compatible with imagemagick >= 7.x so either a dedicated imagemagick-6.x installation has to be used (like archlinux does) or, since the newer 1.0 version in beta, GraphicsMagick could be used as an alternative for handling images: if neither of these two prerequisites are satisfied inkscape builds the same but without those features (and this is frankly not acceptable)....
What about the LFS patch? I applied that and inkscape works as normal; I use a lot of embedded images, so what should not work as expected?
Further I noticed that maybe uniconvertor (with dependecy sk1lib) should be added to the requires; inkscape-0.92.4 likes it to be there during runtime
 
Old 11-17-2019, 11:12 AM   #2228
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,090

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by brobr View Post
What about the LFS patch? I applied that and inkscape works as normal
I think it's clarified in the patch itself: I'll paste the top here
Quote:
Submitted By: Ken Moffat <ken at linuxfromscratch dot org>
Date: 2017-01-09
Initial Package Version: 0.92.0
Upstream Status: N/A
Origin: Self
Description: Look for verisioned ImageMagick-6 pkgconfig files so that
ImageMagick-6 libraries and be installed alongside a full ImageMagick-7.
This requires a patched build of ImageMagick-6
.

diff -Naur inkscape-0.92.0.orig/CMakeScripts/DefineDependsandFlags.cmake inkscape-0.92.0/CMakeScripts/DefineDependsandFlags.cmake
--- inkscape-0.92.0.orig/CMakeScripts/DefineDependsandFlags.cmake 2017-01-02 09:44:59.000000000 +0000
+++ inkscape-0.92.0/CMakeScripts/DefineDependsandFlags.cmake 2017-01-08 03:03:50.171286138 +0000
@@ -373,14 +373,14 @@
list(APPEND INKSCAPE_LIBS ${ZLIB_LIBRARIES})

if(WITH_IMAGE_MAGICK)
- pkg_check_modules(ImageMagick ImageMagick MagickCore Magick++ )
- if(ImageMagick_FOUND)
+ pkg_check_modules(ImageMagick-6 ImageMagick-6 MagickCore-6 Magick++-6 )
+ if(ImageMagick-6_FOUND)

- list(APPEND INKSCAPE_LIBS ${ImageMagick_LDFLAGS})
- add_definitions(${ImageMagick_CFLAGS_OTHER})
+ list(APPEND INKSCAPE_LIBS ${ImageMagick-6_LDFLAGS})
+ add_definitions(${ImageMagick-6_CFLAGS_OTHER})

- list(APPEND INKSCAPE_INCS_SYS ${ImageMagick_INCLUDE_DIRS})
- list(APPEND INKSCAPE_LIBS ${ImageMagick_LIBRARIES})
+ list(APPEND INKSCAPE_INCS_SYS ${ImageMagick-6_INCLUDE_DIRS})
+ list(APPEND INKSCAPE_LIBS ${ImageMagick-6_LIBRARIES})
else()
set(WITH_IMAGE_MAGICK OFF) # enable 'Extensions > Raster'
endif()
Quote:
Originally Posted by brobr View Post
I use a lot of embedded images, so what should not work as expected?
I'll quote from the CMakeLists.txt from the latest version of inkscape in git
Quote:
option(WITH_IMAGE_MAGICK "Compile with support of ImageMagick for raster extensions and image import resolution (requires ImageMagick 6; set to OFF if you prefer GraphicsMagick)" ON)
option(WITH_GRAPHICS_MAGICK "Compile with support of GraphicsMagick for raster extensions and image import resolution" ON)
Quote:
Originally Posted by brobr View Post
Further I noticed that maybe uniconvertor (with dependecy sk1lib) should be added to the requires; inkscape-0.92.4 likes it to be there during runtime
I think this is a matter to discuss with the maintainer...

Last edited by ponce; 11-17-2019 at 01:15 PM.
 
Old 11-17-2019, 11:26 AM   #2229
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,270

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
You go wait for this ??

https://www.linuxquestions.org/quest...ml#post6057482

I understand , 5.4 Linux is not the default for now ..but in somemoment goes , and patches no affect in nothing under Linux 4.19 , i test can apply safely.
 
Old 11-17-2019, 11:37 AM   #2230
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,090

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by USUARIONUEVO View Post
You go wait for this ??

https://www.linuxquestions.org/quest...ml#post6057482

I understand , 5.4 Linux is not the default for now ..but in somemoment goes , and patches no affect in nothing under Linux 4.19 , i test can apply safely.
I'll wait a little because I have not been able to test it myself yet... but I will be, I think, in a couple of days.
 
Old 11-17-2019, 01:37 PM   #2231
SCerovec
Senior Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware on x86 and arm
Posts: 1,689
Blog Entries: 2

Rep: Reputation: 459Reputation: 459Reputation: 459Reputation: 459Reputation: 459
Thumbs up

Quote:
Originally Posted by ponce View Post
I think it's clarified in the patch itself: I'll paste the top here


I'll quote from the CMakeLists.txt from the latest version of inkscape in git


I think this is a matter to discuss with the maintainer...
@ponce do keep up with Your good work, it is greatly appreciated here

I hope I helped just by pointing out the issue - I repeat:

Inkscape loaded just fine with my ImageMagick-7 - i have no clue if it will work and be stable at all - but it launched just fine without any I.M-6 whatsoever on my system

Will report if any issues and will seek the IM-6 to put alongside since i rely quite a lot on Inkscape in my daily affairs.

The SBo script (on Your scripts repo) tho does try to build the 0.92.4 one - while your repo holds the 1.0-b1 built binary

Last edited by SCerovec; 11-17-2019 at 01:39 PM.
 
Old 11-17-2019, 01:41 PM   #2232
nobodino
Member
 
Registered: Jul 2010
Location: in France
Distribution: slackware, slackware from scratch, LFS, linux Mint,Manjaro...
Posts: 646

Rep: Reputation: 383Reputation: 383Reputation: 383Reputation: 383
FlightGear : I had to build flite to be able to build FlightGear, which doesn't appear in the queue?
 
Old 11-17-2019, 02:01 PM   #2233
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,090

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by SCerovec View Post
@ponce do keep up with Your good work, it is greatly appreciated here

I hope I helped just by pointing out the issue - I repeat:

Inkscape loaded just fine with my ImageMagick-7 - i have no clue if it will work and be stable at all - but it launched just fine without any I.M-6 whatsoever on my system

Will report if any issues and will seek the IM-6 to put alongside since i rely quite a lot on Inkscape in my daily affairs.
I'm sure it will work fine, you'll just miss the features I pointed to above (raster extensions and image import resolution) because it won't use imagemagick at all: if you look at your build log of the inkscape package you will find in the output at the end of the configuration step, just before starting the actual build, that imagemagick support had been disabled.

Quote:
The SBo script (on Your scripts repo) tho does try to build the 0.92.4 one - while your repo holds the 1.0-b1 built binary
- inkscape in my script repo should be at version 20191115_a4ee55b ATM, check if you have synced it correctly (instructions are linked in the first post);
- the package in my personal binary repository had been built 40 days ago, but in the meantime I had switched back to 0.92.4 then again to a newer version.

Last edited by ponce; 11-17-2019 at 03:25 PM.
 
1 members found this post helpful.
Old 11-17-2019, 02:14 PM   #2234
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,090

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by nobodino View Post
FlightGear : I had to build flite to be able to build FlightGear, which doesn't appear in the queue?
AFAIK flite is an optional, autodetected, dependency of FlightGear, I don't know why it should be mandatory there: BTW, here FlightGear builds fine with or without having it installed.

Last edited by ponce; 11-17-2019 at 03:24 PM.
 
Old 11-17-2019, 04:53 PM   #2235
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 585

Rep: Reputation: 162Reputation: 162
Quote:
Originally Posted by ponce View Post
... you will find ..., that imagemagick support had been disabled.
..I had switched back to 0.92.4 then again to a newer version.
Hi ponce, thanks for this explanation; I guess that without imagemagick 6-libraries plus that LFS-'patch', my built essentially has disabled imagemagick... ;-) Ah well, at least this 0.92.4 might still be more useful for me this way than the beta version (although the correction for the bug I reported last month went in last week ;-).

You mentioned GraphicsMagick as an alternative. Is it worth trying that, or does ImageMagick has to be disabled altogether?
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 06:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 02:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 02:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 08:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration