LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-15-2019, 04:00 PM   #2206
MDKDIO
Member
 
Registered: Mar 2004
Location: Sweden
Distribution: Slackware 14.2 & Current
Posts: 196

Rep: Reputation: 36

Ran into some issues with building openresolve 3.9.2 using the current .SlackBuild

README could not be found

Solved by commenting out line 99 in openresolve.SlackBuild
Code:
#cp README $PKG/usr/doc/$PRGNAM-$VERSION
P.S. I did not try with version 3.9.0 D.S.
 
Old 11-15-2019, 06:09 PM   #2207
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 7,856

Rep: Reputation: 5438Reputation: 5438Reputation: 5438Reputation: 5438Reputation: 5438Reputation: 5438Reputation: 5438Reputation: 5438Reputation: 5438Reputation: 5438Reputation: 5438
Quote:
Originally Posted by MDKDIO View Post
Ran into some issues with building openresolve 3.9.2 using the current .SlackBuild

README could not be found

Solved by commenting out line 99 in openresolve.SlackBuild
Code:
#cp README $PKG/usr/doc/$PRGNAM-$VERSION
P.S. I did not try with version 3.9.0 D.S.
I'm the maintainer for openresolv. He must've removed the README (or renamed it to README.md) on the newer versions (the script works fine with the 3.9.0 version it calls). I'll try and push out an update this weekend to SBo for the 3.9.2 version. It wasn't high on my list because the updates were minor.
 
Old 11-15-2019, 06:21 PM   #2208
MDKDIO
Member
 
Registered: Mar 2004
Location: Sweden
Distribution: Slackware 14.2 & Current
Posts: 196

Rep: Reputation: 36
Quote:
Originally Posted by bassmadrigal View Post
I'm the maintainer for openresolv. He must've removed the README (or renamed it to README.md) on the newer versions (the script works fine with the 3.9.0 version it calls). I'll try and push out an update this weekend to SBo for the 3.9.2 version. It wasn't high on my list because the updates were minor.
@bassmadrigal Thank you!
I didn't even think of that he could have changed the README file to something else. I did check now, and your guess is correct, it has been renamed README.md


/mdkdio
 
Old 11-15-2019, 06:51 PM   #2209
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,740

Rep: Reputation: Disabled
Tip:
Code:
pandoc -s -f gfm -t html5 -o /path/to/README.html README.md
 
Old 11-15-2019, 06:57 PM   #2210
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,628

Rep: Reputation: 515Reputation: 515Reputation: 515Reputation: 515Reputation: 515Reputation: 515
Quote:
Originally Posted by Didier Spaier View Post
Tip:
Code:
pandoc -s -f gfm -t html5 -o /path/to/README.html README.md
But pandoc is not in a stock slackware system , is 3thd party package.

WANT make pandoc or pandoc-bin as dependency only for the readme file ?
 
Old 11-15-2019, 07:04 PM   #2211
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,740

Rep: Reputation: Disabled
Quote:
Originally Posted by USUARIONUEVO View Post
But pandoc is not in a stock slackware system , is 3thd party package.

WANT make pandoc or pandoc-bin as dependency only for the readme file ?
Not just for that. But maybe a packager having installed pandoc can include README.html in the submission?
 
Old 11-15-2019, 07:49 PM   #2212
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,628

Rep: Reputation: 515Reputation: 515Reputation: 515Reputation: 515Reputation: 515Reputation: 515
packager or not packager , your suggest FORCE , to install on system the pandoc or pandoc-bin ... end of discussion.
 
Old 11-15-2019, 11:23 PM   #2213
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,740

Rep: Reputation: Disabled
I don't intend to force anyone to do anything, but just suggest something that can benefit users: believe me or not, maybe not worth it for a very small README but a lot of documentation is now provided by upstream projects that is way easier to read as a web pages or pdf documents than in markdown format. Was wrong just mentioning this just as an option?
 
Old 11-16-2019, 12:11 AM   #2214
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,628

Rep: Reputation: 515Reputation: 515Reputation: 515Reputation: 515Reputation: 515Reputation: 515
The wrong thing, is post a command , people CANT execute under slackware if not install some PANDOC ... probably the best is in the readme, "build documentation is an optional but requires install pandoc/pandoc-bin"


If some regular user read your comment ,only go to open ternimal and try execute the command.

Start saying , if have pandoc installed, can do "THIS" .... cause in stock slackware CANT DO THIS.

Last reply , i lost time explaining something too obiously for someone, if you no understand is not my problem....and this thread is not for this. :=)

And of course , you dont force to install pandoc to no one , but post command , only works if installs pandoc ...all right man , but not forced..i can execute pandoc , without installs... ha ha ha , very fun joke. :=)


In this case , i think the best way , is convert the README , and provide ready to use inside de slackbuild.tar kit , as an extra file , converted and ready , thats the best way.

Last edited by USUARIONUEVO; 11-16-2019 at 12:18 AM.
 
Old 11-16-2019, 12:39 PM   #2215
brodo
Member
 
Registered: Jan 2004
Location: Poland, Poznan
Distribution: Slackware current 32 / 64
Posts: 384

Rep: Reputation: 27
Quote:
Originally Posted by ponce View Post
Unfortunately that couldn't be enough as some perl packages might not have perl in their name or other non strictly perl packages might install some perl stuff (as you have discovered with wireshark).
How can I recognize which 3-rd party software (only from SBo repo are in my system) that must be recompiled ?
 
Old 11-16-2019, 01:10 PM   #2216
SCerovec
Senior Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware on x86 and arm
Posts: 1,878
Blog Entries: 2

Rep: Reputation: 580Reputation: 580Reputation: 580Reputation: 580Reputation: 580Reputation: 580
There is some odd ball mismatch going on:
I can't build Inkscape 1.0 on my -current and when i try run the prebuilt one from ponce's repo i get missing ImagMagick6 error while -current is running an I.M.-7 package

Looks like some commit somewhere is missing?
https://github.com/ImageMagick/ImageMagick/issues/236 <- related?

FWIW it started when i only referenced the missing symlinks

Last edited by SCerovec; 11-16-2019 at 01:18 PM.
 
Old 11-16-2019, 01:48 PM   #2217
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,740

Rep: Reputation: Disabled
Quote:
Originally Posted by brodo View Post
How can I recognize which 3-rd party software (only from SBo repo are in my system) that must be recompiled ?
For installed packages this will give you a list (not sure it be complete though):
Code:
grep usr/share/perl5/vendor_perl/ /var/log/packages/*|sed "s/:.*//"|uniq
 
1 members found this post helpful.
Old 11-16-2019, 05:04 PM   #2218
brodo
Member
 
Registered: Jan 2004
Location: Poland, Poznan
Distribution: Slackware current 32 / 64
Posts: 384

Rep: Reputation: 27
Quote:
Originally Posted by Didier Spaier View Post
For installed packages this will give you a list (not sure it be complete though):
Code:
grep usr/share/perl5/vendor_perl/ /var/log/packages/*|sed "s/:.*//"|uniq
Yes, that made the trick, Thanks for you and, of course, for the Ponce !

I recompiled the perl-html-tagset and *-parser packages, so wireshark compiled fine.
 
Old 11-16-2019, 05:56 PM   #2219
MDKDIO
Member
 
Registered: Mar 2004
Location: Sweden
Distribution: Slackware 14.2 & Current
Posts: 196

Rep: Reputation: 36
Quote:
Originally Posted by SCerovec View Post
There is some odd ball mismatch going on:
I can't build Inkscape 1.0 on my -current and when i try run the prebuilt one from ponce's repo i get missing ImagMagick6 error while -current is running an I.M.-7 package

Looks like some commit somewhere is missing?
https://github.com/ImageMagick/ImageMagick/issues/236 <- related?

FWIW it started when i only referenced the missing symlinks
Working fine here so far (@ 74% and still going). Was loads of dependencies to sort, but I skipped the libwpd one as it was not required.
I've seen nothing related to ImageMagick so far...

Running current 64-bit updated as of a couple of hours ago. Are you running 32-bit current? (shouldn't matter though, me thinks)

Just to clarify one thing, Inkscape 1.0 is BETA1, is 0.92.4 building ok for you?

Edit:
And now there's an error (3 actually) of missing files... INSTALL, NEWS and GPL*.txt
INSTALL -> INSTALL.md
NEWS -> NEWS.md
GPL*.txt -> New structure in the tar.bz2 file. All Licenses are found in its own folder LICENSES:
GPL-2.0-or-later.txt
GPL-2.0.txt
GPL-3.0-or-later.txt
GPL-3.0.txt
LGPL-2.1-or-later.txt
LGPL-2.1.txt
LGPL-3.0-or-later.txt
LGPL-3.0.txt
MPL-1.1.txt

Edited the inkscape.SlackBuild file, line 102 to be
AUTHORS COPYING* INSTALL.md NEWS.md README* TRANSLATORS doc/* \
Removed GPL and it built just fine

Last edited by MDKDIO; 11-16-2019 at 06:33 PM. Reason: Edit part...
 
Old 11-16-2019, 06:23 PM   #2220
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,628

Rep: Reputation: 515Reputation: 515Reputation: 515Reputation: 515Reputation: 515Reputation: 515
Hi , i cant compile efitools

Quote:
error: ‘EFI_WARN_UNKOWN_GLYPH’
I try update to 1.9.2 , but same error building
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 06:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 02:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 02:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 08:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration