LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Closed Thread
  Search this Thread
Old 09-01-2017, 03:28 AM   #2746
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,722

Rep: Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675

eigen3 many stable version since 3.2.7:

3.2.10:
http://eigen.tuxfamily.org/index.php...g#Eigen_3.2.10
http://bitbucket.org/eigen/eigen/get/3.2.10.tar.gz

or

3.3.4:
http://eigen.tuxfamily.org/index.php...og#Eigen_3.3.4
http://bitbucket.org/eigen/eigen/get/3.3.4.tar.gz
 
Old 09-01-2017, 04:58 PM   #2747
Pixxt
Member
 
Registered: May 2008
Distribution: Slackware, Debian,
Posts: 191

Rep: Reputation: 92
Quote:
Originally Posted by atelszewski View Post
Hi,

Just for kicks, x86_energy_perf_policy is available here.

--
Best regards,
Andrzej Telszewski
Thanks. But that is the least needed utility of the group in my use case.
 
Old 09-02-2017, 09:48 AM   #2749
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,722

Rep: Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675
Just for your info here, if you intend to push qt5 on current, the latest qt5 version (5.9) prefer build with 'pcre2'
qt5 compil with pcre, but by default its choice will be on pcre2, if pcre2 is installed.

tested here
 
2 members found this post helpful.
Old 09-02-2017, 11:01 AM   #2750
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,722

Rep: Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675
libgudev-232:

http://ftp.gnome.org/pub/gnome/sourc...gudev-232.news
http://ftp.gnome.org/pub/gnome/sourc...dev-232.tar.xz
 
Old 09-03-2017, 10:10 AM   #2751
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,874

Rep: Reputation: Disabled
pycairo-1.15.2

Its now hosted at github and uses setup.py instead of autotools.

https://github.com/pygobject/pycairo/blob/master/NEWS
https://github.com/pygobject/pycairo...-1.15.2.tar.gz

pygobject3-3.25.1

http://ftp.gnome.org/pub/GNOME/sourc...3.25.1.changes
http://ftp.gnome.org/pub/GNOME/sourc...-3.25.1.tar.xz
 
Old 09-03-2017, 10:54 AM   #2752
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,722

Rep: Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675
isn't stable release
 
Old 09-03-2017, 11:14 AM   #2753
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,069

Rep: Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318
Quote:
Originally Posted by gmgf View Post
isn't stable release
Since version 1.11.0 Pycairo uses `Semantic Versioning
<http://semver.org/>`__ i.e. the newest version is the latest stable one.
 
1 members found this post helpful.
Old 09-03-2017, 11:40 AM   #2754
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,722

Rep: Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675
sorry it's pygobject who isn't stable release
 
Old 09-03-2017, 11:49 AM   #2755
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,069

Rep: Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318Reputation: 1318
Quote:
Originally Posted by gmgf View Post
sorry it's pygobject who isn't stable release
also, it requires python 3.3+
Quote:
commit 1039e9a512d1df35e9c4656b0b41c1e4a25aafad
Author: Christoph Reiter <creiter@src.gnome.org>
Date: Sun Apr 2 14:04:39 2017 +0200

configure.ac: Require Python 3.3

At the time of the next release nothing will support 3.2 anymore.
 
2 members found this post helpful.
Old 09-03-2017, 01:21 PM   #2756
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,368

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
I make again some more noise arround "include" python3 :=)
Its fulle compatible to coexist python2+python3 without problems.

http://slackbuilds.org/repository/14.2/python/python3/
 
4 members found this post helpful.
Old 09-04-2017, 09:54 AM   #2757
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,722

Rep: Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675
mesa xlocale.h bug:

i have this problem on radeon card (since mesa is compiled on the new glibc):

https://bugs.archlinux.org/task/55244

it's solved with this patch:

https://git.archlinux.org/svntogit/p...=packages/mesa

the patch is also here:
https://cgit.freedesktop.org/mesa/me...a41abf622f3b0d
https://cgit.freedesktop.org/mesa/me...a41abf622f3b0d

Last edited by gmgf; 09-04-2017 at 10:53 AM.
 
1 members found this post helpful.
Old 09-04-2017, 11:25 AM   #2758
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,722

Rep: Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675
another new pango-1.40.12:

http://ftp.gnome.org/pub/gnome/sourc...o-1.40.12.news
http://ftp.gnome.org/pub/gnome/sourc...1.40.12.tar.xz

libzip-1.3.0:

two CVE fix:
https://nih.at/libzip/NEWS.html
https://nih.at/libzip/libzip-1.3.0.tar.xz

another new poppler-0.59.0:

https://poppler.freedesktop.org/
https://poppler.freedesktop.org/poppler-0.59.0.tar.xz

Last edited by gmgf; 09-04-2017 at 11:29 AM.
 
2 members found this post helpful.
Old 09-04-2017, 01:25 PM   #2759
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,722

Rep: Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675Reputation: 675
mesa-17.2.0:

https://mesa3d.org/relnotes/17.2.0.html
ftp://ftp.freedesktop.org/pub/mesa/mesa-17.2.0.tar.xz

but the xlocale.h patch isn't applied for the moment.

I have build it with the patch, it work without problem here:

https://cgit.freedesktop.org/mesa/me...a41abf622f3b0d
 
1 members found this post helpful.
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] how to show the current time at the top in the current shell Always ? rohitchauhan Linux - General 5 04-09-2014 03:05 PM
Slackware ARM (current) epic mistake: the current Android kernels are kicked out! Darth Vader Slackware 16 08-25-2013 04:36 PM
[SOLVED] setup fails on most current Slackware-current March 26, 2012 AlleyTrotter Slackware 15 04-09-2012 06:05 AM
Observation of Feb -current vs March -current Hangaber Slackware 14 03-12-2010 08:26 AM
cvs diff the most current and second last current version powah Linux - Software 1 03-30-2006 01:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration