LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-21-2020, 02:18 AM   #16
kgha
Member
 
Registered: May 2018
Location: Sweden
Distribution: Slackware 64 -current multilib from AlienBob's LiveSlak MATE
Posts: 315

Rep: Reputation: 231Reputation: 231Reputation: 231

Quote:
Originally Posted by TheNutCase View Post
I did install AlienBOB's MuseScore package, and when I ran it (from terminal mode) I got an error message indication that it couldn't find something called "libQt5WebEngine.so.5".
That's odd as well, since qt5-webkit is among the dependencies for musescore listed on the Slackbuilds site and you mentioned that you've been able to successfully build and install all those dependencies.

And since AlienBob's package is built for -current, there's a risk that you will get other error messages after solving this one (but if you're lucky it might work).

Quote:
Originally Posted by TheNutCase View Post
I tried building MuseScore from source - which is how i got the error in the FIRST place.
My bad. Of course you did. What I meant was: did you try building it without using a SBo script, following the instructions on musescore's website? This might produce some other informative error messages.
 
Old 06-21-2020, 03:08 PM   #17
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
At this point I think that I need a couple of somewhat related questions answered:

1.) What all is actually upgraded/installed when I update the Kernel?

2.) How do I find out which Kernel Slackware 14.2 (64bit) is actually using?

3.) Which is the correct method to use for upgrading the Kernel (I'm hoping that doing so will help get MuseScore working correctly)?

And thanks for being so patient with me, as this issue has been quite frustrating for me, to say the least.

Last edited by TheNutCase; 06-22-2020 at 10:25 PM.
 
Old 06-21-2020, 03:15 PM   #18
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,063

Rep: Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825
Your kernel version has nothing to do with compiling MuseScore successfully. Also, Willysr already mentioned to you that he was able to compile MuseScore error-free on Slackware 14.2. You need to take a good look at what you installed on your own computer.

One thing you definitely have to make sure of is: be completely up-to-date with your Slackware patches. Slackware 14.2 has several years of updates waiting in the /patches directory of the package tree, and some of those updates (e.g. mozilla-nss) are important ones.
 
Old 06-21-2020, 05:02 PM   #19
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
I have successfully downloaded and installed all the dependencies (and their sub-dependencies) found at this location:

https://slackbuilds.org/repository/1...arch=musescore

But for some strange reason, I can't get the MuseScore (3.4.2) package to compile correctly. Am I missing any packages? And what patches do I need?

Last edited by TheNutCase; 06-21-2020 at 05:05 PM.
 
Old 06-21-2020, 07:28 PM   #20
garpu
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 563

Rep: Reputation: 270Reputation: 270Reputation: 270
What's the console spew error message you get when you compile it?
 
Old 06-21-2020, 09:54 PM   #21
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
Check my reply on the first page.
 
Old 06-22-2020, 12:50 AM   #22
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,063

Rep: Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825Reputation: 6825
Quote:
Originally Posted by TheNutCase View Post
Check my reply on the first page.
The actual error occurs before the part which you shared with us. The text is of no use as it is.
 
Old 06-22-2020, 02:59 PM   #23
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
The actual error occurs before the part which you shared with us. The text is of no use as it is.
Here is as much of the comile output as I was able to copy. I hope this helps:
Code:
[ 68%] Building CXX object mscore/CMakeFiles/mscoreapp.dir/menus.cpp.o
cd /tmp/SBo/MuseScore-3.4.2/build.release/mscore && /usr/bin/c++   -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_GUI_LIB -DQT_HELP_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_PRINTSUPPORT_LIB -DQT_QML_LIB -DQT_QUICKCONTROLS2_LIB -DQT_QUICKTEMPLATES2_LIB -DQT_QUICKWIDGETS_LIB -DQT_QUICK_LIB -DQT_SQL_LIB -DQT_SVG_LIB -DQT_TESTCASE_BUILDDIR=\"/tmp/SBo/MuseScore-3.4.2/build.release\" -DQT_TESTLIB_LIB -DQT_WIDGETS_LIB -DQT_XMLPATTERNS_LIB -DQT_XML_LIB -DTELEMETRY_DISABLED -I/tmp/SBo/MuseScore-3.4.2/build.release/mscore -I/tmp/SBo/MuseScore-3.4.2/mscore -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -isystem /usr/lib64/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtGui -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/QtTest -isystem /usr/include/qt5/QtQml -isystem /usr/include/qt5/QtQuick -isystem /usr/include/qt5/QtQuickControls2 -isystem /usr/include/qt5/QtQuickTemplates2 -isystem /usr/include/qt5/QtQuickWidgets -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/qt5/QtXml -isystem /usr/include/qt5/QtXmlPatterns -isystem /usr/include/qt5/QtSvg -isystem /usr/include/qt5/QtSql -isystem /usr/include/qt5/QtPrintSupport -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/qt5/QtOpenGL -isystem /usr/include/qt5/QtHelp -I/tmp/SBo/MuseScore-3.4.2 -I/tmp/SBo/MuseScore-3.4.2/build.release -I/usr/include/freetype2 -I/tmp/SBo/MuseScore-3.4.2/thirdparty -I/tmp/SBo/MuseScore-3.4.2/global -I/tmp/SBo/MuseScore-3.4.2/singleapp/src -I/tmp/SBo/MuseScore-3.4.2/telemetry  -O2 -fPIC  -std=gnu++11 -fPIC -O2 -DNDEBUG -DQT_NO_DEBUG -DQT_NO_DEBUG_OUTPUT   -include /tmp/SBo/MuseScore-3.4.2/build.release/all.h -g -Wall -Wno-overloaded-virtual -Winvalid-pch -fPIC -std=gnu++11 -o CMakeFiles/mscoreapp.dir/menus.cpp.o -c /tmp/SBo/MuseScore-3.4.2/mscore/menus.cpp
[ 68%] Building CXX object mscore/CMakeFiles/mscoreapp.dir/musescore.cpp.o
cd /tmp/SBo/MuseScore-3.4.2/build.release/mscore && /usr/bin/c++   -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_GUI_LIB -DQT_HELP_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_PRINTSUPPORT_LIB -DQT_QML_LIB -DQT_QUICKCONTROLS2_LIB -DQT_QUICKTEMPLATES2_LIB -DQT_QUICKWIDGETS_LIB -DQT_QUICK_LIB -DQT_SQL_LIB -DQT_SVG_LIB -DQT_TESTCASE_BUILDDIR=\"/tmp/SBo/MuseScore-3.4.2/build.release\" -DQT_TESTLIB_LIB -DQT_WIDGETS_LIB -DQT_XMLPATTERNS_LIB -DQT_XML_LIB -DTELEMETRY_DISABLED -I/tmp/SBo/MuseScore-3.4.2/build.release/mscore -I/tmp/SBo/MuseScore-3.4.2/mscore -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -isystem /usr/lib64/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtGui -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/QtTest -isystem /usr/include/qt5/QtQml -isystem /usr/include/qt5/QtQuick -isystem /usr/include/qt5/QtQuickControls2 -isystem /usr/include/qt5/QtQuickTemplates2 -isystem /usr/include/qt5/QtQuickWidgets -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/qt5/QtXml -isystem /usr/include/qt5/QtXmlPatterns -isystem /usr/include/qt5/QtSvg -isystem /usr/include/qt5/QtSql -isystem /usr/include/qt5/QtPrintSupport -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/qt5/QtOpenGL -isystem /usr/include/qt5/QtHelp -I/tmp/SBo/MuseScore-3.4.2 -I/tmp/SBo/MuseScore-3.4.2/build.release -I/usr/include/freetype2 -I/tmp/SBo/MuseScore-3.4.2/thirdparty -I/tmp/SBo/MuseScore-3.4.2/global -I/tmp/SBo/MuseScore-3.4.2/singleapp/src -I/tmp/SBo/MuseScore-3.4.2/telemetry  -O2 -fPIC  -std=gnu++11 -fPIC -O2 -DNDEBUG -DQT_NO_DEBUG -DQT_NO_DEBUG_OUTPUT   -include /tmp/SBo/MuseScore-3.4.2/build.release/all.h -g -Wall -Wno-overloaded-virtual -Winvalid-pch -fPIC -std=gnu++11 -o CMakeFiles/mscoreapp.dir/musescore.cpp.o -c /tmp/SBo/MuseScore-3.4.2/mscore/musescore.cpp
In file included from /tmp/SBo/MuseScore-3.4.2/mscore/musescore.cpp:124:0:
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h:24:75: error: expected class-name before '{' token
 class MyWebUrlRequestInterceptor : public QWebEngineUrlRequestInterceptor {
                                                                           ^
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h:31:29: error: 'QWebEngineUrlRequestInfo' has not been declared
       void interceptRequest(QWebEngineUrlRequestInfo& info)
                             ^
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h: In constructor 'Ms::MyWebUrlRequestInterceptor::MyWebUrlRequestInterceptor(QObject*)':
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h:29:15: error: class 'Ms::MyWebUrlRequestInterceptor' does not have any field named 'QWebEngineUrlRequestInterceptor'
             : QWebEngineUrlRequestInterceptor(p) {}
               ^
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h: In member function 'void Ms::MyWebUrlRequestInterceptor::interceptRequest(int&)':
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h:33:18: error: request for member 'setHttpHeader' in 'info', which is of non-class type 'int'
             info.setHttpHeader("Accept-Language",
                  ^
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h: At global scope:
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h:42:47: error: expected class-name before '{' token
 class MyWebEnginePage : public QWebEnginePage {
                                               ^
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h:49:53: error: 'QWebEnginePage' has not been declared
       bool acceptNavigationRequest(const QUrl& url, QWebEnginePage::NavigationType type, bool isMainFrame);
                                                     ^
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h:49:84: error: expected ',' or '...' before 'type'
       bool acceptNavigationRequest(const QUrl& url, QWebEnginePage::NavigationType type, bool isMainFrame);
                                                                                    ^
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h: In constructor 'Ms::MyWebEnginePage::MyWebEnginePage(QObject*)':
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h:47:15: error: class 'Ms::MyWebEnginePage' does not have any field named 'QWebEnginePage'
             : QWebEnginePage(parent) {}
               ^
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h: At global scope:
/tmp/SBo/MuseScore-3.4.2/mscore/startcenter.h:56:41: error: expected class-name before '{' token
 class MyWebView : public QWebEngineView {
                                         ^
[ 68%] Building CXX object mscore/CMakeFiles/mscoreapp.dir/musescoredialogs.cpp.o
cd /tmp/SBo/MuseScore-3.4.2/build.release/mscore && /usr/bin/c++   -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_GUI_LIB -DQT_HELP_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_PRINTSUPPORT_LIB -DQT_QML_LIB -DQT_QUICKCONTROLS2_LIB -DQT_QUICKTEMPLATES2_LIB -DQT_QUICKWIDGETS_LIB -DQT_QUICK_LIB -DQT_SQL_LIB -DQT_SVG_LIB -DQT_TESTCASE_BUILDDIR=\"/tmp/SBo/MuseScore-3.4.2/build.release\" -DQT_TESTLIB_LIB -DQT_WIDGETS_LIB -DQT_XMLPATTERNS_LIB -DQT_XML_LIB -DTELEMETRY_DISABLED -I/tmp/SBo/MuseScore-3.4.2/build.release/mscore -I/tmp/SBo/MuseScore-3.4.2/mscore -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -isystem /usr/lib64/qt5/./mkspecs/linux-g++ -isystem /usr/include/qt5/QtGui -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/QtTest -isystem /usr/include/qt5/QtQml -isystem /usr/include/qt5/QtQuick -isystem /usr/include/qt5/QtQuickControls2 -isystem /usr/include/qt5/QtQuickTemplates2 -isystem /usr/include/qt5/QtQuickWidgets -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/qt5/QtXml -isystem /usr/include/qt5/QtXmlPatterns -isystem /usr/include/qt5/QtSvg -isystem /usr/include/qt5/QtSql -isystem /usr/include/qt5/QtPrintSupport -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/qt5/QtOpenGL -isystem /usr/include/qt5/QtHelp -I/tmp/SBo/MuseScore-3.4.2 -I/tmp/SBo/MuseScore-3.4.2/build.release -I/usr/include/freetype2 -I/tmp/SBo/MuseScore-3.4.2/thirdparty -I/tmp/SBo/MuseScore-3.4.2/global -I/tmp/SBo/MuseScore-3.4.2/singleapp/src -I/tmp/SBo/MuseScore-3.4.2/telemetry  -O2 -fPIC  -std=gnu++11 -fPIC -O2 -DNDEBUG -DQT_NO_DEBUG -DQT_NO_DEBUG_OUTPUT   -include /tmp/SBo/MuseScore-3.4.2/build.release/all.h -g -Wall -Wno-overloaded-virtual -Winvalid-pch -fPIC -std=gnu++11 -o CMakeFiles/mscoreapp.dir/musescoredialogs.cpp.o -c /tmp/SBo/MuseScore-3.4.2/mscore/musescoredialogs.cpp
mscore/CMakeFiles/mscoreapp.dir/build.make:1704: recipe for target 'mscore/CMakeFiles/mscoreapp.dir/musescore.cpp.o' failed
make[3]: *** [mscore/CMakeFiles/mscoreapp.dir/musescore.cpp.o] Error 1
make[3]: *** Waiting for unfinished jobs....
In file included from /tmp/SBo/MuseScore-3.4.2/mscore/editstyle.h:23:0,
                 from /tmp/SBo/MuseScore-3.4.2/mscore/editstyle.cpp:16:
/tmp/SBo/MuseScore-3.4.2/build.release/mscore/ui_editstyle.h: In member function 'void Ui_EditStyleBase::setupUi(QDialog*)':
/tmp/SBo/MuseScore-3.4.2/build.release/mscore/ui_editstyle.h:977:10: note: variable tracking size limit exceeded with -fvar-tracking-assignments, retrying without
     void setupUi(QDialog *EditStyleBase)
          ^
make[3]: Leaving directory '/tmp/SBo/MuseScore-3.4.2/build.release'
CMakeFiles/Makefile2:591: recipe for target 'mscore/CMakeFiles/mscoreapp.dir/all' failed
make[2]: *** [mscore/CMakeFiles/mscoreapp.dir/all] Error 2
make[2]: Leaving directory '/tmp/SBo/MuseScore-3.4.2/build.release'
Makefile:149: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/tmp/SBo/MuseScore-3.4.2/build.release'
Makefile:52: recipe for target 'release' failed
make: *** [release] Error 2
 
Old 06-22-2020, 03:21 PM   #24
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,481

Rep: Reputation: Disabled
could it be that you have built qt5 without webengine?
 
Old 06-22-2020, 07:14 PM   #25
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
could it be that you have built qt5 without webengine?
I tried building webengine, and got the following output (and yes, I installed all of it's dependencies):
Code:
bash-4.3# ./python3-PyQtWebEngine.SlackBuild
PyQtWebEngine-5.13.2/
PyQtWebEngine-5.13.2/configure.py
PyQtWebEngine-5.13.2/LICENSE
PyQtWebEngine-5.13.2/ChangeLog
PyQtWebEngine-5.13.2/pyproject.toml
PyQtWebEngine-5.13.2/mk_distinfo.py
PyQtWebEngine-5.13.2/README
PyQtWebEngine-5.13.2/NEWS
PyQtWebEngine-5.13.2/sip/
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebengineprofile.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginehistory.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginescript.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebengineclientcertificateselection.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginedownloaditem.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginecertificateerror.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginescriptcollection.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebengineview.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginepage.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginefullscreenrequest.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginecontextmenudata.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/QtWebEngineWidgetsmod.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginesettings.sip
PyQtWebEngine-5.13.2/sip/QtWebEngine/
PyQtWebEngine-5.13.2/sip/QtWebEngine/qquickwebengineprofile.sip
PyQtWebEngine-5.13.2/sip/QtWebEngine/qtwebengineglobal.sip
PyQtWebEngine-5.13.2/sip/QtWebEngine/qquickwebenginescript.sip
PyQtWebEngine-5.13.2/sip/QtWebEngine/QtWebEnginemod.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineclientcertificatestore.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineurlrequestinterceptor.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineurlrequestinfo.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineurlrequestjob.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineurlscheme.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebenginequotarequest.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/QtWebEngineCoremod.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineregisterprotocolhandlerrequest.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebenginehttprequest.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebenginenotification.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebenginecookiestore.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineurlschemehandler.sip
Configuring PyQtWebEngine 5.13.2...
The PyQtWebEngine .sip files will be installed in /usr/share/sip/PyQt5.
PyQtWebEngine will be installed in /usr/lib64/python3.7/site-packages/PyQt5.
PyQt 5.13.2 is being used.
Qt 5.12.8 is being used.
sip 4.19.20 is being used.
The sip executable is /usr/bin/python3-sip.
PyQtWebEngine is being built with 'protected' redefined as 'public'.
The PEP 484 stubs will be installed in
/usr/lib64/python3.7/site-packages/PyQt5.
The QScintilla API file will be installed in /usr/lib64/qt5/qsci/api/python.
Generating the C++ source for the QtWebEngine module...
/usr/bin/python3-sip -I /tmp/SBo/PyQtWebEngine-5.13.2/sip -I /usr/share/sip/PyQt5 -n PyQt5.sip -t WS_X11 -t Qt_5_12_4 -B Qt_6_0_0 -t QtWebEngine_5_12_4 -y QtWebEngine.pyi -a QtWebEngine.api -P -o -c /tmp/SBo/PyQtWebEngine-5.13.2/QtWebEngine /tmp/SBo/PyQtWebEngine-5.13.2/sip/QtWebEngine/QtWebEnginemod.sip
sip: Deprecation warning: the -B flag is deprecated
Generating the .pro file for the QtWebEngine module...
Generating the C++ source for the QtWebEngineCore module...
/usr/bin/python3-sip -I /tmp/SBo/PyQtWebEngine-5.13.2/sip -I /usr/share/sip/PyQt5 -n PyQt5.sip -t WS_X11 -t Qt_5_12_4 -B Qt_6_0_0 -t QtWebEngine_5_12_4 -y QtWebEngineCore.pyi -a QtWebEngineCore.api -P -o -c /tmp/SBo/PyQtWebEngine-5.13.2/QtWebEngineCore /tmp/SBo/PyQtWebEngine-5.13.2/sip/QtWebEngineCore/QtWebEngineCoremod.sip
sip: Deprecation warning: the -B flag is deprecated
Generating the .pro file for the QtWebEngineCore module...
Generating the C++ source for the QtWebEngineWidgets module...
/usr/bin/python3-sip -I /tmp/SBo/PyQtWebEngine-5.13.2/sip -I /usr/share/sip/PyQt5 -n PyQt5.sip -t WS_X11 -t Qt_5_12_4 -B Qt_6_0_0 -t QtWebEngine_5_12_4 -y QtWebEngineWidgets.pyi -a QtWebEngineWidgets.api -P -o -c /tmp/SBo/PyQtWebEngine-5.13.2/QtWebEngineWidgets /tmp/SBo/PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/QtWebEngineWidgetsmod.sip
sip: Deprecation warning: the -B flag is deprecated
Generating the .pro file for the QtWebEngineWidgets module...
Generating the QScintilla API file...
Generating the top-level .pro file...
Generating the Makefiles...
/usr/bin/qmake-qt5 -recursive PyQtWebEngine.pro
Info: creating stash file /tmp/SBo/PyQtWebEngine-5.13.2/.qmake.stash
Reading /tmp/SBo/PyQtWebEngine-5.13.2/QtWebEngine/QtWebEngine.pro
Project ERROR: Unknown module(s) in QT: webengine
Error: /usr/bin/qmake-qt5 failed to create a Makefile from PyQtWebEngine.pro.
bash-4.3#

Last edited by TheNutCase; 06-22-2020 at 07:23 PM.
 
Old 06-22-2020, 07:28 PM   #26
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,426

Rep: Reputation: 447Reputation: 447Reputation: 447Reputation: 447Reputation: 447
i can reproduce the error.


error is caused to build qt5 without webengine ... you put some lines with error ocurs , but you no see what append first ..errors pointing webengine as culprit ...


Quote:
/usr/src/slapt-src/multimedia/MuseScore/MuseScore-3.4.2/mscore/startcenter.h: En el constructor ‘Ms::MyWebEnginePage::MyWebEnginePage(QObject*)’:
/usr/src/slapt-src/multimedia/MuseScore/MuseScore-3.4.2/mscore/startcenter.h:47:15: error: la clase ‘Ms::MyWebEnginePage’ no tiene ningún campo llamado ‘QWebEnginePage’
: QWebEnginePage(parent) {}

Last edited by USUARIONUEVO; 06-22-2020 at 07:36 PM.
 
Old 06-22-2020, 08:56 PM   #27
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by USUARIONUEVO View Post
i can reproduce the error.


error is caused to build qt5 without webengine ... you put some lines with error ocurs , but you no see what append first ..errors pointing webengine as culprit ...
I tried to build webengine WITHOUT QT5 - and got the following output (but I built Qt5 without errors):
Code:
bash-4.3# ./python3-PyQtWebEngine.SlackBuild
PyQtWebEngine-5.13.2/
PyQtWebEngine-5.13.2/configure.py
PyQtWebEngine-5.13.2/LICENSE
PyQtWebEngine-5.13.2/ChangeLog
PyQtWebEngine-5.13.2/pyproject.toml
PyQtWebEngine-5.13.2/mk_distinfo.py
PyQtWebEngine-5.13.2/README
PyQtWebEngine-5.13.2/NEWS
PyQtWebEngine-5.13.2/sip/
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebengineprofile.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginehistory.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginescript.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebengineclientcertificateselection.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginedownloaditem.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginecertificateerror.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginescriptcollection.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebengineview.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginepage.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginefullscreenrequest.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginecontextmenudata.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/QtWebEngineWidgetsmod.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineWidgets/qwebenginesettings.sip
PyQtWebEngine-5.13.2/sip/QtWebEngine/
PyQtWebEngine-5.13.2/sip/QtWebEngine/qquickwebengineprofile.sip
PyQtWebEngine-5.13.2/sip/QtWebEngine/qtwebengineglobal.sip
PyQtWebEngine-5.13.2/sip/QtWebEngine/qquickwebenginescript.sip
PyQtWebEngine-5.13.2/sip/QtWebEngine/QtWebEnginemod.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineclientcertificatestore.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineurlrequestinterceptor.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineurlrequestinfo.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineurlrequestjob.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineurlscheme.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebenginequotarequest.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/QtWebEngineCoremod.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineregisterprotocolhandlerrequest.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebenginehttprequest.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebenginenotification.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebenginecookiestore.sip
PyQtWebEngine-5.13.2/sip/QtWebEngineCore/qwebengineurlschemehandler.sip
Usage: python configure.py [options]

configure.py: error: '/usr/bin/qmake-qt5' is not an executable
 
Old 06-22-2020, 09:12 PM   #28
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,426

Rep: Reputation: 447Reputation: 447Reputation: 447Reputation: 447Reputation: 447
you are on the wrong way ...

qt5 with webengine enabled.

If you read the qt5 notes probably understand better what im saying.

Quote:
To NOT build qtwebengine (EXPERIMENTAL):

WEBENGINE=no ./qt5.SlackBuild


Then , you need build qt5 , with WEBENGINE=yes "thats the default option" ... but you can forced to ensure.

Quote:
WEBENGINE=yes ./qt5.SlackBuild



YOUR PROBLEM IS UNDER QT5 PACKAGE

what qt5 package have ?
you build from slackbuilds ?
you are sure build with wenengine=yes ?

As i say i can reproduce your error build, but only under "incomplete" qt5 package build (no webengine)

Last edited by USUARIONUEVO; 06-22-2020 at 09:16 PM.
 
Old 06-22-2020, 09:55 PM   #29
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
Accodging to this link ( https://slackbuilds.org/repository/1...PyQtWebEngine/ )one of the sub-requirements is qt5.
 
Old 06-22-2020, 10:21 PM   #30
TheNutCase
Member
 
Registered: May 2016
Location: Columbia, South Carolina14
Distribution: Slackware 14.2
Posts: 334

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by USUARIONUEVO View Post
you are on the wrong way ...

qt5 with webengine enabled.

If you read the qt5 notes probably understand better what im saying.



Then , you need build qt5 , with WEBENGINE=yes "thats the default option" ... but you can forced to ensure.




YOUR PROBLEM IS UNDER QT5 PACKAGE

what qt5 package have ?
you build from slackbuilds ?
you are sure build with wenengine=yes ?

As i say i can reproduce your error build, but only under "incomplete" qt5 package build (no webengine)
But I built Qt5 using "WEBENGINE=yes" as the default. So Why can't I then build MuseScore?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Trouble building Musescore on Slackware 64 Captain Pinkeye Slackware 7 06-30-2014 12:41 PM
[SOLVED] Musescore won't install on Intel 64 bit CPU PC, help please alex polvorilla Linux - Software 3 12-30-2012 02:46 PM
LXer: MuseScore, LilyPond, and Chordii: Projects on the Move LXer Syndicated Linux News 0 03-29-2011 05:40 AM
Classical organ sound fonts for MuseScore Tom Nichol Linux - Software 0 06-18-2009 02:30 PM
MusEScore 0.1pre2 compilation issues stev160 Linux - Software 0 07-15-2004 09:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration