Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 08-07-2002, 09:22 PM   #1
LQ Newbie
Registered: Jun 2002
Location: Northern, NJ
Distribution: Slackware
Posts: 20

Rep: Reputation: 0
Please somone help internet problem for my slackbox.

I am running a Slackware linux box and have a linksys cable/dsl router, I cant get the internet to work but I cant do DHCP because I need port forwarding. Im trying to get static to work but I cant. Someone please help me with this problem. The Slackware is 8.1 and the computer is a Celeon 400 mhz 128 ram 8 gig hd.
Old 08-07-2002, 10:36 PM   #2
Senior Member
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
You might find the DSL-HOWTO helpfull. Normally located in


It covers using PPPoX and PPPoE, etc.

I have ADSL on POTS but it is static IP so it is just like any network connection. But the internet service has to be configured for static and the ISP has to assign your IP address for it to work. If they didn't assign you an IP and gateway address then you can't use static. Then it must be using DHCP for the assignment. Perhaps if you post the service provider name, someone may use the same or similar provider that could help more.
Old 08-08-2002, 01:46 PM   #3
Registered: Jul 2002
Location: Lacon, IL
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
You might try this for setting up a static ip for eth0

make a file called /etc/rc.d/rc.eth0
ie.. (touch /etc/rc.d/rc.eth0)
edit it with this content

#! /bin/sh

echo "Configuring eth0 as ${eth0}..."
/sbin/ifconfig eth0 up
/sbin/ifconfig eth0 ${eth0} broadcast ${BROADCAST} netmask ${NETMASK}
echo "Setting up IP routes..."
/sbin/route add -net ${NETWORK} dev eth0
/sbin/route add -host ${eth0} eth0
/sbin/route add default gw ${GATEWAY}
if [ -x /etc/rc.d/rc.forward-up ]; then
. /etc/rc.d/rc.forward-up

This works for my dsl and I am static
Old 08-08-2002, 01:52 PM   #4
Registered: Jul 2002
Location: Lacon, IL
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
Oh and make a file called /etc/rc.d/rc.forward-up

if [ -f /proc/sys/net/ipv4/ip_forward ]; then
if [ "$IPV4_FORWARD" = "1" ]; then
echo "Activating IPv4 packet forwarding..."
echo 1 > /proc/sys/net/ipv4/ip_forward
echo "Disabling IPv4 packet forwarding..."
echo 0 > /proc/sys/net/ipv4/ip_forward

this will activate the ip_forward modual for you

Check to make sure its already activated in

Hope this helps


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
my slackbox didn't detect my mouse Paxmaster Linux - Software 2 09-24-2004 04:56 PM
ssh internet -> router -> slackbox Tuttle Linux - Networking 5 09-14-2004 01:51 PM
Please somone help me (Problems with my modem...) parscyber Linux - Hardware 1 08-20-2004 05:57 PM
How to know when somone is trying to login xtreme17 Programming 3 10-19-2003 02:38 AM
I finally gave up.... Somone please help... mqonnet Linux - Distributions 1 02-28-2003 01:09 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:20 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration