LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-21-2020, 10:24 AM   #16
LuckyCyborg
Member
 
Registered: Mar 2010
Posts: 650

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419

I had a similar problem with my main computer and I solved by removing the XFCE.

Last edited by LuckyCyborg; 06-21-2020 at 10:25 AM.
 
Old 06-21-2020, 10:40 AM   #17
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,700
Blog Entries: 1

Rep: Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049
Once had that problem when using KDE5 and solved it by removing the check marks in the boxes in the Xfce settings. In Xfce go to, "Settings Manager" > "Session and Startup" > "Application Autostart."
You can also do that from within kde by opening a terminal and running,

xfce4-settings-manager

at the prompt.

Last edited by cwizardone; 06-21-2020 at 10:43 AM.
 
1 members found this post helpful.
Old 06-21-2020, 10:44 AM   #18
Gordie
Member
 
Registered: Aug 2007
Location: Nolalu, Ontario, Canada
Distribution: Slackware Linux
Posts: 607

Rep: Reputation: 222Reputation: 222Reputation: 222
Quote:
Originally Posted by cwizardone View Post
Once had that problem when using KDE5 and solved it by removing the check marks in the boxes in the Xfce settings. In Xfce go to, "Settings Manager" > "Session and Startup" > "Application Autostart."
You can also do that from within kde by opening a terminal and running,

xfce4-settings-manager

at the prompt.
Did you mean to type
Code:
xfce4-settings-manager
 
Old 06-21-2020, 10:47 AM   #19
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,700
Blog Entries: 1

Rep: Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049
^^^ ?
 
Old 06-21-2020, 10:50 AM   #20
Gordie
Member
 
Registered: Aug 2007
Location: Nolalu, Ontario, Canada
Distribution: Slackware Linux
Posts: 607

Rep: Reputation: 222Reputation: 222Reputation: 222
Quote:
Originally Posted by cwizardone View Post
^^^ ?
I used copy and paste to try your command and xfce-settings-manager was what I got.

Anyway, is there now so all is good. Enjoy your day and sorry for the noise
 
Old 06-21-2020, 03:22 PM   #21
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,700
Blog Entries: 1

Rep: Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049
Ships in the night and all that.
 
Old 06-22-2020, 09:52 AM   #22
0XBF
Member
 
Registered: Nov 2018
Location: Winnipeg
Distribution: Slackware
Posts: 188

Rep: Reputation: 138Reputation: 138
Quote:
Originally Posted by cwizardone View Post
Once had that problem when using KDE5 and solved it by removing the check marks in the boxes in the Xfce settings. In Xfce go to, "Settings Manager" > "Session and Startup" > "Application Autostart."
You can also do that from within kde by opening a terminal and running,

xfce4-settings-manager

at the prompt.
I tried this in hopes that it would be a simpler solution than using the ~/.local folder "fix". Didn't work out for me though, xfce4-notifyd keeps on running in plasma. I switched it back with the .local folder again and reverted the checkboxes in xfce4-settings-manager. Now baloo isn't autostarting anymore. Before mucking about with xfce4 settings it would autostart with a plasma session, afterwards it doesn't even though plasma settings say it does (I noticed baloo because I have been troubleshooting it lately, its running into problems with mutliple instances and hitting inotify limits).

Guess I have to dig into ~/.config now and find whatever files that xfce4-settings-manager created in there. It'd be nice if these two DE's played together a little nicer. I haven't tried any of the newer XFCE packages yet but I'm hopping they improve this bit in the newer versions.
 
Old 06-22-2020, 10:13 AM   #23
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,700
Blog Entries: 1

Rep: Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049
There is a box for baloo in the xfce4 settings. Check or uncheck as needed.
The method I outlined worked for me with kde5, which I've since removed from
the computer and won't be installing again. Ever. Each to their own.
Sorry you had a problem.

While I think about it. Have you looked at the kde startup and shutdown/service manager settings?

Last edited by cwizardone; 06-22-2020 at 10:15 AM.
 
Old 06-22-2020, 10:55 AM   #24
0XBF
Member
 
Registered: Nov 2018
Location: Winnipeg
Distribution: Slackware
Posts: 188

Rep: Reputation: 138Reputation: 138
I did try to use the xfce4 settings checkboxes to reapply autostarting baloo but it didn't work as advertised. Perhaps its because I ran the application from the Plasma 5 environment. I didn't want to start a full XFCE session because I have had it dirty up ~/.config in the past.

Anyways, I used 'find' to locate modified ~/.config files from the last hour and it looks like xfce4-settings-manager copied /etc/xdg/autostart/* to ~/.config/autostart/ and wiped the contents of the files in the process. Archwiki tells me that ~/.config/autostart is prioritized over the /etc/xdg/autostart directory, hence nothing autostarting properly (except for xfce4-notifyd, go figure).

I wiped ~/.config/autostart and baloo is back to working as expected. It looks like plasma uses ~/.config/autostart for starting latte-dock (since it put that back in after restarting the session), and /etc/xdg/autostart for starting baloo. If a user disables autostarting baloo in plasma, it write to ~/.config/baloofilerc. XFCE on the other hand does it by using ~/.config/autostart which has a side effect overriding /etc/xdg/autostart, and contradicting what plasma settings want.

Like you said, "to each their own". I'm not trying to blame one or the other but the problem stands that they tend to share and overwrite each other's config files, as seen in this case.
 
1 members found this post helpful.
Old 06-22-2020, 12:01 PM   #25
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado, USA
Distribution: Slackware
Posts: 625

Rep: Reputation: 205Reputation: 205Reputation: 205
Just to add to this notification discussion...

I've been wrestling with a failing notification process since the upgrade to KDE-5_20.06 w/elogind. I'm running X11, not Wayland, and everything else appears OK so far. The send-notify is invoked from a local server when a new email arrives. It has worked with ktown until the latest update. Here's a sample of the error in /var/log/messages when I try to manually initiate a message:

Code:
Jun 22 08:56:50 my_desktop sshd[31005]: Accepted publickey for my_user from 10.10.10.x port 59044 ssh2: RSA SHA256:20gLDihoYgjH8RUrwrTagR/bFL2AuFkhG8yItuWC06Y
Jun 22 08:56:50 my_desktop dbus-daemon[2674]: [session uid=1001 pid=2672] Activating service name='org.freedesktop.Notifications' requested by ':1.177' (uid=1001 pid=31014 comm="notify-send Email Name <email@example.com> Fwd: A")
Jun 22 08:56:55 my_desktop sshd[31012]: Received disconnect from 10.10.10.x port 59044:11: disconnected by user
Jun 22 08:56:55 my_desktop sshd[31012]: Disconnected from user my_user 10.10.10.x port 59044
Jun 22 08:57:50 my_desktop dbus-daemon[2674]: [session uid=1001 pid=2672] Activated service 'org.freedesktop.Notifications' failed: Process org.freedesktop.Notifications exited with status 1
I'm at a loss as to were to look next.
 
Old 06-22-2020, 12:01 PM   #26
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,700
Blog Entries: 1

Rep: Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049Reputation: 3049
Quote:
Originally Posted by 0XBF View Post
......I'm not trying to blame one or the other but the problem stands that they tend to share and overwrite each other's config files, as seen in this case.
Oh, I agree, but in the past kde5 did more damage to Xfce than the other way around. The last few versions of kde5 haven't caused as much interference.
OTOH, Kde4, which I'm using at the moment, did not change or overwrite the Xfce settings.
 
Old 06-24-2020, 11:15 PM   #27
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado, USA
Distribution: Slackware
Posts: 625

Rep: Reputation: 205Reputation: 205Reputation: 205
Quote:
Originally Posted by Chuck56 View Post
Just to add to this notification discussion...

I've been wrestling with a failing notification process since the upgrade to KDE-5_20.06 w/elogind. I'm running X11, not Wayland, and everything else appears OK so far. The send-notify is invoked from a local server when a new email arrives. It has worked with ktown until the latest update.
Well I found a workaround and now notifications are displayed on my Plasma desktop from the local server when a new email arrives. In the past I piped a message over ssh and provided "export DISPLAY=:0" before the "notify-send". Now with the latest Plasma I have to get the current desktop DBUS_SESSION_BUS_ADDRESS then export the full value before the "notify-send". The full value looks like this:
Code:
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-L5IhFXU7qB,guid=aa8621b06cadbd67250cac574ef3397b
So this ends up as a 2 step process instead of the old 1 step process but at least it's working!
 
Old 06-25-2020, 07:56 AM   #28
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,795

Rep: Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709
I have build a package of the git 'xfce4-notify' version and the conflict with plasma is fixed:

https://git.xfce.org/apps/xfce4-noti...96b53f434a6f47

probably fixed in the future xfce4-notify-0.62 version.
 
2 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] The KDE Plasma 5.34.4 was released 10 days ago and it is not in KTown yet. What happened with the "greatest and mightest" thing? ZhaoLin1457 Slackware 63 08-13-2018 10:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration