LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-29-2019, 04:08 AM   #1
recan
Member
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 34

Rep: Reputation: Disabled
no sound using amd Rx 580 card !


Hello
recently i changed my graphic card Nvdia Gtx 1060 with Amd Rx 580.
so I uninstalled the Nvidia Driver using the Binary driver from Nvidia
rebooting kde started and boom no sound , in pavucontrol all my hdmi profils look as unplugged I tried slackware live edition and the sound works fine.
I m using kernel 4.4.157 ; need I a new kernel ?
PHP Code:
lspci -knn|grep -iA3 VGA
01
:00.0 VGA compatible controller [0300]: Advanced Micro DevicesInc. [AMD/ATIDevice [1002:67df] (rev e7)
        
SubsystemDevice [1da2:e353]
01:00.1 Audio device [0403]: Advanced Micro DevicesInc. [AMD/ATIDevice [1002:aaf0]
        
SubsystemDevice [1da2:aaf0
PHP Code:
aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0PCH [HDA Intel PCH], périphérique 0ALC887-VD Analog [ALC887-VD Analog]
  
Sous-périphériques1/1
  Sous
-périphérique #0: subdevice #0
carte 1HDMI [HDA ATI HDMI], périphérique 3HDMI 0 [HDMI 0]
  
Sous-périphériques1/1
  Sous
-périphérique #0: subdevice #0
carte 1HDMI [HDA ATI HDMI], périphérique 7HDMI 1 [HDMI 1]
  
Sous-périphériques0/1
  Sous
-périphérique #0: subdevice #0
carte 1HDMI [HDA ATI HDMI], périphérique 8HDMI 2 [HDMI 2]
  
Sous-périphériques1/1
  Sous
-périphérique #0: subdevice #0
carte 1HDMI [HDA ATI HDMI], périphérique 9HDMI 3 [HDMI 3]
  
Sous-périphériques1/1
  Sous
-périphérique #0: subdevice #0
carte 1HDMI [HDA ATI HDMI], périphérique 10HDMI 4 [HDMI 4]
  
Sous-périphériques1/1
  Sous
-périphérique #0: subdevice #0
carte 1HDMI [HDA ATI HDMI], périphérique 11HDMI 5 [HDMI 5]
  
Sous-périphériques1/1
  Sous
-périphérique #0: subdevice #0
root@H61:~# aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0PCH [HDA Intel PCH], périphérique 0ALC887-VD Analog [ALC887-VD Analog]
  
Sous-périphériques1/1
  Sous
-périphérique #0: subdevice #0
carte 1HDMI [HDA ATI HDMI], périphérique 3HDMI 0 [HDMI 0]
  
Sous-périphériques1/1
  Sous
-périphérique #0: subdevice #0
carte 1HDMI [HDA ATI HDMI], périphérique 7HDMI 1 [HDMI 1]
  
Sous-périphériques0/1
  Sous
-périphérique #0: subdevice #0
carte 1HDMI [HDA ATI HDMI], périphérique 8HDMI 2 [HDMI 2]
  
Sous-périphériques1/1
  Sous
-périphérique #0: subdevice #0
carte 1HDMI [HDA ATI HDMI], périphérique 9HDMI 3 [HDMI 3]
  
Sous-périphériques1/1
  Sous
-périphérique #0: subdevice #0
carte 1HDMI [HDA ATI HDMI], périphérique 10HDMI 4 [HDMI 4]
  
Sous-périphériques1/1
  Sous
-périphérique #0: subdevice #0
carte 1HDMI [HDA ATI HDMI], périphérique 11HDMI 5 [HDMI 5]
  
Sous-périphériques1/1
  Sous
-périphérique #0: subdevice #0 
any help plz , forgive my english !
 
Old 10-29-2019, 10:03 AM   #2
0XBF
Member
 
Registered: Nov 2018
Location: Winnipeg
Distribution: Slackware
Posts: 92

Rep: Reputation: Disabled
You could try clearing out your old pulseaudio config files with something like:
Code:
mv ~/.config/pulse ~/.config/pulse_old
And then restarting pulseaudio by killing it:
Code:
pulseaudio -k
Pulseaudio should restart automatically and remake the .config/pulse files (as long as you haven't disabled autospawning for pulse). If that works then you can remove the .config/pulse_old files. If it doesn't work then we will have to dig deeper.
 
Old 10-29-2019, 10:04 AM   #3
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 197

Rep: Reputation: 84
You need 4.19.x or later (or perhaps 4.14.x) for the kernel drivers to properly work.
I'm not sure that matters if your userspace is too old. 14.2 based "current" is probably
your best chance.
 
Old 10-29-2019, 11:18 AM   #4
recan
Member
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 34

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by 0XBF View Post
You could try clearing out your old pulseaudio config files with something like:
Code:
mv ~/.config/pulse ~/.config/pulse_old
And then restarting pulseaudio by killing it:
Code:
pulseaudio -k
Pulseaudio should restart automatically and remake the .config/pulse files (as long as you haven't disabled autospawning for pulse). If that works then you can remove the .config/pulse_old files. If it doesn't work then we will have to dig deeper.
Thank you for your answer but not working.
 
Old 10-29-2019, 11:19 AM   #5
recan
Member
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 34

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by rogan View Post
You need 4.19.x or later (or perhaps 4.14.x) for the kernel drivers to properly work.
I'm not sure that matters if your userspace is too old. 14.2 based "current" is probably
your best chance.
thank you , any help or suggestion howto build kernel ?.
 
Old 10-29-2019, 12:19 PM   #6
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 6,219

Rep: Reputation: 3961Reputation: 3961Reputation: 3961Reputation: 3961Reputation: 3961Reputation: 3961Reputation: 3961Reputation: 3961Reputation: 3961Reputation: 3961Reputation: 3961
You can grab a config file from -current's source tree on your favorite mirror, then just copy that into the directory of your extracted 4.19 kernel sources.

Full instructions can be found here, but simplified instructions are below. My instructions may not follow conventional practices, but they are simple and should work fine.

Code:
# Become root
su -

# Download the latest kernel and extract it to /usr/src
wget https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.19.81.tar.xz
cd /usr/src
tar xvf ~/linux-4.19.81.tar.xz
cd linux-4.19.81

# Now download -current's kernel config for 4.19.x and rename it to .config
wget https://mirror.slackbuilds.org/slackware/slackware64-current/source/k/kernel-configs/config-generic-4.19.80.x64
mv config-generic-4.19.80.x64 .config

# Build the kernel and modules and then install the modules
make bzImage modules
make modules_install

# Move your kernel to /boot and generate an initrd for the new kernel
cp arch/x86/boot/bzImage /boot/vmlinuz-generic-4.19.80
$(/usr/share/mkinitrd/mkinitrd_command_generator.sh -k 4.19.80 -a -o /boot/initrd-4.19.80.gz)

# Update either /etc/lilo.conf to point to the new kernel and run lilo or run eliloconfig
# If you need help with this part, let us know what bootloader you have and we can provide additional guidance
But as rogan mentioned, the rest of 14.2 is probably too old to properly use that card. You'd likely need to run the proprietary amdgpu-pro drivers or upgrade to -current (which is the development version of Slackware that will eventually become 15.0)
 
Old 10-29-2019, 01:20 PM   #7
recan
Member
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 34

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bassmadrigal View Post
You can grab a config file from -current's source tree on your favorite mirror, then just copy that into the directory of your extracted 4.19 kernel sources.

Full instructions can be found here, but simplified instructions are below. My instructions may not follow conventional practices, but they are simple and should work fine.

Code:
# Become root
su -

# Download the latest kernel and extract it to /usr/src
wget https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.19.81.tar.xz
cd /usr/src
tar xvf ~/linux-4.19.81.tar.xz
cd linux-4.19.81

# Now download -current's kernel config for 4.19.x and rename it to .config
wget https://mirror.slackbuilds.org/slackware/slackware64-current/source/k/kernel-configs/config-generic-4.19.80.x64
mv config-generic-4.19.80.x64 .config

# Build the kernel and modules and then install the modules
make bzImage modules
make modules_install

# Move your kernel to /boot and generate an initrd for the new kernel
cp arch/x86/boot/bzImage /boot/vmlinuz-generic-4.19.80
$(/usr/share/mkinitrd/mkinitrd_command_generator.sh -k 4.19.80 -a -o /boot/initrd-4.19.80.gz)

# Update either /etc/lilo.conf to point to the new kernel and run lilo or run eliloconfig
# If you need help with this part, let us know what bootloader you have and we can provide additional guidance
But as rogan mentioned, the rest of 14.2 is probably too old to properly use that card. You'd likely need to run the proprietary amdgpu-pro drivers or upgrade to -current (which is the development version of Slackware that will eventually become 15.0)
Thank you very much for all suggestions and notes , I will try hopfly no breaking system IoI
for the Proprietary amdgpu-pro I dont know howto instal it at all.
I swith to Grub2 because lilo fall back to safe mode , it was first issue related to ma card rx 580.
 
Old 10-29-2019, 06:41 PM   #8
PJBrs
Member
 
Registered: Oct 2006
Distribution: Slackware 14.2
Posts: 47

Rep: Reputation: 18
I had some similar issues with my R9 Nano. I didn't want to switch to -current, don't want to risk any breakage. I just installed a fairly recent kernel package from current and that seemed to just work. Probably still does with the latest kernel package, although I can't offer any guarantees. I did update mesa, which was quite a chore on 14.2, although the worst of it, llvm-8.0, can be found in /extra in slackware. So, in my experience 14.2 can be made to work, but it does require quite some compilation to get good performance.
 
Old 10-30-2019, 01:28 AM   #9
recan
Member
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 34

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by PJBrs View Post
I had some similar issues with my R9 Nano. I didn't want to switch to -current, don't want to risk any breakage. I just installed a fairly recent kernel package from current and that seemed to just work. Probably still does with the latest kernel package, although I can't offer any guarantees. I did update mesa, which was quite a chore on 14.2, although the worst of it, llvm-8.0, can be found in /extra in slackware. So, in my experience 14.2 can be made to work, but it does require quite some compilation to get good performance.

Thank you so much for your reply and advise
I tried to install compile and install a new kernel 4.19
no sound also probably Something I mess up ... , but I will try again if not i will install the live edition of slackware.
thank you everyone for all your concerning and help
be safe.
 
Old 10-30-2019, 04:30 AM   #10
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 197

Rep: Reputation: 84
I have tried the same ting as PJBrs talked about. I got the Frankenware to work in the end with a LOT of work.
All I got for the trouble was a unupgradeable system that required even more work. Just don't do it is My advice.

Save yourself some trouble and just install one of the isos from e.g. the slackware.uk site:
https://slackware.uk/people/alien-cu...64-current-iso

Running current is not going to be a bug-free experience. Already the installer usually has a few gremlins but you'll
have the "latest and the greatest" of the best, and all your hardware IS going to be supported.
 
Old 10-30-2019, 03:09 PM   #11
recan
Member
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 34

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by rogan View Post
I have tried the same ting as PJBrs talked about. I got the Frankenware to work in the end with a LOT of work.
All I got for the trouble was a unupgradeable system that required even more work. Just don't do it is My advice.

Save yourself some trouble and just install one of the isos from e.g. the slackware.uk site:
https://slackware.uk/people/alien-cu...64-current-iso

Running current is not going to be a bug-free experience. Already the installer usually has a few gremlins but you'll
have the "latest and the greatest" of the best, and all your hardware IS going to be supported.
Thank you very much , running current as it is non bug-free I prefer to stay away , I will try to install the live edition based on current less bugs I think .
 
Old 10-30-2019, 06:50 PM   #12
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 197

Rep: Reputation: 84
Nothing is bug-free, and I dind't mean to imply that current is a buggy mess. It's relly quite ok. Try it!
If you happen to encounter something you percieve as a bug, then report it here. There's a lot of helpful
people here that usually helps you out with problems.
 
Old 10-30-2019, 07:23 PM   #13
recan
Member
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 34

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by rogan View Post
Nothing is bug-free, and I dind't mean to imply that current is a buggy mess. It's relly quite ok. Try it!
If you happen to encounter something you percieve as a bug, then report it here. There's a lot of helpful
people here that usually helps you out with problems.
Hello , writing from installed Live slackware edition ; sound work fine , and i m planning to try the current in futur. surely it is not buggy mess but for daily use I suspect to be a good choice correct me if I m wrrong
And I M sure that slack s users are a union community ready to help and this from my personel expriance.

Thank you veru much happy to be among slack s users.
 
Old 10-30-2019, 07:31 PM   #14
Skaendo
Senior Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 1,044

Rep: Reputation: Disabled
If you are trying to get audio through HDMI, I recently went through this on 14.2.

I had to open up a terminal and do the following:
Code:
## Start alsamixer
    $ alsamixer

## Select audio device
    F6

## Fix auto-mute
    Auto-Mute -> Disabled

## Exit
    Esc
After that, audio through HDMI works fine for me.
You might need to restart application.

NOTE: Your audio device might not be defined as HDMI, mine was named 'HDA ATI SB', but that will vary depending on your hardware.

Last edited by Skaendo; 10-30-2019 at 07:37 PM.
 
Old 10-31-2019, 01:25 AM   #15
recan
Member
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 34

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Skaendo View Post
If you are trying to get audio through HDMI, I recently went through this on 14.2.

I had to open up a terminal and do the following:
Code:
## Start alsamixer
    $ alsamixer

## Select audio device
    F6

## Fix auto-mute
    Auto-Mute -> Disabled

## Exit
    Esc
After that, audio through HDMI works fine for me.
You might need to restart application.

NOTE: Your audio device might not be defined as HDMI, mine was named 'HDA ATI SB', but that will vary depending on your hardware.
Thank you I tried this also but the problem is that in pavucontrol it said the same thing ...Unplugged also in alsa it showen as S/PDIF so Amd/Ati is recognized and video worked only problem of sound.

I m working on slackware live edition Kde5 just installed and sound via hdmi and the built in work fine ,let explore this Slackware option.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Issue with laptop using ATI Radeon RX 580. alex14641 Linux - Hardware 12 01-13-2019 04:51 PM
SOLVED: Problems to Internet Using Sierra Wireless AirCard 580 Dennola4 Linux - Newbie 1 01-28-2009 04:17 AM
SOLVED: Problems Connecting to Internet Using Sierra Wireless AirCard 580 Dennola4 Linux - Newbie 1 01-28-2009 04:17 AM
Installation problem with dlink 4 port server card DFE 580 TX s_maz Linux - Newbie 1 01-08-2009 01:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration