LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-20-2004, 03:08 PM   #16
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware 14.2
Posts: 1,266

Rep: Reputation: 56

I also have the SB Live and the module I load for it is snd-emu10k1
You might have to comment out the module you are loading or blacklist it in hotplug.
 
Old 11-20-2004, 04:13 PM   #17
SirrusX
LQ Newbie
 
Registered: Nov 2004
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: 0
Right so not to seem too stupid but what is required to load the module or blacklist hotplug?

And now for a incredibly stupid question.
In lilo.conf, the line about timeout =, it is the countdown for the bootloader isn't it?
Right, so why the isn't my computer counting down from 100 tenths of a seconds as it is the value I typed in for it, and not from 1200 tenths of a second?
 
Old 11-20-2004, 05:15 PM   #18
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Rep: Reputation: 31
SirrusX said:

"As I said I have a SBLive 5.1 soundcard but the card that alsamixer says I have is
a Brooktree Bt878, with the chip Bt87x."



I too have an SB live & a bt878 card. At one point I had to physically take out the
bt878 card becuase alsa thought my bt878 card was the primary sound device
and the SBlive was a secondary sound device (and it wasn't working).

If your sound is not working yet, I would physically remove the bt878, and then run:

alsaconfig
alsamixer
alsactl store

(to setup the SBlive).

Then make sure the sound works. If it does (which it should), shutdown, and then
put the bt878 card in. I'm sure there is a way to configure alsa to switch device 1
and 2, but I couldn't find it.

(p.s. - there is a switch you can add to the alsaconfig command to setup the 2nd device,
but I can't remember it - it really didn't help me anyway.)

good luck
-tw
 
Old 11-20-2004, 06:52 PM   #19
SirrusX
LQ Newbie
 
Registered: Nov 2004
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: 0
Right so I hope this means I'm making progress.

I took out the TV card and ran alsaconfig again. It still had my soundcard listed there but it gave me this reply.

Loading driver...
Loading ALSA mixer settings: /usr/sbin/alsactl restore
/usr/sbin/alsactl: load_state:1134: No soundcards found...
Setting default volumes...

But it also said the soundcard was ready for use. Anyway I ran alsamixer after that and it gave me this reply.

alsamixer: function snd_ctl_open failed for default: No such device

And I didn't hear any sound after this either.

Sirrus
 
Old 11-20-2004, 07:32 PM   #20
SirrusX
LQ Newbie
 
Registered: Nov 2004
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: 0
Oh, by the way at startup it now says something like this also

Loading ALSA kernel modules.
/lib/modules/2.4.26/kernel/sound/pci/emu10k1/snd-emu10k1.o.gz: init_module: No such device
/lib/modules/2.4.26/kernel/sound/pci/emu10k1/snd-emu10k1.o.gz: Hint: insmod errors can be caused by incorrect module
parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.26/kernel/sound/pci/emu10k1/snd-emu10k1.o.gz: insmod
/lib/modules/2.4.26/kernel/sound/pci/emu10k1/snd-emu10k1.o.gz failed
/lib/modules/2.4.26/kernel/sound/pci/emu10k1/snd-emu10k1.o.gz: insmod snd-emu10k1 failed


Then I have run into another problem I can't explain at all. When I sent my last post I was goig to shut down the computer. So when I was back in the terminal there was 5-6 lines with this.


(gedit:4103): GdkPixbuf-Critical **: filegdk-pixbuf-io.c: line769 (gdk_pixbuf_new_from_file): assertion 'filename != NULL'
failed

And the mouse couldn't be moved in any sensible way. It was on the top most line of the page copy-pasting sections at random. And the only thing I had done under that session was that I had used the web to write the previous post and copy-paste the text which the computer gave me when I ran alsaconf and alsamixer from a file using gedit.
I tried to reboot a couple of times to see if it would go away but it seems to be there every time now I log out from kde.

Sirrus
 
Old 11-20-2004, 08:36 PM   #21
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Rep: Reputation: 31
ok... sounds crazy... but:

I am guessing for now the bt878 is out of the computer.

1st:
(as root or SU'd) when you type:

lspci

do you get similar lines to these?:

00:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00:0a.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)

If so, slackware sees the card. good. go to "2nd".
if not, check the card. you got problems.


2nd:
type:

alsamixer

in the upper left corner it should say or something similar to:

Card: Sound Blaster Live!
Chip: Cirrus Logic CS4297A rev 4
Item: Master

if so, adjust volume and make sure its not muted. ESC, and then run "alsactl store" .
Start GUI and see if the sound works.

if not, run "alsaconf --log" . See what happens. If its bad, read /tmp/alsaconf.log
for details.

post results. gl
-tw
 
Old 11-20-2004, 10:10 PM   #22
DaWallace
Member
 
Registered: Feb 2004
Location: Southern Maine, United States
Distribution: Slackware Ubuntu Debian FreeBSD
Posts: 418

Rep: Reputation: 31
Quote:
Originally posted by rutty
I think even if you chose the IMPS/2 option during the install it doesn't set this up properly in xorg.conf. Maybe it's an install bug.
if I'm correct slack doesn't configure X at all during the install... leaving you to do it manually
 
Old 11-21-2004, 02:20 AM   #23
artofluke
Member
 
Registered: Sep 2003
Posts: 37

Rep: Reputation: 15
don't know if you got sound yet, but this is what always works on slack for me:

$: alsamixer
$: su
#: alsactl store


When you go into alsamixer press 'm' to unmute the master volume, and then turn it up with the arrow keys, hit esc and su and alsactl store to keep the settings.
 
Old 11-21-2004, 05:57 AM   #24
SirrusX
LQ Newbie
 
Registered: Nov 2004
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: 0
Right so lspci gave me something like this.

00:08.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

As for the alsamixer I don't even get into the program at the moment it only gives me a message like this.

alsamixer: function snd_ctl_open failed for default: No such device

and when ran alsaconf --log it still located Creative Labs blah blah EMU10k1.

then during the config it showed in the terminal this text.

Loading driver...
Loading ALSA mixer settings: /usr/sbin/alsactl restore
/usr/sbin/alsactl: load_state:1134: No soundcards found...
Setting default volumes...

And as for the log file /tmp/alsaconf.log which was supposed to be created I haven't seen of yet.
 
Old 11-21-2004, 08:06 AM   #25
SirrusX
LQ Newbie
 
Registered: Nov 2004
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: 0
Ups, I seem to accidentally have copy-pasted the wrong lines from lspci. This is maybe a bit more correct.

00:08.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00:08.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)

Sirrus
 
Old 11-21-2004, 08:17 AM   #26
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware 14.2
Posts: 1,266

Rep: Reputation: 56
post the output of lsmod. I wonder if you are still loading the wrong driver first and it is attaching to that device.
 
Old 11-21-2004, 09:45 AM   #27
SirrusX
LQ Newbie
 
Registered: Nov 2004
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: 0
Right, so this is what lsmod printed out.

Module Size Used by Not tainted
8139too 14376 1
mii 2272 0 [8139too]
crc32 2880 0 [8139too]
uhci 24444 0 (unused)
usbcore 59308 1 [uhci]
ntfs 51424 11 (autoclean)
ide-scsi 9328 0
emu10k1-gp 1352 0 (unused)
gameport 1420 0 [emu10k1-gp]
emu10k1 55852 0 (unused)
sound 55656 0 [emu10k1]
ac97_codec 12084 0 [emu10k1]
soundcore 3396 7 [emu10k1 sound]
agpgart 43940 0 (unused)

Sirrus
 
Old 11-21-2004, 10:26 AM   #28
rotvogel
Member
 
Registered: Oct 2003
Posts: 534

Rep: Reputation: 30
Quote:
Originally posted by SirrusX
Right, so this is what lsmod printed out.

Module Size Used by Not tainted
emu10k1 55852 0 (unused)
sound 55656 0 [emu10k1]
ac97_codec 12084 0 [emu10k1]
soundcore 3396 7 [emu10k1 sound]

Sirrus
Let's compare with this, I have an emu10k1 too and the alsa modules loaded are:
Code:
Module                  Size  Used by    Not tainted
snd-pcm-oss            38536   0
snd-mixer-oss          13592   1  [snd-pcm-oss]
snd-emu10k1            76424   8
snd-hwdep               4580   0  [snd-emu10k1]
snd-pcm                61864   3  [snd-pcm-oss snd-emu10k1]
snd-timer              14724   0  [snd-pcm]
snd-util-mem            1424   0  [snd-emu10k1]
snd-rawmidi            13540   0  [snd-emu10k1]
snd-ac97-codec         55664   0  [snd-emu10k1]
snd-seq-device          4176   0  [snd-emu10k1 snd-rawmidi]
snd                    34180   4  [snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-hwdep snd-pcm snd-timer snd-util-mem snd-rawmidi snd-ac97-codec snd-seq-device]
soundcore               3844   6  [snd]
snd-page-alloc          5164   0  [snd-mixer-oss snd-emu10k1 snd-hwdep snd-pcm snd-timer snd-rawmidi snd-seq-device snd]
You are still loading OSS drivers which are preventing alsa to load. So check the /etc/rc.d/rc.modules script if the emu10k1 module is loaded there and if so, comment the line. Also check the /etc/hotplug/blacklist to be sure the emu10k1 is uncommented. If you are using hotplug that will prevent the driver from being loaded automaticly by the hotplug script during boot.
 
Old 11-21-2004, 11:42 AM   #29
SirrusX
LQ Newbie
 
Registered: Nov 2004
Distribution: Slackware
Posts: 20

Original Poster
Rep: Reputation: 0
Yes I can finally hear sounds now. Thank you everybody. But if you still have some patience I still have some minor problems.

Ok so now the sound comes from the usual line-out or what ever it is called butIi would like to use the digital-out plug, because I have a amplifier and 5.1 speaker system connected to it. So the question is where do I change this?

Also of some reason there seems to be a ~1second delay in the sound.

And then I got some problem with logging out from kde. The mouse pointer stays on the top most line and can't be moved and it copy-pastes text randomly.

But thanks anyway.

Sirrus
 
Old 11-21-2004, 01:14 PM   #30
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Rep: Reputation: 31
"but I would like to use the digital-out plug."

By default its muted. type alsamixer. arrow over all the way to the right.

The item name is:
Item: SB Live Analog/Digital Output Jack [Off]

press 'm' to turn it on so the item now reads:
Item: SB Live Analog/Digital Output Jack

Don't forget "alsactl store"

That should do it.
(i think)


(it might not have the answer to your questoin,
but its a good page about EMU10K1.)
http://www.euronet.nl/~mailme/index4.html

Last edited by tw001_tw; 11-21-2004 at 01:22 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie problems... :( DARKGuy Mandriva 3 08-23-2005 10:48 PM
Not so newbie, but having X problems, just the same... polonius19 Linux - Newbie 3 08-12-2004 05:37 PM
Newbie having problems... Sirus Linux - Wireless Networking 3 06-02-2004 09:28 AM
assorted newbie problems howzat Linux - Newbie 8 09-09-2003 09:01 AM
newbie having device problems carlcromer Linux - Software 8 04-16-2001 12:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration